Author Topic: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack  (Read 40124 times)

0 Members and 1 Guest are viewing this topic.

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17392
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #50 on: July 14, 2017, 11:23:26 pm »
Today I ran the calibration procedure (again because the calibration data from yesterday somehow got lost). According to the log it seems the attenuator for channel 4 (which used to be on channel 2 which was defective) is a little bit off for the 1x (1.024) and 5x (5.092) settings.
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Offline Jwalling

  • Supporter
  • ****
  • Posts: 1240
  • Country: us
  • This is work?
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #51 on: July 14, 2017, 11:31:12 pm »
Today I ran the calibration procedure (again because the calibration data from yesterday somehow got lost). According to the log it seems the attenuator for channel 4 (which used to be on channel 2 which was defective) is a little bit off for the 1x (1.024) and 5x (5.092) settings.

A long-shot, but what if you config back to 54835A?
Jay

System error. Strike any user to continue.
 

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17392
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #52 on: July 15, 2017, 08:44:34 am »
I'm more inclined to swap the attenuators but the error is so small I don't think it is worth the effort. BTW this is a picture showing the input path (from the help file I found):


These are the calibration results
Code: [Select]
1)
Hf Attenuators:         Passed                                             
         0.991           4.968          10.002          50.212             

2)
Hf Attenuators:         Passed                                             
         0.996           4.988          10.009          50.148             

3)
Hf Attenuators:         Passed                                             
         0.994           4.985          10.000          50.114             

4)
Hf Attenuators:         Failed                                             
         1.014           5.092          10.000          50.000             
Channel 4 is clearly different but the error is less than 2%. Maybe channel 2 got overloaded which damaged the attenuator and destroyed the ADC hybrid.
« Last Edit: July 15, 2017, 08:51:27 am by nctnico »
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Offline Jwalling

  • Supporter
  • ****
  • Posts: 1240
  • Country: us
  • This is work?
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #53 on: July 15, 2017, 01:15:33 pm »
I have an entire ACQ board (unknown status, missing all the A/D converters and has one attenuator module which is known to be bad) Do you think you could use any parts from it? You could have the attenuator module for the cost of shipping.
Some of those Teledyne relays have resistor(s) inside, maybe the one that was overloaded increased the resistance on one of them?
« Last Edit: July 15, 2017, 01:17:32 pm by Jwalling »
Jay

System error. Strike any user to continue.
 

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17392
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #54 on: July 15, 2017, 02:21:03 pm »
Tempting but I think I'll leave it like it is for now. Also shipping costs may be getting close to buying a new relay if one of them turns out to be bad. I see no obvious resistive divider structures so I guess the attenuation network is inside the relay.
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Online TheSteve

  • Supporter
  • ****
  • Posts: 2962
  • Country: ca
  • GHz
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #55 on: July 15, 2017, 02:34:39 pm »
Yep, those are Teledyne attenuators. Far from cheap if you need replacements.
VE7FM
 

Online TheSteve

  • Supporter
  • ****
  • Posts: 2962
  • Country: ca
  • GHz
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #56 on: July 27, 2017, 10:02:53 pm »
Just bought a 54845a so I can join the repair club.
VE7FM
 

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17392
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #57 on: July 27, 2017, 10:19:28 pm »
Just bought a 54845a so I can join the repair club.
Looking forward to read how it goes! I had a bit of a play with mine last week and it has some nice features.
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Offline Neganur

  • Supporter
  • ****
  • Posts: 1114
  • Country: fi
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #58 on: July 28, 2017, 04:22:14 pm »
This one does:
www.ebay.com/itm/Hot-Tested-mSATA-to-2-5-PATA-IDE-Enclosure-Adapter-Case-With-Screws/201268830337

PS, thanks for this! You linked this already quite a while ago in another thread and I bought one together with a Kingston SSD for my E8357A.
Finally got around to clone the drive this evening and everything works as expected :)
 

Offline Tony_G

  • Frequent Contributor
  • **
  • Posts: 581
  • Country: us
  • Checkout my old test gear channel (link in sig)
    • TGSoapbox
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #59 on: July 30, 2017, 10:35:43 am »
Just saw this come up on an auction site and thought it might help, if the price is right of course:

http://www.go-dove.com/en/auction/view?id=12334874

No relationship with the site or seller, except that I bought pieces through the auction site before.

Online TheSteve

  • Supporter
  • ****
  • Posts: 2962
  • Country: ca
  • GHz
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #60 on: August 06, 2017, 12:04:07 am »
My 54845A arrived yesterday, picked it up and cracked it open today.
Many of the cables were disconnected - once I got them reconnected and it looked safe I powered it up. It was advertised as having no display, and that was correct, no video at all on the LCD, just a backlight. I connected an external monitor and it gets to the BIOS screen. At the same time I could hear the harddrive clunking like mad - very much dead. I found another 20 gig HD and connected it up. The scope had the original pouch on top and inside was the original floptical recovery media. I removed the floptical drive cleaned it and reinstalled. The disks are from 1999 but so far are still working. Recovery is in progress.

Updates as they happen.

edit - only had a PS2 keyboard so I made an adapter using an 8 PIN din with pins removed and a PS2 socket. Got to 25% recovery and the floptical drive doesn't sound very healthy but is still going.

edit2 - The sucker has an American Megatrends Atlas PCI-III motherboard, a K6-2-/300 CPU and a whopping 64 megs of ram!

edit3 - recovery succeeded and self tests pass. The HD was making too much noise though so I dug out a couple IDE 2.5 inch flash drives, one of them seems to work fine so I am recovering to it.

Once I determine how much is working I will be pulling the front off to have a look at the LCD.
« Last Edit: August 06, 2017, 01:31:21 am by TheSteve »
VE7FM
 

Online TheSteve

  • Supporter
  • ****
  • Posts: 2962
  • Country: ca
  • GHz
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #61 on: August 06, 2017, 04:04:05 am »
Well this is encouraging:

VE7FM
 

Online TheSteve

  • Supporter
  • ****
  • Posts: 2962
  • Country: ca
  • GHz
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #62 on: August 06, 2017, 04:15:26 am »
Pulled the entire front off the scope. There was a place to push the autoprobe front panel off but the location doesn't match any pictures posted in this thread or the service manual.
After getting the front off I determined the ribbon cable wasn't even plugged into the LCD panel. There were also many missing screws. I reconnected the LCD and am very pleased to see it come to life.
Now I bought this as a parts unit with no display, no other info was known other then it "appeared complete". Several of the case screws were missing in the picture. It was obviously taken apart for some reason and it looks like someone shoved it back together in hurry being so much was disconnected internally.

So far many screws and one of the BNC locking nuts is also missing from the front. I did notice some of the vertical encoders do miss/jump steps - maybe that was the original fault someone was planning to work on and not the LCD panel itself? They are all covered in heavy dust and likely need a good cleaning.

I do see a little pulsing/flicker on the LCD panel as it is warming up - maybe it will get worse, or there is a power supply issue.
VE7FM
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 15689
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #63 on: August 06, 2017, 04:33:10 am »
I do see a little pulsing/flicker on the LCD panel as it is warming up - maybe it will get worse, or there is a power supply issue.
On the screen info or the backlight ?
Avid Rabid Hobbyist
 

Offline Tony_G

  • Frequent Contributor
  • **
  • Posts: 581
  • Country: us
  • Checkout my old test gear channel (link in sig)
    • TGSoapbox
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #64 on: August 06, 2017, 05:19:09 am »
Nice, glad to hear it seems to basically work.

As an aside, I've wondered how HP expected you to clip the probe ground to gnd socket for compensation. Seems really easy for it to pop off.

Online TheSteve

  • Supporter
  • ****
  • Posts: 2962
  • Country: ca
  • GHz
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #65 on: August 06, 2017, 06:54:01 am »
Well no flicker recently, may have been a bad connection to one of the backlite tubes. I have reassembled the unit for now and given it a quick cleaning. There is one screw barely holding the front controls in. I will have to order some longer screws.
Most of the encoders are behaving now but one or two need further cleaning. I tried out a 1152A 2.5 GHz active probe and it calibrates fine on each channel. I will have to find a way to upgrade the software - this MB has no USB. And I don't have any spare magneto optical media floating around. It was nice to find the original Win98 license and restore media in the top pouch - that has gotta be quite uncommon.

I am trying out 8 GS/s mode, here is a 1.5 GHz 1 Vpp signal. If I go higher in frequency the attenuation isn't too bad but before 1.6 GHz triggering stops.

edit - took a while but I finally found the proper length M3x0.5 26mm screws in my collection (20 year old radio control parts). Also found some screws to use on the case so the scope is no longer missing any screws. The rotary encoders were also cleaned a second time and seem pretty good now.
« Last Edit: August 06, 2017, 10:45:14 pm by TheSteve »
VE7FM
 

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17392
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #66 on: August 06, 2017, 07:36:36 am »
Dang! I wish I bought that one! I guess the previous owner didn't had any knowledge about PCs and started pulling cables.
Does it also pass it's self calibration?
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Online TheSteve

  • Supporter
  • ****
  • Posts: 2962
  • Country: ca
  • GHz
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #67 on: August 06, 2017, 07:41:48 am »
Dang! I wish I bought that one! I guess the previous owner didn't had any knowledge about PCs and started pulling cables.
Does it also pass it's self calibration?

Yes, self test and self calibration both pass. So far I am very impressed, I have less then $290 USD into it including the shipping.
Guess I can't complain too much that it only had 3 feet. For the moment it has the two front feet installed.

Amazing how much hardware is in it compared to my MSOX3000T series scope...
« Last Edit: August 06, 2017, 07:43:53 am by TheSteve »
VE7FM
 

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17392
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #68 on: August 06, 2017, 04:09:13 pm »
Dang! I wish I bought that one! I guess the previous owner didn't had any knowledge about PCs and started pulling cables.
Does it also pass it's self calibration?
Yes, self test and self calibration both pass. So far I am very impressed, I have less then $290 USD into it including the shipping.
Oh, yes please RUB IT IN!  ;)
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Online TheSteve

  • Supporter
  • ****
  • Posts: 2962
  • Country: ca
  • GHz
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #69 on: August 06, 2017, 07:03:05 pm »
Here are a couple shots showing SWR (return loss) of the input. I don't know if this would change at all if the scope was rejumpered to a 54846A etc. It is interested to note it uses 4 different ranges, the MSOX3000 series uses only two.

20mV/div
50mV/div
200mV/div
500mV/div



VE7FM
 

Online TheSteve

  • Supporter
  • ****
  • Posts: 2962
  • Country: ca
  • GHz
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #70 on: August 07, 2017, 10:56:19 pm »
Decided I should try upgrading from version 3.50 today.
As nctnico has already mentioned the built in upgrade tool only wants to read from the Magneto Optical drive. He used a hex editor to change the path so he could read the upgrade files from a USB drive. My scope has no USB ports so I tried something else.
I unpacked the 4_3_upg upgrade package on my desktop and copied the files directly to the scopes hard drive. I then booted the scope, killed the scope app and used explorer to copy the files to c:\scope\upgrade\scope\temp\
Once the files are copied you can run HP548UPG.exe directly from that directory and it will perform the upgrade.
With version 4.3 running I removed all of the files from the upgrade directory and repeated the process with the 4.5 update.
It was a pretty hassle free way to upgrade the scope. Going from version 3.5 to 4.3 easily doubles the boot time of the scope(3.5 direct to 4.5 might not as it will skip the web features). I suppose that is the tradeoff for adding the built in webserver with webcontrol. If nothing else it makes it easy to grab screen shots.

VE7FM
 
The following users thanked this post: nctnico

Offline Jwalling

  • Supporter
  • ****
  • Posts: 1240
  • Country: us
  • This is work?
Jay

System error. Strike any user to continue.
 

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17392
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #72 on: August 12, 2017, 10:18:03 am »
This just showed up if you're interested nctnico.
http://www.ebay.com/itm/Agilent-HP-Keysight-54845-66502-Attenuator-for-54845A-54845B-54835A-T7-B17-/182713390428?epid=12003971610&hash=item2a8a91155c:g:a3AAAOSw8VJZjg9C
Interesting but I think a new relay may be cheaper and there is also the question whether the relays aren't worn on an attenuator from Ebay.
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Offline eurofox

  • Supporter
  • ****
  • Posts: 835
  • Country: be
    • Music
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #73 on: August 17, 2017, 04:43:59 pm »
I joint the club, just won a dead 54845A, nice cosmetic with install disk, manuals, original keyboard and mouse.
eurofox
 

Offline Tony_G

  • Frequent Contributor
  • **
  • Posts: 581
  • Country: us
  • Checkout my old test gear channel (link in sig)
    • TGSoapbox
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #74 on: August 17, 2017, 07:07:47 pm »
I joint the club, just won a dead 54845A, nice cosmetic with install disk, manuals, original keyboard and mouse.

Nice - Look forward to seeing the photos and the story of bringing it back to life.


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf