Author Topic: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack  (Read 40153 times)

0 Members and 1 Guest are viewing this topic.

Offline JanNousiainen

  • Contributor
  • Posts: 25
  • Country: fi
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #75 on: August 22, 2017, 02:07:09 pm »
Yay, I will join the club too :)

Just got a broken 54845A from my employer for free. It was working well and was even calibrated recently but then all channels started to show signal being over the vertical range and there was three FAIL's on self test and on that point the scope program just crashed. Original mouse, keyboard and mouse mat follows the scope.

Symptoms sounds pretty similar as in here:

http://www.dasarodesigns.com/projects/fixing-an-hp-agilent-54845a-infinium-oscilloscope/

With a bit of luck this could actually be fixed and then I have pretty impressive scope compared to what I have now :)
"I have approximate knowledge of many things."
 

Offline Tony_G

  • Frequent Contributor
  • **
  • Posts: 581
  • Country: us
  • Checkout my old test gear channel (link in sig)
    • TGSoapbox
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #76 on: August 22, 2017, 05:19:05 pm »
Yay, I will join the club too :)

Just got a broken 54845A from my employer for free.

Good luck with it - If you need it I have the software hosted further up in the thread I think. If you can't find the link let me know and I'll repost.

TonyG

Offline JanNousiainen

  • Contributor
  • Posts: 25
  • Country: fi
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #77 on: August 23, 2017, 07:58:31 am »
Had time to snap few photos:

20935000_10155501727973463_374710227212071001_o by Jan Nousiainen, on Flickr

21014096_10155501726808463_3357537562277012915_o by Jan Nousiainen, on Flickr

21014043_10155501734243463_7132642189203810817_o by Jan Nousiainen, on Flickr

20988433_10155501729338463_4532608220713741416_o by Jan Nousiainen, on Flickr

K6-200 CPU, 16 MB of RAM, 1,3 GB HDD and Windows 95... You cannot get lower specs even if you tried I think :P

Most obvious things to upgrade, RAM and CPU? Will this unit run Windows 98 straight away?
"I have approximate knowledge of many things."
 

Online zucca

  • Supporter
  • ****
  • Posts: 1947
  • Country: it
  • EE meid in Itali
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #78 on: August 23, 2017, 08:30:54 am »
JanNousiainen never turn it on, without taking it apart first.  :-/O

Looks like you have some adventure in front of you with that scope, please keep us posted.
Can't know what you don't love. St. Augustine
Can't love what you don't know. Zucca
 

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17407
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #79 on: August 23, 2017, 08:38:56 am »
I'd fix/diagnose the problems first and then start thinking about upgrading.
I think you have an older model so you have to investigate what kind of processor and memory the motherboard will work with.
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Offline Tony_G

  • Frequent Contributor
  • **
  • Posts: 581
  • Country: us
  • Checkout my old test gear channel (link in sig)
    • TGSoapbox
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #80 on: August 23, 2017, 02:53:31 pm »
Just adding this here in case it's useful to you:

you can launch scope.exe using the service command  " scope.exe /service" that gives extra options in the self test menu where you can set attenuator click and othe roptions

Also you should be able to use the link to the scope software to upgrade to Win98 - I'm not sure what the experience will be like but I'd check the PDF that describes the process and limitations first.

TonyG

Offline eurofox

  • Supporter
  • ****
  • Posts: 835
  • Country: be
    • Music
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #81 on: August 23, 2017, 08:38:15 pm »
My scope on the way to my home, should be here in about 2 weeks.



eurofox
 

Offline JanNousiainen

  • Contributor
  • Posts: 25
  • Country: fi
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #82 on: August 24, 2017, 09:45:03 am »
Ran the scope app with /service option and got boatload of new fails, too many to mention. Opened the case to have a quick look inside but saw nothing obvious.

Well, atleast the external display works :)

IMG_20170823_220033 by Jan Nousiainen, on Flickr

Info screen:

IMG_20170823_220134 by Jan Nousiainen, on Flickr

AMI Atlas III motherboard, propably oldest used in Infiniums?

IMG_20170823_225438 by Jan Nousiainen, on Flickr

Trying to make room on my desk to start proper inspection, supply voltages and bypassing attenuators by feeding signal straight to hybrids etc.

What needs to be removed to get the attenuator modules out?
"I have approximate knowledge of many things."
 

Offline JanNousiainen

  • Contributor
  • Posts: 25
  • Country: fi
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #83 on: August 30, 2017, 12:35:31 pm »
Still cleaning desk (and installing more sockets to lab etc) to be able to start proper debugging  >:(

Being overly optimistic, ordered some 64 MB of RAM in addition of current 16 MB to allow Windows 98 to run which is required to run later SW. Where can I find the update images/files? I think I need IDE CD-ROM too?
"I have approximate knowledge of many things."
 

Offline Tony_G

  • Frequent Contributor
  • **
  • Posts: 581
  • Country: us
  • Checkout my old test gear channel (link in sig)
    • TGSoapbox
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #84 on: August 30, 2017, 03:19:49 pm »
In case you need it I saved a copy of the software folders from the Keysight FTP Server (they went missing last time I checked there)

https://1drv.ms/f/s!Amqar8_XQ9Uzj6YhN1xHdM8tQdKMOA

TonyG

I used a parallel port CD-ROM drive I bought from eBay ("MicroSolutions Backpack Parallel Port CD-ROM Drive", I paid $14 for it but I took a quick look and they seem to be much more expensive now). Apparently you can hook up an IDE CD ROM drive on the secondary IDE channel though so I'd try that path, especially if you have one laying around already.

TonyG

Offline JanNousiainen

  • Contributor
  • Posts: 25
  • Country: fi
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #85 on: August 30, 2017, 10:52:13 pm »
Holy freaking crap!  :o

I followed through this article and did some measurements: http://www.dasarodesigns.com/projects/fixing-an-hp-agilent-54845a-infinium-oscilloscope/

And guess what? In my scope the -3.1V supply shows +0.8V, same as in his scope! So it is probably failed opamp in my scope too!  Could it really be so simple? ^-^

Going to order few LT2726 IC's ASAP...
"I have approximate knowledge of many things."
 

Offline JanNousiainen

  • Contributor
  • Posts: 25
  • Country: fi
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #86 on: August 31, 2017, 06:36:30 am »
In case you need it I saved a copy of the software folders from the Keysight FTP Server (they went missing last time I checked there)

https://1drv.ms/f/s!Amqar8_XQ9Uzj6YhN1xHdM8tQdKMOA

TonyG

I used a parallel port CD-ROM drive I bought from eBay ("MicroSolutions Backpack Parallel Port CD-ROM Drive", I paid $14 for it but I took a quick look and they seem to be much more expensive now). Apparently you can hook up an IDE CD ROM drive on the secondary IDE channel though so I'd try that path, especially if you have one laying around already.

TonyG

Thank you for the link :) I think I will try the IDE CD-ROM first, could be easier and faster to source one of those. Or, I do have few already but they are in different country than me...
"I have approximate knowledge of many things."
 

Offline JanNousiainen

  • Contributor
  • Posts: 25
  • Country: fi
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #87 on: August 31, 2017, 06:48:05 am »
Now a stupid Infinium noob question  :P

Do the upgrades only contain the scope SW and not OS? Looking at the upgrade file sizes that might be the case? I have not yet upgraded SW so I don't know.

If updates only contain scope SW and it is OS independent, can I just install Windows XP to my scope (now Windows 95) and then install upgrade on that? Provided that my ancient HW is able to run XP that is.
"I have approximate knowledge of many things."
 

Online TheSteve

  • Supporter
  • ****
  • Posts: 2962
  • Country: ca
  • GHz
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #88 on: August 31, 2017, 07:33:15 am »
The upgrades I have used are scope applications only. Based on what I've read I'd stick with Win98.
VE7FM
 

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17407
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #89 on: August 31, 2017, 09:49:04 am »
I tried to install XP but the problem is that the drivers for the acquisition card are not available. The Windows98 drivers won't work on XP because XP is completely different when it comes to drivers.
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Online zucca

  • Supporter
  • ****
  • Posts: 1947
  • Country: it
  • EE meid in Itali
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #90 on: August 31, 2017, 12:42:06 pm »
same old story, only bad SW can stop good HW EE
Can't know what you don't love. St. Augustine
Can't love what you don't know. Zucca
 

Online Howardlong

  • Super Contributor
  • ***
  • Posts: 4705
  • Country: gb
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #91 on: August 31, 2017, 01:50:49 pm »
I tried to install XP but the problem is that the drivers for the acquisition card are not available. The Windows98 drivers won't work on XP because XP is completely different when it comes to drivers.

Do you know what the VIDs/PIDs are for the acq card? Maybe in the range 15BC:0500 to 15BC:0507?
 

Offline Tony_G

  • Frequent Contributor
  • **
  • Posts: 581
  • Country: us
  • Checkout my old test gear channel (link in sig)
    • TGSoapbox
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #92 on: August 31, 2017, 03:58:48 pm »
The full software should be in there - Drill into the 54845A folder and you'll see a bunch of folders marked XX_recovery - Those should have the full OS versions in them - I'm not sure how it works out what the OS to install is but the file sizes are right for that.

My Scope was Win98 and I started from the 3_5_recovery image and then did the 4_x updates.

TonyG

Offline eurofox

  • Supporter
  • ****
  • Posts: 835
  • Country: be
    • Music
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #93 on: August 31, 2017, 04:09:47 pm »
I should get mine tomorrow, I will post my repair progress here if ntcnico don’t mind that we pollute he’s post but I think it is a good idea to keep the repair of the same instrument in one post.  :horse:
eurofox
 

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17407
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #94 on: August 31, 2017, 06:45:09 pm »
No objections from me. It's Dave's forum anyway  :P
Looking forward to what you find!
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Offline JanNousiainen

  • Contributor
  • Posts: 25
  • Country: fi
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #95 on: August 31, 2017, 09:48:13 pm »
Holy freaking crap!  :o

I followed through this article and did some measurements: http://www.dasarodesigns.com/projects/fixing-an-hp-agilent-54845a-infinium-oscilloscope/

And guess what? In my scope the -3.1V supply shows +0.8V, same as in his scope! So it is probably failed opamp in my scope too!  Could it really be so simple? ^-^

Going to order few LT2726 IC's ASAP...

Hmmmmm, also +0.85V regulator output looks funny, Vout is 3.9V. Perhaps good idea to replace that one too, type is LT1086CM. Not sure what the ADJ pin should be at, mine is about +2.5V.
"I have approximate knowledge of many things."
 

Offline eurofox

  • Supporter
  • ****
  • Posts: 835
  • Country: be
    • Music
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #96 on: September 05, 2017, 01:09:32 pm »
I got finally my scope today.  :-+

Very big surprise when power up, start …. Boot ….. no error …. Pass al tests.  :-DD :-+ :-+ :popcorn:

It was sold “as is” with no warranty, was sold by someone who know nothing about instruments and buy from closing business ….  :horse:

I got one brand new probe with it. Got the original installations disks still sealed.   :bullshit:

After cleaning up it is in a near mint condition, only minor problem I have to replace the legs but this is not a problem.  :wtf:


« Last Edit: September 05, 2017, 01:11:30 pm by eurofox »
eurofox
 

Offline nctnico

  • Super Contributor
  • ***
  • Posts: 17407
  • Country: nl
    • NCT Developments
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #97 on: September 05, 2017, 02:12:06 pm »
@eurofox:  Great find :-+ sometimes people can get lucky!
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Offline Tony_G

  • Frequent Contributor
  • **
  • Posts: 581
  • Country: us
  • Checkout my old test gear channel (link in sig)
    • TGSoapbox
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #98 on: September 05, 2017, 02:39:00 pm »
I've always wondered how HPAK expected the probe ground to connect to the grounding plug given that they have alligator clips on the probes and a socket for the ground....

Anyway, glad to see you scored there - Hopefully Jan does the OpAmp swap and it starts working too.

TonyG

Online Jwalling

  • Supporter
  • ****
  • Posts: 1240
  • Country: us
  • This is work?
Re: Agilent 54835A scope (4 channel 1GHz / 4Gs/s) repair & uphack
« Reply #99 on: September 05, 2017, 03:35:02 pm »
I got finally my scope today.  :-+

Very big surprise when power up, start …. Boot ….. no error …. Pass al tests.  :-DD :-+ :-+ :popcorn:

Does it pass the calibration as well?
Jay

System error. Strike any user to continue.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf