Author Topic: Array 3720A Electronic Load - Firmware Update  (Read 1098 times)

0 Members and 1 Guest are viewing this topic.

Offline motocoder

  • Supporter
  • ****
  • Posts: 769
  • Country: us
  • Electrical Engineer
Array 3720A Electronic Load - Firmware Update
« on: September 26, 2015, 10:30:56 am »
Second try here, hoping somebody knows how to get the firmware updater working on this thing. I had a very confusing, unfruitful conversation with Array, specifically with a lady there who just does not speak English very well, and ultimately she just stopped responding to my questions. I never could figure out what she was saying...

When I try to update the firmware using their update tool, I first get an error telling me that the device version is newer than the firmware (it isn't), then when I hit OK, there is a very long pause, followed by a message telling me to check the communications. I do see that it's tried and communicate with the load, because the Remote light is lit.

I thought maybe it was a Windows version thing, so I set up Windows 7 32-bit on a disk partition, booted into that, and tried it there, but no luck.

I opened the unit up, and I see what looks to be a JTAG connector next to the micro (an atmega128A). I wonder if the easier route might be to just connect that up to my JTAGICE3, and program the micro that way. The files they supply are marked *.bin, though, so I am not 100% sure it's a file I can program directly that way.

Any help, much appreciated.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf