Author Topic: DS Logic  (Read 1862 times)

0 Members and 1 Guest are viewing this topic.

Offline wd5gnr

  • Regular Contributor
  • *
  • Posts: 179
DS Logic
« on: June 15, 2015, 11:26:51 pm »
I bought a DS Logic off eBay. Good specs. 100MHz on 16 channels with an adjustable threshold. 400Mhz on 4 channels. Custom version of Sigrok.

I thought I'd share a few notes (I was going to add them to the Crowdsourced topic, but it was 120 days old so..)

On Linux, you DO need to build all the pieces because apparently the stock versions aren't all you need (in particular, libsigrokdecode needed to be the latest).

Also, if you don't want to run as root, you need the following in /etc/udev/rules.d/99-dslogic.rules


## DSLogic
# 2a0e:0001
ATTRS{idVendor}=="2a0e", ATTRS{idProduct}=="0003", ENV{ID_MM_DEVICE_IGNORE}="1"
ATTRS{idVendor}=="2a0e", ATTRS{idProduct}=="0003", ENV{MTP_NO_PROBE}="1"
SUBSYSTEMS=="usb", ATTRS{idVendor}=="2a0e", ATTRS{idProduct}=="0003", GROUP="plugdev", MODE="0660"


I have found reference that it could be idProduct is 1, but on mine, it is 3 (I bet 1 is the old one and 3 is the pro). lsusb will tell you. Restart udev or reboot and if you are in the plug dev group you should be ok.

Pretty good quality. Not sure the little grounded cables would actually handle anything really going at 400MHz, but honestly a 400MHz LA is only going to go around 200MHz and probably a lot less. So good enough for most of what I do these days.

Just to try out 400Mhz, I picked up a serial line and an I2C channel off a demo board.



Yeah, 400Mhz is way overkill for this, but it works fine at lower rates too.

Not sure why but the search function doesn't appear to work. Probably operator error. Works now for no apparent reason, so apparently operator error.

I don't see that the TO pin (trigger out?) works. I also have not tried it with an external clock yet.

« Last Edit: June 16, 2015, 01:26:39 am by wd5gnr »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf