Author Topic: DS1054Z Ultra Sigma USB-TMC not finding  (Read 3208 times)

0 Members and 1 Guest are viewing this topic.

Offline Stretto

  • Newbie
  • Posts: 2
  • Country: bo
DS1054Z Ultra Sigma USB-TMC not finding
« on: June 24, 2017, 03:11:06 am »
Hi, I just bought a new DS1054Z a few days ago and the first thing I did was unlock it using the methods online that generate a serial to unlock all the features. The scope seems to work find but I have not put it through any real tests(calibrate the probes, simple tests, etc).

I installed the software as I'm more of a software oriented person. I installed Ultra Sigma and the various apps for it found on the rigol site. I plugged in the USB cable from the PC(a high new PC) and made sure computer was chosen from the IO/USB settings on the scope.

Ultra Sigma never finds the scope. I've rebooted several times, etc but it never finds it. I've installed the IVI driver etc. I will attempt to uninstall everything tomorrow and start fresh, and possibly try the lan method to see if that works(But I don't wanna use that as it isn't conducive to my setup).

Hopefully someone knows something that might work? It seems like it's suppose to be something relatively straight forward, but it's not.

Offline JohnPen

  • Regular Contributor
  • *
  • Posts: 240
  • Country: gb
Re: DS1054Z Ultra Sigma USB-TMC not finding
« Reply #1 on: June 24, 2017, 04:28:43 pm »

I have had the same problem recently after a long gap.  Originally it worked fine last year but now it doesn't. It still worked OK via LAN but didn't work on USB. After a fair bit of digging round it seems to be a missing driver perhaps Win10 removed it or maybe an update.  Searching for a driver update on the internet Win10 cannot find one.  Now the solution below:

You need to reload NIVISA Runtime.  It can be found on the Batronix website.   The link is highlighted under the Ultra Sigma Software heading.

Download it and install it.  Be warned in my case it suggested a 'restart' on completion.  This resulted in my machine throwing up a blue screen saying error and collecting info which on reaching 100% it then stuck there.  No response to anything so I had to power down by pulling the plug out. 

On rebooting everything came up OK and Ultra Sigma now see's my unlocked DS1054Z as it used to.  Hopefully this will solve your problem as well.


Offline CustomEngineerer

  • Frequent Contributor
  • **
  • Posts: 459
  • Country: us
Re: DS1054Z Ultra Sigma USB-TMC not finding
« Reply #2 on: June 24, 2017, 10:16:04 pm »
I would also suggest trying different usb cables. First time I hooked my Rigol scope to my computer through USB, the computer recognized it and auto installed drivers for it, but thats all I could get it to do. UltraSigma and any other program I tried would not talk to it. Finally discovered that it was a crappy USB cable that I had used because it was the longest I had (and had bought very cheaply). I tried using another cable and it worked with no issues.

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo