Author Topic: keithley 195 option repair  (Read 271 times)

0 Members and 1 Guest are viewing this topic.

Offline tjl0023

  • Newbie
  • Posts: 1
  • Country: us
keithley 195 option repair
« on: May 13, 2019, 07:02:53 am »
I purchased a keithley 195 with the option installed but the amps range only works on the 20uA and 100uA range. All of the other amp ranges show "-oflo". The adc works fine so i have a feeling its just something with the range switching but i cant find any info about it. any suggestions on what to do next?
- Taylor L.
 

Offline lowimpedance

  • Super Contributor
  • ***
  • Posts: 1057
  • Country: au
  • Watts in an ohm?
Re: keithley 195 option repair
« Reply #1 on: May 13, 2019, 09:31:04 am »
 The online manual has the schematic of the option and also in the maintenance section there are tables showing which relays / FET's that are used for each range/function etc.
Do the ACV ranges work correctly or do they fail in a similar pattern ?.
The odd multimeter or 2 or 3 or 4...or........can't remember !.
 

Offline TurboTom

  • Frequent Contributor
  • **
  • Posts: 574
  • Country: de
Re: keithley 195 option repair
« Reply #2 on: May 13, 2019, 09:45:49 am »
I can't tell for sure in your case but I recently fixed a 195A that had several of the analog multiplexer JFETs blown. These seem to be quite fragile actually. I ended up replacing all of them (Q102~104, Q107~114, Q121, Q122). Some are selected types (Q121,Q122) and I did my best to find failrly good matches to these  -- one of the original transistors was still okay so I was able to measure the on-resistance.

If the DC ranges on your 195 are working correctly, you may want to have a look at Q502 and Q503 and maybe also Q505 and Q506 on the AC option board.

Good luck,
Thomas
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf