Products > Test Equipment

EEVblog 121GW Multimeter Issues

(1/273) > >>

bryanp:
Hi Dave (and everyone else),

I have done a search on the forums for a dedicated 1212GW support thread but could not find one, apologies if I have missed it.

I just received my 121GW and it is awesome. I was looking over the set up menu to set the date and time etc but am having a few issues.

1. If I change the year (it defaults to 2016), the day, month, hour or minutes the setting does not stick/save. Changing (and having them save) other set up menu items works fine. I have tried cycling the power on the meter after making a change but that has no effect.

2. Is it possible to disable the beep please, at least for button presses and any time the rotary switch is changed? The beep is loud which is great for continuity etc but after trying to figure out how to change the date/time it is starting to annoy.

3. There appears to be a set up menu option between item 7 (Hour-Minute) and item 8 Logging Interval. This set up menu item is not mentioned in the manual, and it is present on at least the Low Z, V and Ohms ranges. The set up menu item consists of 5 digits, it seems to default to 5 zeros but these numbers can be changed from 0-9 and once you hold down the setup button to edit this option you can use the set up button to switch between each digit. I do not know what these numbers/digits mean. I changed the last digit (on the right hand side) to a value and saved it but this seemed to have no effect.

4. An erratum for the manual in regards to changing the Hour-Minute and Month-Day set up menu items should include some mention of a long setup button press to switch between month and day for instance and a short setup button press to save and move on. This functionality seems to be the opposite to the five zeros set up menu item (mentioned above) as a short press switches between zeros/digits and a long press saves and switches to the next set up menu item.

Please let me know if I am being an idiot and have missed something obvious.

Thanks and the meter really is a beast.

EEVblog:
This is a thread for discussion of bugs and issues found with the 121GW meter.
Please state your version number.

exe:
Hi Dave!

On my "U-1.01" low z doesn't work until voltage reaches 11V. Then it works fine (but shows only one digit after dot (like 11.3V), intentionally low resolution?).

Update rate is like 0.5samples/s. Tried to change "In x" (by default it's ln 0), no luck.

amspire:

--- Quote from: bryanp on January 08, 2018, 12:21:24 am ---1. If I change the year (it defaults to 2016), the day, month, hour or minutes the setting does not stick/save. Changing (and having them save) other set up menu items works fine. I have tried cycling the power on the meter after making a change but that has no effect.

--- End quote ---
Just got my meter today, and I am very impressed. Calibration is pretty much spot on.

The time/date works fine on my meter (version U-1.01). It arrived with the correct time and it seems to keep correct time even after changing the batteries. 

After changing a time/date field, are you pressing the setup button for about two seconds until the beep to save the change?

DrGeoff:

--- Quote from: bryanp on January 08, 2018, 12:21:24 am ---1. If I change the year (it defaults to 2016), the day, month, hour or minutes the setting does not stick/save. Changing (and having them save) other set up menu items works fine. I have tried cycling the power on the meter after making a change but that has no effect.

--- End quote ---

Confirmed. I have 2072-06-12 as the default date and changing it does not save.
Time does not save correctly either.


--- Quote from: bryanp on January 08, 2018, 12:21:24 am ---2. Is it possible to disable the beep please, at least for button presses and any time the rotary switch is changed? The beep is loud which is great for continuity etc but after trying to figure out how to change the date/time it is starting to annoy.

--- End quote ---

Yes please!

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version