Author Topic: [SOLVED] BM235 backlight issue pressing around HOLD button (NOT the noise issue)  (Read 1158 times)

0 Members and 1 Guest are viewing this topic.

Offline Gywhard

  • Newbie
  • Posts: 2
  • Country: it
Hello everyone, this is my first post in this forum.
My name is Andrea, i come from Italy. I'm a Physics student, electronics enthusiast, and ham radio operator.
I just got today the sweet little Brymen BM235, EEVBlog edition of course!
The meter seems to work like a treat, except for this little quirk I found:
Since a picture is worth a thousand words, I figured a video would be even better.
It's 21s long: https://youtu.be/Z6IF9wOUrw0
I noticed it by accident while testing the Delta function. Basically if I press on the plastic enclosure around the HOLD button area it can make the backlight go away

Has anyone got any guesses what the issue might be? Could it be some sort of connection problem? Could it be the LCD itself?
« Last Edit: March 09, 2017, 05:06:22 pm by Gywhard »
 

Offline iainwhite

  • Supporter
  • ****
  • Posts: 303
  • Country: us
  • Measure twice...
Welcome to the forum!
I tried to make my BM235-EEV do the same thing and it didn't - the backlight stayed on when I pressed several places in that area.

Maybe you have a poor contact or something similar?
Maybe Dave will see your post and reply - might even turn into a video if he can reproduce it!
 

Offline Gywhard

  • Newbie
  • Posts: 2
  • Country: it
Hey! Check THIS out!
I seem to have found the solution:
What I did was I took it APAAAAAAART, (really didn't like to desolder the two wires connecting the main board to the protection board), and noticed the backlight module was spring-connected to the board. Maybe one of the springs was a bit bent, or maybe the module itself wasn't properly seated, I don't know. I put a dab of contact cleaner on the pads, tightened the self tapping screws in the top part fairly hard, and this seemed to have fixed it!
Here's the ultra poor quality video, I was holding my phone with one hand and manipulating with the other: (please also excuse my italian reinterpretation of the english language :) )
https://youtu.be/SNntyelmeLA

Well, I'll tag this topic solved (is it a right thing to do?)
Let's hope this problem never presents itself again.
Weird anyway, in fact I searched quite a bit and didn't found anyone having the same issue.
« Last Edit: March 09, 2017, 05:08:24 pm by Gywhard »
 

Offline iainwhite

  • Supporter
  • ****
  • Posts: 303
  • Country: us
  • Measure twice...
Nice work!   I'm glad you fixed it.  I thought your video was fine too - I could see what you meant regarding the springs.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf