Products > Test Equipment

Hantek - Tekway - DSO hack - get 200MHz bw for free

<< < (640/640)

StuBudd:
A late night play:
New DSO5072P
SW 3.40.0 (210308.0)
HW 1010xffff8108
Power Board DSO5000 Series Power Data 2020/08 Ver 2.1
Has a "card reader" hardware between CR2032 and beeper.
Mainboard 2015/5/26 Ver 1.01 DSO5000C Serial MB

Windows 8.1
USB driver had to be installed booting into "Disable Driver Signature Enforcement"
Could not connect to device (no idea ~ SW version!?!)

Upgraded SW to 3.40.0 (210225.0) dso5kp_func_dso5072p20210225.up ~ No backup created prior to upgrade

This upgrade is from Hantek ~ no idea why an earlier SW version.

Can now connect to device. Scope software run in compatibility mode Windows 8.

DSO-BW-Changer.exe worked after installing C++ Redistribution for missing DLL. Think 2010 version. 2015 may not work.

DSO-BW-Changer.exe seems to work although I have no idea how to test. Software shows DSO200MB.

Device functions.  :-//

But then I am new to oscilloscopes :)

Got some 200MHz probes coming  :-+

Thanks and now off to sleep.


tehnics:
Hello,
I am new here and I have a problem with my Hantek 5072P. Was working fine but not used for about half year. Last week wanted to use it and logo appear and freeze.
Well, I do not have a back-up done, I never though will be a problem with it.
So I started to search on internet about issue and most of the google research leads to this topic.

I used  DNW.Exe and via serial I was able to see all message on start-up boot.

Boot log file is below


--- Code: ---*** Warning - bad CRC or NAND, using default environment

##### EmbedSky BIOS for SKY2416/TQ2416 #####

This Board: SDRAM is 64MB; LCD display size is: 800 X 480

Press Space key to Download Mode.!

SD:File System init failed!

Start Linux ...


NAND read: device 0 offset 0x300000, size 0x400000

 4194304 bytes read: OK

Boot with zImage


Starting kernel ...


Uncompressing Linux... done, booting the kernel.
Linux version 3.2.35 (root@zgt) (gcc version 4.3.3 (Sourcery G++ Lite 2009q1-176) ) #10 PREEMPT Thu Feb 9 10:40:49 CST 2017
CPU: ARM926EJ-S [41069265] revision 5 (ARMv5TEJ), cr=00053177
CPU: VIVT data cache, VIVT instruction cache
Machine: SMDK2416
Memory policy: ECC disabled, Data cache writeback
CPU S3C2416/S3C2450 (id 0x32450003)
S3C24XX Clocks, Copyright 2004 Simtec Electronics
CPU: MPLL on 800.000 MHz, cpu 400.000 MHz, mem 133.333 MHz, pclk 66.666 MHz
CPU: EPLL on 96.000 MHz, usb-bus 48.000 MHz
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
Kernel command line: noinitrd ubi.mtd=3 root=ubi0:rootfs rootfstype=ubifs init=/linuxrc console=ttySAC0 mem=64M
PID hash table entries: 256 (order: -2, 1024 bytes)
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 64MB = 64MB total
Memory: 58996k/58996k available, 6540k reserved, 0K highmem
Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
    vmalloc : 0xc4800000 - 0xf6000000   ( 792 MB)
    lowmem  : 0xc0000000 - 0xc4000000   (  64 MB)
    modules : 0xbf000000 - 0xc0000000   (  16 MB)
      .text : 0xc0008000 - 0xc03f0000   (4000 kB)
      .init : 0xc03f0000 - 0xc0410000   ( 128 kB)
      .data : 0xc0410000 - 0xc05a9140   (1637 kB)
       .bss : 0xc05a9164 - 0xc05c6e9c   ( 120 kB)
SLUB: Genslabs=13, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
NR_IRQS:107
irq: clearing subpending status 00000002
Calibrating delay loop... 198.45 BogoMIPS (lpj=496128)
pid_max: default: 4096 minimum: 301
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
NET: Registered protocol family 16
S3C2416: Initializing architecture
S3C2416: IRQ Support
S3C24XX DMA Driver, Copyright 2003-2006 Simtec Electronics
DMA channel 0 at c4804000, irq 88
DMA channel 1 at c4804100, irq 89
DMA channel 2 at c4804200, irq 90
DMA channel 3 at c4804300, irq 91
DMA channel 4 at c4804400, irq 92
DMA channel 5 at c4804500, irq 93
bio: create slab <bio-0> at 0
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
s3c-i2c s3c2410-i2c: slave address 0x10
s3c-i2c s3c2410-i2c: bus frequency set to 9 KHz
s3c-i2c s3c2410-i2c: i2c-0: S3C I2C adapter
Advanced Linux Sound Architecture Driver Version 1.0.24.
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
NET: Registered protocol family 1
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
s3c-adc s3c24xx-adc: attached adc driver
msgmni has been set to 115
io scheduler noop registered (default)
io scheduler cfq registered
s3c-fb s3c-fb: window 0: fb
s3c-fb s3c-fb: LCD type is TN83 800*480, default_bpp=16, pixclock=5
s3c-fb s3c-fb: window 1: fb
s3c-fb s3c-fb: LCD type is TN83 800*480, default_bpp=16, pixclock=5
s3c2440-uart.0: ttySAC0 at MMIO 0x50000000 (irq = 70) is a S3C2440
console [ttySAC0] enabled
s3c2440-uart.1: ttySAC1 at MMIO 0x50004000 (irq = 73) is a S3C2440
s3c2440-uart.2: ttySAC2 at MMIO 0x50008000 (irq = 76) is a S3C2440
s3c2440-uart.3: ttySAC3 at MMIO 0x5000c000 (irq = 94) is a S3C2440
loop: module loaded
S3C24XX NAND Driver, (c) 2004 Simtec Electronics
info->cpu_type=3, tacls_max=8
s3c24xx-nand s3c2416-nand: Tacls=3, 22ns Twrph0=7 52ns, Twrph1=3 22ns
s3c24xx-nand s3c2416-nand: System booted from NAND
s3c24xx-nand s3c2416-nand: NAND ECC disabled
NAND device: Manufacturer ID: 0xec, Chip ID: 0xf1 (Samsung NAND 128MiB 3,3V 8-bit)
NAND_ECC_NONE selected by board driver. This is not recommended!
Scanning device for bad blocks
Bad eraseblock 103 at 0x000000ce0000
Bad eraseblock 242 at 0x000001e40000
Creating 8 MTD partitions on "NAND":
0x000000000000-0x000000100000 : "uboot"
0x000000100000-0x000000180000 : "params"
0x000000180000-0x000000380000 : "logo"
0x000000380000-0x000000400000 : "misc"
0x000000400000-0x000000800000 : "kernel"
0x000000800000-0x000004e00000 : "rootfs"
0x000004e00000-0x000005200000 : "kernel_bk"
0x000005200000-0x000008000000 : "recover"
UBI: attaching mtd3 to ubi0
UBI: physical eraseblock size:   131072 bytes (128 KiB)
UBI: logical eraseblock size:    126976 bytes
UBI: smallest flash I/O unit:    2048
UBI: VID header offset:          2048 (aligned 2048)
UBI: data offset:                4096
UBI: max. sequence number:       0
UBI error: ubi_read_volume_table: the layout volume was not found
UBI error: ubi_init: cannot attach mtd3
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
s3c2410-ohci s3c2410-ohci: S3C24XX OHCI
s3c2410-ohci s3c2410-ohci: new USB bus registered, assigned bus number 1
s3c2410-ohci s3c2410-ohci: irq 42, io mem 0x49000000
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
usbcore: registered new interface driver usblp
usbcore: registered new interface driver uas
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
g_serial gadget: Gadget Serial v2.4
g_serial gadget: g_serial ready
s3c-hsudc s3c-hsudc: bound driver g_serial
samsung-ts s3c2416-ts: driver attached, registering input device
input: S3C24XX TouchScreen as /devices/virtual/input/input0
S3C24XX RTC, (c) 2004,2006 Simtec Electronics
s3c-rtc s3c2410-rtc: rtc disabled, re-enabling
s3c-rtc s3c2410-rtc: rtc core: registered s3c as rtc0
i2c /dev entries driver
S3C2410 Watchdog Timer, (c) 2004 Simtec Electronics
s3c2410-wdt s3c2410-wdt: watchdog inactive, reset disabled, irq disabled
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
s3c-sdhci s3c-sdhci.1: clock source 0: hsmmc (133333333 Hz)
s3c-sdhci s3c-sdhci.1: clock source 1: hsmmc (133333333 Hz)
s3c-sdhci s3c-sdhci.1: clock source 2: hsmmc-if (24000000 Hz)
mmc0: SDHCI controller on samsung-hsmmc [s3c-sdhci.1] using ADMA
S3C24XX_UDA134X SoC Audio driver
UDA134X SoC Audio Codec
asoc: uda134x-hifi <-> s3c24xx-iis mapping ok
ALSA device list:
  #0: S3C24XX_UDA134X
TCP cubic registered
NET: Registered protocol family 17
Registering the dns_resolver key type
s3c-rtc s3c2410-rtc: setting system clock to 2000-01-01 00:00:01 UTC (946684801)
VFS: Cannot open root device "ubi0:rootfs" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
1f00            1024 mtdblock0  (driver?)
1f01             512 mtdblock1  (driver?)
1f02            2048 mtdblock2  (driver?)
1f03             512 mtdblock3  (driver?)
1f04            4096 mtdblock4  (driver?)
1f05           71680 mtdblock5  (driver?)
1f06            4096 mtdblock6  (driver?)
1f07           47104 mtdblock7  (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


--- End code ---


I press space key right away pressing power button and I enter in download mode (see attached image). All drivers installed and was no problem to access oscilloscope via USB.
BUT from here I am lost :D.
I look to some video and I understand I should update "rootfs.ubi" *F5 option in menu*, it was done successfully but noting changed, still same problem with freeze logo

Looking more, also I found this topic https://www.eevblog.com/forum/testgear/hantek-dso5102b-need-kernel-zimage-not-booting/
where might be a problem with Linux kernel and need "zImage.bin" to be uploaded. Does anyone has this file ? What could be problem ?

I have to say that I am not newbie in electronic, but I am totally lost in Linux things, so please be patient with me to make my osciloscope alive.





tehnics:
I look more in the log file and what jumped in my eye is the last part:

VFS: Cannot open root device "ubi0:rootfs" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
1f00            1024 mtdblock0  (driver?)
1f01             512 mtdblock1  (driver?)
1f02            2048 mtdblock2  (driver?)
1f03             512 mtdblock3  (driver?)
1f04            4096 mtdblock4  (driver?)
1f05           71680 mtdblock5  (driver?)
1f06            4096 mtdblock6  (driver?)
1f07           47104 mtdblock7  (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

after this I run again in download mode and press [0] Set the boot parameters and [5] View the parameters (too see all booting parameters)

This is I get as result

--- Code: ---Enter your selection: 5

Name(enter to view all paramters):

bootargs=noinitrd ubi.mtd=3 root=ubi0:rootfs rootfstype=ubifs init=/linuxrc console=ttySAC0 mem=64M

bootcmd=nand read.jffs2 c0008000 kernel;bootm c0008000

bootdelay=1

baudrate=115200

ethaddr=10:23:45:67:89:ab

ipaddr=192.168.1.6

serverip=192.168.1.8

gatewayip=192.168.1.2

netmask=255.255.255.0

stdin=serial

stdout=serial

stderr=serial

ethact=dm9000

mtdids=nand0=nandflash0

mtdparts=mtdparts=nandflash0:512k@0(bios),512k(params),2048K(logo),4m(kernel),-(root)

partition=nand0,0

mtddevnum=0

mtddevname=bios


Environment size: 504/16380 bytes

--- End code ---
as far as I can see,  root=ubi0:rootfs , that is correct or wrong ?

That makes me feel that when linux try to load do not find boot root location/partition. I understand correct ?
How to correct this ? Any idea ?

I had most as same problem as this quy (same error issue) in this topic: https://www.eevblog.com/forum/testgear/hantek-mso5074fg-firmware-upgrade-problem/msg598724/#msg598724
So my solution is to somehow someone to send me a DSO5102P or 5072P back-up file...

Tugo:
Hi!
I will not be able to help you with anything beside an advise: how about contacting Hantek directly to tell them what happened when you turned it on after half year of no usage. Later you can tell them more but I wouldn't do that in my first message to them.
And please let us know how it went. Maybe somebody else will also need the same help.
Good luck  :-+

Edit: Or you can go to their forum -> https://www.eediscuss.com/forum.php

Navigation

[0] Message Index

[*] Previous page

There was an error while thanking
Thanking...
Go to full version