Author Topic: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator  (Read 38254 times)

0 Members and 1 Guest are viewing this topic.

Offline BugCatcher

  • Contributor
  • Posts: 8
  • Country: de
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #225 on: May 20, 2021, 05:52:33 pm »
Hi Tony,

thank you for the first results!
I found my old data for the MHS5200A. Test setup was very simple. Channel 1 connected to ext. input (frequency counter). This generator can run frequency counter and DDS in parallel.
There is an unexpected difference of approx. 7ppm. Root cause is a hidden factory calibration. Correction is applied for the DDS but not for the counter.
Close to 20MHz I scanned manually a 50Hz range in steps of 1Hz (user interface would allow 10mHz steps). The results show the frequency readings from the internal counter (10s gate, 0.1Hz resolution). The results are fully repeatable ... there is neither temperature nor noise in the game!

What can we see?

-  50 different frequency settings result in only 17 different output frequencies (with full 10mHz resolution: 5000 versus 17)
      =>   FAKE resolution !!!

-  the mapping between input settings and output frequencies is not a simple quantization
      =>   there must be an additional implementation problem around the used arithmetic
                       (e.g. insufficient precision of 32bit float)

Hope your new device is performing well and not showing nasty effects  ;-)

       BugCatcher

[attachimg=1]
 

Offline radiolistener

  • Super Contributor
  • ***
  • Posts: 1818
  • Country: ua
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #226 on: May 20, 2021, 09:04:26 pm »
Waterfall on the siglent okey :)

25 MHz + 0.1 Hz

Can you please show more wide span? too see at least second and third harmonics.

For example try span 200 MHz
 

Offline OnAironaut

  • Newbie
  • Posts: 3
  • Country: lv
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #227 on: May 22, 2021, 02:16:57 pm »
I can't seem to get a sinusoidal waveform from 2 V to 8 V. The device automatically decreases the "Amp" setting as soon as I start increasing the "Offset". Is it possible to generate such a waveform with this function generator? Am I doing something wrong? Have I misunderstood the specs? Thank you!





 

Offline tonyalbus

  • Frequent Contributor
  • **
  • Posts: 799
  • Country: nl
  • To better understand, you need to open it ;-)
    • My Channel
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #228 on: May 22, 2021, 02:36:58 pm »
@OnAironaut Could have something to do with the frequency... i think on higher frequencies usually the Amplitude is limited. Try the same on lower Freq.
Nice siglent scope  :-+
Electronics enthusiast, TEA and Radio Amateur (PE1ONS)
Marconi  - TTi - Thandar - Thurmbly - HP - Fluke - Philips - Siglent - Owon - TEK - Anritsu - Keithley - AVO - BG7TBL
https://www.youtube.com/TonyAlbus
 

Offline OnAironaut

  • Newbie
  • Posts: 3
  • Country: lv
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #229 on: May 22, 2021, 03:13:27 pm »
Thanks! It was the frequency, indeed. 2V to 8V sine works fine at 10 MHz. Too bad I need 28.8 MHz. Oh, well...
 

Offline TimNJ

  • Super Contributor
  • ***
  • Posts: 1344
  • Country: us
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #230 on: May 22, 2021, 03:51:44 pm »
Amplifiers are often (almost always?) compensated to keep them stable. That is, the bandwidth, or gain at high frequency is limited to keep it from oscillating/introducing distortion.


If you don't want to think about bandwidth, you can think about voltage slew-rate, or dv/dt limitation. As frequency increases, holding amplitude constant, the maximum dv/dt of a given sine wave increases. As amplitude increases, holding frequency constant, the dv/dt also increases. So, if you are operating at the amplifiers maximum dv/dt, then if you want to increase frequency, you need to decrease amplitude, and vice versa.


Probably some inaccuracies in this explanation, but that's how I think of it.
 


Offline radiolistener

  • Super Contributor
  • ***
  • Posts: 1818
  • Country: ua
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #232 on: May 22, 2021, 08:13:53 pm »
I can't seem to get a sinusoidal waveform from 2 V to 8 V. The device automatically decreases the "Amp" setting as soon as I start increasing the "Offset". Is it possible to generate such a waveform with this function generator?

I think it may not be possible, because min and max value is limited by absolute Voltage against zero, and if you add offset it cannot increase max limit.
 

Offline Labrat101

  • Frequent Contributor
  • **
  • Posts: 448
  • Country: 00
  • Renovating Old Test Equipment & Calibration ..
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #233 on: May 23, 2021, 06:14:52 am »
Check the settings under settings options in the menu . The min & max can be changed.  They maybe still on the defaults.
"   All Started With A BIG Bang!! .  .   & Magic Smoke  "
 

Offline tonyalbus

  • Frequent Contributor
  • **
  • Posts: 799
  • Country: nl
  • To better understand, you need to open it ;-)
    • My Channel
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #234 on: May 23, 2021, 11:03:37 am »
@radiolist

Electronics enthusiast, TEA and Radio Amateur (PE1ONS)
Marconi  - TTi - Thandar - Thurmbly - HP - Fluke - Philips - Siglent - Owon - TEK - Anritsu - Keithley - AVO - BG7TBL
https://www.youtube.com/TonyAlbus
 

Offline radiolistener

  • Super Contributor
  • ***
  • Posts: 1818
  • Country: ua
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #235 on: May 23, 2021, 10:57:31 pm »
tonyalbus

-34 dBc for 2'nd and -29 dBc for 3'rd  - it's horrible. Does it have anti-aliasing low pass filter on the output?   ???
« Last Edit: May 23, 2021, 10:59:21 pm by radiolistener »
 

Offline IAmBack

  • Regular Contributor
  • *
  • Posts: 108
  • Country: pl
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #236 on: June 25, 2021, 12:50:09 pm »
A 3 AWGs and the one  oscilloscope story here.
All three AWGs were connected do the scope (SDS2104x plus):  UTG962 (yellow line), SDS2104x plus gen (blue line), and SDG2042 (purple line). Frequencies were set to 35MHz and fine - tuned to get as stable plots as possible. Blue plot is sync source, therefore it is rock solid.
Purple plot's frequency is slightly off - therefore it flows slowly (but it's "movement" is stable, sort of "majestatic').
Yellow plot jumps here and there, showing UTG962 higher phase noise. Hopefully attached GIF will animate correctly here.
Maybe someone will find it useful...

p.s.(edit)
Zip file attached with animated GIF inside. Just in case.
« Last Edit: June 25, 2021, 02:29:36 pm by IAmBack »
 
The following users thanked this post: tonyalbus

Offline BugCatcher

  • Contributor
  • Posts: 8
  • Country: de
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #237 on: June 28, 2021, 09:43:14 am »
Hi,
excellent observation!

Now we have a few questions:
- is this a HW-bug (e.g. due to "out of lock" of the 20MHz -> 200MHz PLL)
- is this a "nasty" design feature (e.g. to offer high resolution at high frequencies)
I would recommend following tests (one Siglent generator is sufficient):
- one period of sine is an integer number of samples (e.g. 50, 40, 25, 20, ... MHz) *
  don't apply fine-tuning on the UTG side! Tune the Siglent!
  -> if an above frequency is clean, repeat with a modified frequency (e.g. add a random offset in the range of 10kHz)
- what happens at lower frequencies (e.g. 3.5MHz or even lower) ? 
No need for videos. Persistence mode is sufficient!
Other approach would be the use of a high resolution / high dynamic range spectrum analyzer or an SDR (software defined radio) in waterfall mode.

* there could be a hidden problem: calibration factor (if available) must be equal "1"

BugCatcher
 

Offline 1audio

  • Regular Contributor
  • *
  • Posts: 113
  • Country: us
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #238 on: July 10, 2021, 05:56:09 pm »
There is a seemingly honest review on Amazon suggesting much lower harmonics:
"Spectral purity - here's where most of the inexpensive generators fall flat. The 962 is not without problems. On the plus side, the specs call for harmonics of the fundamental output to be a minimum of -40dB down for 30MHz to 60MHz. I generally found harmonics to be around -60dB down or better for all frequencies. It is impressive. "

https://www.amazon.com/gp/customer-reviews/RL2C0ECIUCE59/ref=cm_cr_dp_d_rvw_ttl?ie=UTF8&ASIN=B08PQCFG4M

I'm interested in the "flatness" of its response. Has anyone measured it?
 

Offline ВАДИМ

  • Newbie
  • Posts: 1
  • Country: ru
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #239 on: July 11, 2021, 03:58:12 pm »
good day. IT IS POSSIBLE TO TAKE A HEX FILE FROM YOU FOR eeprom 24LC64. stasukov.v@mail.ru
 

Offline Serg_D

  • Newbie
  • Posts: 4
  • Country: ru
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #240 on: July 23, 2021, 05:29:46 pm »
Hello! Purchased UTG962 without the letter E in the designation. The default language was English. When you reset to factory settings, the English language is saved. In the System/About menu, the model is listed as UTG900.
There's a problem with the software on your Windows 10 computer. The driver is inserted, the device in the system is detected, but Devices Manager does not find the generator.
I tried on another computer with Windows 7, it works normally there. Did anyone put software on Windows 10? How did you manage to defeat the problem?
 

Offline Labrat101

  • Frequent Contributor
  • **
  • Posts: 448
  • Country: 00
  • Renovating Old Test Equipment & Calibration ..
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #241 on: July 23, 2021, 05:58:32 pm »
Hello! Purchased UTG962 without the letter E in the designation. The default language was English. When you reset to factory settings, the English language is saved. In the System/About menu, the model is listed as UTG900.
There's a problem with the software on your Windows 10 computer. The driver is inserted, the device in the system is detected, but Devices Manager does not find the generator.
I tried on another computer with Windows 7, it works normally there. Did anyone put software on Windows 10? How did you manage to defeat the problem?
yes it works in windows 10
"   All Started With A BIG Bang!! .  .   & Magic Smoke  "
 

Offline Serg_D

  • Newbie
  • Posts: 4
  • Country: ru
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #242 on: July 23, 2021, 06:09:45 pm »
yes it works in windows 10
And what order of installation did you do?
I was just running the Devices Manager Installer.exe installation file. The same thing I did on a computer with Windows 7 and everything worked. On a Windows 10 computer, I tried running as an Administrator and tried compatibility modes with other versions of OS. Nothing helped
 

Offline Labrat101

  • Frequent Contributor
  • **
  • Posts: 448
  • Country: 00
  • Renovating Old Test Equipment & Calibration ..
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #243 on: July 23, 2021, 07:31:23 pm »
yes it works in windows 10
And what order of installation did you do?
I was just running the Devices Manager Installer.exe installation file. The same thing I did on a computer with Windows 7 and everything worked. On a Windows 10 computer, I tried running as an Administrator and tried compatibility modes with other versions of OS. Nothing helped
I don't exactly remember I just followed the instruction in a readme file.
I did it about 9 months ago .and it just worked .
"   All Started With A BIG Bang!! .  .   & Magic Smoke  "
 

Offline Serg_D

  • Newbie
  • Posts: 4
  • Country: ru
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #244 on: July 23, 2021, 07:54:58 pm »
I don't exactly remember I just followed the instruction in a readme file.
I followed that instruction, too. But the drivers in the folder "DriverPack_Libusb" were not installed because of the error "DPInst.exe cannot be installed on this operating system." On a Windows 7 computer, these drivers also did not install due to a similar error, but nevertheless the software itself worked completely.
Divers from the "VISA Driver 5.4" folder were also not installed on both computers, but apparently they were already in the system, since there were no errors during their installation.
In general, I am completely perplexed why this software does not work for 10.
 

Offline Caliaxy

  • Regular Contributor
  • *
  • Posts: 128
  • Country: us
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #245 on: July 23, 2021, 10:23:41 pm »
I can't seem to get a sinusoidal waveform from 2 V to 8 V. The device automatically decreases the "Amp" setting as soon as I start increasing the "Offset". Is it possible to generate such a waveform with this function generator? Am I doing something wrong? Have I misunderstood the specs? Thank you!

I know it's a two-month-old question...

Since the outputs of UNI-T UTG932 are isolated from the mains ground, have you tried to add the 5V offset with a power supply in series with the output (ground of the BNC generator output connected to (+) of the power supply, output signal between the BNC center pin and (-) of the power supply)?
 

Offline Serg_D

  • Newbie
  • Posts: 4
  • Country: ru
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #246 on: Yesterday at 03:50:30 pm »
So, there's no movement on my problem. I wrote a request for a problem on the support@uni-trend.com.cn, there has been no answer for several days. Tried reinstalling the application, not helping. Then the device driver flew off and did not put in any way. In the system, the device was defined as UTG900 without drivers. Pitched it to the folder DriverPack_Libusb, says that no driver was found in this folder. When installing Devices Manager Installer.exe, I see that the PL2303_v130 driver is installed (1.3.0?) This already leads to bad thoughts about Chinese clones of PL2303 that are not supported by the official chip manufacturer. Who disassembled the device, what is there with the USB driver?
As a result, I found another computer with Windows 10 on board to check the health of the software. After installation, the program successfully identified the generator and I was able to manage it. As a result, I pulled the driver from this computer and manually installed it on a computer where the driver flew and the software did not work. The device driver was successfully installed, the device is now defined, but the program is still not working.
This led to the idea that the operating system itself does not allow access to the USB port. At the same time, I do not receive any mistakes. I tried to install Devices Manager with Windows Firewall exceptions, but this did not help either.
Guys! Maybe from my confused story someone can understand the reason for what is happening and help me defeat this problem? Friends advise me to clean up the operating system. But I do not want such radical measures yet. At the same time, I will lose the software I installed. And his recovery is both a loss of time and extra nerves. Yes, and I have no confidence that this will help. |O |O |O
 

Offline Labrat101

  • Frequent Contributor
  • **
  • Posts: 448
  • Country: 00
  • Renovating Old Test Equipment & Calibration ..
Re: UNI-T UTG932/UTG962 200MSa/s Function Arbitrary Waveform Generator
« Reply #247 on: Yesterday at 06:15:25 pm »
There is a possibility that the other windows 10 was a different version . and or there maybe a problem with your motherboard itself. Windows 10 is crappy since they did a load of updates . Windows does not check the system at all well and can install
wrong drivers not uncommon as some M/B are not always 100% compat
I moved over to Linux about 12yrs ago .
but my Laptop IBM Lenovo has win10  which did work with the UTG962 (900 series ) I had already had NI visa installed as far as
I can remember . I would try uninstalling it and use NI visa as its a newer version the the on from china .
Also when you down load from UNI -T make sure you D/L the write program there are several versions in the (900 series)
 But suspect its your wind10 . also disable your antivirus . & Defender  Your antivirus could be eating your driver  >:D
If you are paranoic load the entire program and drivers into a folder on your deck top . Shut down your Antivirus  completely .
Uninstall what you have . reboot the computer  . make sure the antivirus is still disabled  . turn your internet off wifi .. cable.
reinstall the UNI-T program  again . reboot after install .  this may solve your problem ..
 
« Last Edit: Yesterday at 06:17:50 pm by Labrat101 »
"   All Started With A BIG Bang!! .  .   & Magic Smoke  "
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf