Author Topic: Flakey Fluke 8060A  (Read 1528 times)

0 Members and 1 Guest are viewing this topic.

Offline moby

  • Contributor
  • Posts: 15
  • Country: nz
Flakey Fluke 8060A
« on: March 29, 2017, 08:33:57 pm »
I have inadvertantly killed two Fluke 8060As (a couple of years apart). It seemed to occur when I drew an arc off one of the test probes when measuring a voltage supposedly well within the ratings of the meter. Highside primary SMPSU testing springs to mind (around 400v). The meters now only work some of the time. Other times they display gibberish at startup (a random number or things like "-OL") which don't change no matter what the switcn settings. The four buttons (REL, dB etc) still seem to work. Some days the meters work fine!. Any ideas what might be happening here - I know these things are ancient but nothing new quite matches the feature set.
M
 

Offline retiredcaps

  • Super Contributor
  • ***
  • Posts: 3560
  • Country: ca
Re: Flakey Fluke 8060A
« Reply #1 on: March 29, 2017, 08:53:43 pm »
First, welcome to the forum.

The Fluke 8060A have a known problem with leaky capacitors.  They leak from the bottom bung and you cannot tell from visual inspection.  There are many threads here on the leaky 8060A capacitors with pictures.

If you were measuring high voltage, there is a chance that the MOVs in the 8060A became damaged.   They should measure open circuit resistance.  You can measure in circuit first, then desolder to verify.
« Last Edit: March 30, 2017, 12:37:41 am by retiredcaps »
 

Offline ModemHead

  • Frequent Contributor
  • **
  • Posts: 731
  • Country: us
  • No user-serviceable parts inside.
    • Mr. ModemHead
Re: Flakey Fluke 8060A
« Reply #2 on: March 30, 2017, 12:19:04 am »
Some days the meters work fine!
Then hopefully nothing major is fried.  But still, thou shalt check for leaky capacitors.

Also carefully take apart the LCD/microprocessor assembly and clean the elastomeric connectors with strong IPA.
 

Offline tautech

  • Super Contributor
  • ***
  • Posts: 22246
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Flakey Fluke 8060A
« Reply #3 on: March 31, 2017, 03:56:42 am »
@moby
If you haven't found this thread started by one of the designers or your 8060A it's worthy of a read:
https://www.eevblog.com/forum/testgear/old-fluke-multimeters/
Avid Rabid Hobbyist
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf