Author Topic: HP 3467A Multimeter DOA  (Read 520 times)

0 Members and 1 Guest are viewing this topic.

Offline jgrhops

  • Newbie
  • Posts: 1
  • Country: us
HP 3467A Multimeter DOA
« on: December 14, 2019, 07:26:17 pm »
Hello everyone,

I recently picked up an "as is/parts only" HP logging multimeter on the cheap. The internals are very clean with no obvious signs of problems, however it is completely dead, with no display and no sound of relay action. The few motherboard test points show spot on voltages. There is an 8-pin connector at the top of the A3 (Orange) board which looks like it should have a ribbon cable connected but doesn't. (See attached) Could it be this simple?

On the other hand, I can't see where the other end of the mystery cable would connect. Can anyone verify this one way or another? On this connector all the voltages are correct except for the +8 VDC which is way high at +11V.

Baby steps! Any thoughts or suggestions greatly appreciated.
 

Online Kleinstein

  • Super Contributor
  • ***
  • Posts: 11437
  • Country: de
Re: HP 3467A Multimeter DOA
« Reply #1 on: December 14, 2019, 07:39:03 pm »
The pin header looks more like a set of test points. This could be for production testing.
 

Offline wn1fju

  • Frequent Contributor
  • **
  • Posts: 458
  • Country: us
Re: HP 3467A Multimeter DOA
« Reply #2 on: December 14, 2019, 07:57:32 pm »
I have a working HP 3467A.  There are no cables to that header, nor are there any other cables going to the individual boards. 

Reseat all the boards, do a visual inspection, check the P/S voltages - the usual stuff.

With mine, the problem was the printer mechanism.  The cheap plastic gears chew themselves up and it is goodbye printer.  It can be fixed, however,
somewhat painfully.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf