Author Topic: keithley 2400 C power issue  (Read 1816 times)

0 Members and 1 Guest are viewing this topic.

Offline richcj10

  • Supporter
  • ****
  • Posts: 201
  • Country: us
keithley 2400 C power issue
« on: April 24, 2013, 03:30:45 am »
I have acquired this piece B/C it wasn't working. (nothing on the screen, no beep) I have found out that the AC in to DC (12v & 5v) is working but the 12V DC to AC to +-15, +-30, etc isn't.
I think the problem is at the front end of the transformer. does anyone have the schematic?

Thanks,

Rick
 

Offline MetraCollector

  • Regular Contributor
  • *
  • Posts: 97
  • Country: cz
Re: keithley 2400 C power issue
« Reply #1 on: April 24, 2013, 10:12:30 am »
As I know, schematics are not available, I was trying to find some for K2000 with no success.
Anyway, service manual is available through G. and there are some flow chart for repairing these Keithley instruments.
GL !
 

Offline free_electron

  • Super Contributor
  • ***
  • Posts: 7593
  • Country: us
    • SiliconValleyGarage
Re: keithley 2400 C power issue
« Reply #2 on: April 24, 2013, 03:04:50 pm »
Most likely that big power hybrid is shot. On the bottom board there is an industrial power converter brick. Either a vicor or an ericsson. They are hard to find...

Professional Electron Wrangler.
Any comments, or points of view expressed, are my own and not endorsed , induced or compensated by my employer(s).
 

Offline richcj10

  • Supporter
  • ****
  • Posts: 201
  • Country: us
Re: keithley 2400 C power issue
« Reply #3 on: April 24, 2013, 03:09:07 pm »
It works.
I get the 12v and 5v out of it.
I just discovered if I run my o-scope probe across one side of U3 (Main CPU)
it will reset and turn on with a "No Com" error.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf