Author Topic: Need help getting :WAV:DATA? on MSO1104Z  (Read 665 times)

0 Members and 1 Guest are viewing this topic.

Offline sudobash

  • Newbie
  • Posts: 3
  • Country: us
Need help getting :WAV:DATA? on MSO1104Z
« on: April 23, 2019, 06:37:12 pm »
Hi all,

Been a lurker here, but I've got an issue that I can't solve on my own now. I have gotten a new scope for work that I am 90% happy with, but I have a few issues with. I have a MSO1104Z (My work bought it so it is not a hacked one either). My main use is the logic analyzer, and I want to download the data to my computer to use sigrok and other custom tools on. I can save a CSV to a flashdrive, but that takes several minutes(!) to complete, and ain't nobody got time for that!

I got really excited trying out SCPI commands on it, and I (thought) that I had figured out how to download the LA data. I've been using these commands:

Code: [Select]
:STOP
:WAV:MODE RAW
:WAV:FORM BYTE
:WAV:SOUR D0
:WAV:STAR 1
:WAV:STOP 120000
:WAV:PRE?
0,2,1200,1,1.000000e-09,2.300000e-07,0,0.000000e+00,0,0
:WAV:DATA?
#9000001200


I thought that this would dump out the D0-D7 LA values as byte bitmasks. That is what the DS1000Z Programming Guide suggests to me. But it just outputs the header #9000001200 and no data.  :(

I've retried this with :WAV:SOUR CHAN1 and it worked as expected. I piped the data I got through hexdump -e '1/1 "%1u\n"' and into gnuplot and I got a graph just like what I saw on the screen. But I need the LA values, not the voltage probe ones.

Am I doing something wrong, or is there some workaround for this? Anybody with a DSO1104Z scope (or upgraded equivalent) able to reproduce this?

Thanks!

Edit: I should also mention that with :WAV:SOUR CHAN1 I have only been able to get proper results with :WAV:MODE NORM not :WAV:MODE RAW
Edit2: Perhaps I should also say that I am going at this over Ethernet with nc 10.0.0.74 5555
« Last Edit: April 23, 2019, 06:51:10 pm by sudobash »
 

Online Fungus

  • Super Contributor
  • ***
  • Posts: 10932
  • Country: 00
Re: Need help getting :WAV:DATA? on MSO1104Z
« Reply #1 on: April 23, 2019, 08:15:21 pm »
It probably doesn't like your value for "STOP"

Try querying STOP and see what it says. Try reading a smaller amount.


« Last Edit: April 23, 2019, 08:16:57 pm by Fungus »
 

Offline sudobash

  • Newbie
  • Posts: 3
  • Country: us
Re: Need help getting :WAV:DATA? on MSO1104Z
« Reply #2 on: April 23, 2019, 09:08:11 pm »
Thanks for the reply. By "STOP" do you mean ":WAV:STOP"? I just tried 1200, 500, and even 12 with no difference (except the #9000001200 header changed)
 

Offline smithnerd

  • Regular Contributor
  • *
  • Posts: 105
  • Country: gb
Re: Need help getting :WAV:DATA? on MSO1104Z
« Reply #3 on: April 23, 2019, 09:54:42 pm »
Try setting :WAV:SOUR D0 as the first operation?
 

Offline Mechatrommer

  • Super Contributor
  • ***
  • Posts: 9757
  • Country: my
  • reassessing directives...
Re: Need help getting :WAV:DATA? on MSO1104Z
« Reply #4 on: April 23, 2019, 10:04:06 pm »
i think he meant :STOP up above. you have to give DSO sometime to really in STOP mode before getting data. retry by either

1) removing that :STOP command but manually press STOP button on DSO, until it really stopped then run the get data command. see if any difference.
2) after :STOP command, do loop by checking :MODE (iirc) command, if it returns "STOP" then proceed with data download.

https://www.eevblog.com/forum/testgear/upload-a-full-mso7000-la-buffer/msg2072149/#msg2072149
ymmv.
It's extremely difficult to start life.. one features of nature.. physical laws are mathematical theory of great beauty... You may wonder Why? our knowledge shows that nature is so constructed. We simply have to accept it. One could describe the situation by saying that... (Paul Dirac)
 

Offline sudobash

  • Newbie
  • Posts: 3
  • Country: us
Re: Need help getting :WAV:DATA? on MSO1104Z
« Reply #5 on: April 23, 2019, 11:41:58 pm »
@Mechatrommer
Quote
i think he meant :STOP up above. you have to give DSO sometime to really in STOP mode before getting data. retry by either

1) removing that :STOP command but manually press STOP button on DSO, until it really stopped then run the get data command. see if any difference.

I made sure that the Stop button was lit red before I tried running my commands.

@smithnerd
Quote
Try setting :WAV:SOUR D0 as the first operation?

I tried that, and got the same results:

Code: [Select]
:WAV:SOUR D0
:WAV:MODE RAW
:WAV:FORM BYTE
:WAV:STAR 1
:WAV:STOP 100
:WAV:DATA?
#9000000100


All the examples I see are using ":WAV:SOUR CHAN1"
 

Online Fungus

  • Super Contributor
  • ***
  • Posts: 10932
  • Country: 00
Re: Need help getting :WAV:DATA? on MSO1104Z
« Reply #6 on: April 24, 2019, 06:46:27 am »
Thanks for the reply. By "STOP" do you mean ":WAV:STOP"? I just tried 1200, 500, and even 12 with no difference (except the #9000001200 header changed)

Yes.

You're seeing "#9000001200" in the reply so obviously it's not accepting the ":WAV:STOP 120000" command.


 

Online Fungus

  • Super Contributor
  • ***
  • Posts: 10932
  • Country: 00
Re: Need help getting :WAV:DATA? on MSO1104Z
« Reply #7 on: April 24, 2019, 06:50:48 am »
Edit: I should also mention that with :WAV:SOUR CHAN1 I have only been able to get proper results with :WAV:MODE NORM not :WAV:MODE RAW

That's very suspicious, I'd start investigating there.

I don't have an MSO but I've definitely read data in RAW mode, no problem.

Edit2: Perhaps I should also say that I am going at this over Ethernet with nc 10.0.0.74 5555

That's the preferred way to do it.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf