Products > Test Equipment

New Fluke 87-V is broken

(1/2) > >>

My parents were very nice to me for Christmas and bought me a Fluke 87-V multimeter.  I've worked with it since a few times, and I really like it.  Today, however, I seem to have killed it.

I wanted to put some labels on the multimeter.  I figured one label should go on the inside.  I took out the battery, lifted the back of the multimeter, and stuck the label on the back cover.  I put the cover back on, reinstalled the battery, and checked to make sure it still worked.

Well, it didn't.  I have no idea what I did.  I literally popped the cover off, and popped it right back on.  I made sure the mode selector switch on the inside was on the OFF position, I checked for foreign object debris, and I measured the battery voltage to make sure it wasn't dead.  Everything checked out well.

I did more investigation.  I took off the LCD & plastic plate, as well as the shield.  No FOD here.  I checked underneath the mode switch.  All the plungers? looked straight and springy, and the contacts on the PCB looked clean.

I have no idea what's wrong.  Fluke is closed today, so I plan on calling them tomorrow to see how well their lifetime warranty works.  In the meantime, please review the video below and give me some other non-warranty-voiding ideas.

Ryan Nazaretian

Here's the video.

Take it apart again and make a video of it operating without the front cover like the picture. You can rotate the white selector (there is an arrow on it) with an allen key.  I have a feeling that the selector isn't lined up correctly.

ModemHead's blog post gives an idea of how it works (could be specific to the original 80 series)...

"Also, there is the potential to engage the switch hub with the knob via its hexagonal shaft in such a way that it is not aligned properly.  This would allow the switch hub to be rotated beyond where it normally stops."

I don't think that's an issue here.  I recorded a video, but I have to edit it because my mom and our puppy walked in while I was recording...  It's clearly lined up properly.

College kid at home problems...  :-\

The V generation does not have the PTF/voltage-divider style code switch on the back, so it can't be that.  (No rotary switch self-test either.)  But there's obviously something wrong with the rotary switch, specifically that portion of it that indicates which function is selected, to the micro-controller.  It's out of sync with how the front end is configured, hence the non-sensical results.

I haven't taken any of 'V' generation units apart, and I haven't seen any publicly available schematics for it either, so I can't come up with any more specific advice.   :-\


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod