Author Topic: New Hantek DSO2X1X models?  (Read 445998 times)

0 Members and 3 Guests are viewing this topic.

Online Aldo22

  • Frequent Contributor
  • **
  • Posts: 834
  • Country: ch
Re: New Hantek DSO2X1X models?
« Reply #1775 on: January 24, 2024, 06:21:50 pm »
It's just cutting 2mm of the shaft plastic... Why the overthinking?
I'm not in a hurry.
The part is not broken, it works "as designed" by Hantek.  ;)
If I can find the exact part for the same shipping costs, then I'd rather take that than cutting and filing a PEC12R-4225.
But it's good to know that this option exists.
I'll look around a bit and then probably order the PEC12R-4025F-S0024.

Btw. is there anything to consider when removing the front cover?
There is only one ribbon cable, right?

Thank you.
 

Offline habl

  • Newbie
  • Posts: 7
  • Country: ru
Re: New Hantek DSO2X1X models?
« Reply #1776 on: January 29, 2024, 03:21:25 pm »
Hey, everybody.

At some point in the firmware update, my oscilloscope calibration function broke. I have read that this happens due to incorrect FPGA firmware. I have a full dump of the oscilloscope from the time of purchase, I rebuilt it - it shows firmware 220210.00 and Firmware 3204, but when I try to calibrate I get error 511d6. Tried different FPGA versions - some have error 511d1, some have error 511d6.

Help me to understand, please.
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1777 on: January 29, 2024, 06:58:16 pm »
Try latest 320x or 3102, must be one of them
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline habl

  • Newbie
  • Posts: 7
  • Country: ru
Re: New Hantek DSO2X1X models?
« Reply #1778 on: January 31, 2024, 03:06:39 am »
@DavidAlfa I found out that the latest version of dsoflash at the moment from your google disk does not allow to restore correctly my backup, taken by dsoflash a year and a half ago. I have recorded and read with the old version of dsoflash - the results are identical and recorded and read with the google disk version several times and the files are different. I uploaded the files to a temporary folder on google drive so you can analyze them.
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1779 on: January 31, 2024, 04:42:06 am »
With no booting between writing and reading? Otherwise that will change the filesystem.
Except small areas in the UBI partitions, all the flash is identical.
(Edit: Because it wasn't erasing the flash due a bug in the code!).
« Last Edit: February 02, 2024, 09:05:30 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline habl

  • Newbie
  • Posts: 7
  • Country: ru
Re: New Hantek DSO2X1X models?
« Reply #1780 on: January 31, 2024, 04:59:30 am »
Yes, without booting between writing and reading.
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1781 on: January 31, 2024, 05:12:00 am »
The UBI partitions CRC is different,  this can only be done by the scope itself, DSOFlash can't do this.
If data was bad, like wrogn CRC written, the scope wouldn't boot or work properly!
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline habl

  • Newbie
  • Posts: 7
  • Country: ru
Re: New Hantek DSO2X1X models?
« Reply #1782 on: January 31, 2024, 05:19:49 am »
That's the thing, if I write the dump with the old version of dsoflash, the oscilloscope loads, but if I write the dump with the your google disk, the oscilloscope does not load - hangs on the second splash screen. I've checked several times.
 

Offline habl

  • Newbie
  • Posts: 7
  • Country: ru
Re: New Hantek DSO2X1X models?
« Reply #1783 on: January 31, 2024, 05:24:17 am »
Looks like my nand memory chip is dead. Because now it is not detected by dsoflash.
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1784 on: January 31, 2024, 07:49:53 am »
Strange, but will check it later. Writing to the flash can't kill it in such way!
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline habl

  • Newbie
  • Posts: 7
  • Country: ru
Re: New Hantek DSO2X1X models?
« Reply #1785 on: January 31, 2024, 09:52:41 am »
I soldered out the flash drive, it reads in the programmer. The problem is not the flash drive, but a badly soldered contact near the flash drive. Thanks for the advice!

But the problem with dsoflash from your google disk remains. The images filled with it do not help to boot the oscilloscope.
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1786 on: January 31, 2024, 03:52:07 pm »
That's the thing, if I write the dump with the old version of dsoflash, the oscilloscope loads, but if I write the dump with the your google disk, the oscilloscope does not load - hangs on the second splash screen. I've checked several times.
Sill very rare than the first ~15MB are perfect and then only few bytes of the UBI header change.  Will check it, but it's extremely slow and time consuming so I can't tell when it'll be ready.
Actually you'll never really need DSOflash to restore anything, just run lastest platform-tools, then restore fw version, model/serial and AWG calibration from Backup Builder.

Edit:
Read my flash, wrote back, read again, exactly the same md5sum.
« Last Edit: January 31, 2024, 04:57:01 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1787 on: January 31, 2024, 11:12:23 pm »
@DavidAlfa I found out that the latest version of dsoflash at the moment from your google disk does not allow to restore correctly my backup
Well, indeed, your restore.bin didn't match the original when reading back.
Will make more tests...
« Last Edit: February 02, 2024, 09:03:57 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1788 on: February 01, 2024, 10:44:43 pm »
I was able to initialize the SDRAM (Not easy, zero documentation available for FEL |O), it's much larger than the SRAM scratchpad (64MB vs ~4KB), so it will allow much longer queues, removing a lot of overhead.
It made a dramatic speedup to 300KB/s, it only takes 7 minutes now!


« Last Edit: February 02, 2024, 07:40:01 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline habl

  • Newbie
  • Posts: 7
  • Country: ru
Re: New Hantek DSO2X1X models?
« Reply #1789 on: February 02, 2024, 07:30:51 am »
Yes, dsoflash is now correctly restoring the image on my oscilloscope. Thank you very much.
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1790 on: February 02, 2024, 06:44:32 pm »
Great! Thanks for reporting.
I added the final touches, including md5 generation and verification, updated the files in Google Drive.
« Last Edit: February 02, 2024, 07:41:58 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline vistorik

  • Regular Contributor
  • *
  • Posts: 103
  • Country: de
Re: New Hantek DSO2X1X models?
« Reply #1791 on: February 06, 2024, 09:52:12 pm »
Semenich56 from the 4pda forum https://4pda.to/forum/index.php?showtopic=1018961&view=findpost&p=128147933 received a DSO2C10 with GD5F1GQ4UAYIG flash memory instead of W25N01GVZEIG.
« Last Edit: February 06, 2024, 09:56:57 pm by vistorik »
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1792 on: February 06, 2024, 10:16:36 pm »
No problem, check the supported spi nand memories, the GD5F1GQ4UAYIG is included, everything should work.
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline vistorik

  • Regular Contributor
  • *
  • Posts: 103
  • Country: de
Re: New Hantek DSO2X1X models?
« Reply #1793 on: February 06, 2024, 10:47:07 pm »
No problem, check the supported spi nand memories, the GD5F1GQ4UAYIG is included, everything should work.
DavidAlfa, do you think the dsoflash could read this flash?
« Last Edit: February 07, 2024, 12:30:41 pm by vistorik »
 

Offline vistorik

  • Regular Contributor
  • *
  • Posts: 103
  • Country: de
Re: New Hantek DSO2X1X models?
« Reply #1794 on: February 08, 2024, 01:18:54 am »
Semenich56 from the 4pda forum could not get a memory (GD5F1GQ4UAYIG) dump https://4pda.to/forum/index.php?showtopic=1018961&view=findpost&p=128198761 using dsoflash.
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1795 on: February 08, 2024, 04:43:37 am »
If the memory wasn't detected properly It would complain showing unsupported memory error.
The scope rebooting is a completely new behavior that I've never seen before!

Are you using latest version? Or did you copy dsoflash to the 4pda thread? Because it's been updated recently to correct a bug not restoring the firmware properly, also got much faster.
I noticed a unnecessary step in the .bat files, since now dsoflash sets the usb to high-speed mode by itself, sunxi-fel is no longer required.
Updated the files. But this would not cause any rebooting, just set the usb mode twice.
« Last Edit: February 08, 2024, 05:10:45 am by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline phmarek

  • Contributor
  • Posts: 14
  • Country: at
Dead after a few keypresses
« Reply #1796 on: February 15, 2024, 07:42:08 pm »
Hi!

I reactivated my 2D15 after a few months of non-use, and noticed that there was no waveform display - which I thought was due to wrong trigger settings.
Then I noticed that only a few keypresses work (Trig Menu, or CH1 Menu, a few others), but then the UI freezes.

As the USB and SSH console still worked, I could reboot without my local modifications -- same problem. Even dropping the CPU overclocking doesn't help.
Remove the USB cable doesn't help.

dmesg or the serial console have no (error) output when pressing the keys; the UI freezes, but the console keeps working, and the phoenix binary looks like it's running normally, using 98% CPU like always.

As (some) keys work once or twice after reboot, I don't think it's hardware-related - can anyone offer ideas what is wrong?

Thanks!
« Last Edit: February 15, 2024, 07:44:47 pm by phmarek »
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1797 on: February 15, 2024, 10:59:27 pm »
Press load defaults. 98% CPU is normal in this device.
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Online Aldo22

  • Frequent Contributor
  • **
  • Posts: 834
  • Country: ch
Re: Dead after a few keypresses
« Reply #1798 on: February 16, 2024, 09:47:39 am »
As (some) keys work once or twice after reboot, I don't think it's hardware-related - can anyone offer ideas what is wrong?

I don't know if this is helpful, but my unit (overclocked) only crashes in the first few minutes after startup, if at all.
It depends a bit on what is turned on from the last session.

Then when I turn it back on, it runs for hours without interruption.
It looks like it might be "too cold" when it first starts up.
Sounds strange, but I can't explain it any other way.
Maybe it has something to do with the new PSU?

It's best not to do anything to it for 2 minutes after starting, at least with my device. Then it runs reliably.

But that probably has nothing to do with your case.
« Last Edit: February 16, 2024, 09:52:43 am by Aldo22 »
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6082
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #1799 on: February 16, 2024, 03:07:40 pm »
It's probably the RAM, happened to me too. I just leave it stock, OC only the CPU.
You'll get nothing out of that extra 5% OC else that lockups.
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 
The following users thanked this post: Aldo22


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf