Author Topic: New Hantek DSO2X1X models?  (Read 47766 times)

0 Members and 2 Guests are viewing this topic.

Offline tv84

  • Super Contributor
  • ***
  • Posts: 2242
  • Country: pt
Re: New Hantek DSO2X1X models?
« Reply #425 on: June 14, 2021, 01:18:50 pm »
Winbond SPI NAND chip includes a small OTP memory area (One Time Programmable), it's very possible that firmware updates get somehow recorded, we just don't know.

I don't believe that they would go to all that trouble with such a device. Bigger brands don't do it...
 

Offline tttonyyy

  • Regular Contributor
  • *
  • Posts: 54
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #426 on: June 14, 2021, 01:45:49 pm »
It seems unlikely.  But there may have been a flag file or other metadata created or modified in the filesystem as part of the original upgrade.

I was a little suspicious of /dso/etc/check_sys_inf executable but it turns out it's just a helper to extract values given a key from the .inf file.  For example from my filesystem dump running it on an Raspberry Pi:

pi@raspberrypi:~/tmp/backup $ ./filesystem/dso/etc/check_sys_inf ./config/system.inf Model
DSO2D15

There is also an intriguingly named executable /dso/app/spi containing strings like "fpga dev open failed" which I assume is used for some FPGA actions.
 

Offline bobikolev

  • Newbie
  • Posts: 1
  • Country: bg
Re: New Hantek DSO2X1X models?
« Reply #427 on: June 14, 2021, 03:19:16 pm »
Hi guys I'd like to share my experience with my new DSO2C10, which I bought on 20.04.2021 from Aliexpress for 202$.
When I received it it was showing : Software-1.0.1.1.0(20210416.00),hardware-000........000,Firmware-3200. After the
latest update I downloaded from the Hantek site , which was 20210416, firmware changed to 3000 and calibration broke
giving every time error 511d1 when I try to caliblrate, then I did the following thing to restore it and even make it DSO2D15.
First I opened it to confirm the mainboard is model  DSO2D15_V1.7 2021.1.14 and all parts regarding GEN are present.
Second I downloaded from https://drive.google.com/drive/folders/1Tqk8YbL_M3S0vtk7h_cZ-01U2idIaqqx, provided by "DavidAlfa"
"filesystem_20210416 backup" , "do_other_update(Restore filesystem)" from scripts forlder and "dso3kb_20210510" from
firmware folder, all these files unzipped on root dir of usbdrive.
Rename "do_other_update(Restore filesystem)" to "do_other_update"
Create folder "backup"insert in this folder unzipped "filesystem_20210416" and raname it to "filesystem"
in "filesystem" folder find two files (sys_inf.new and system.inf) and edit them with Notepad++ as described earlier
to give it model 2D15, serno (yours) ,maker(hantek) and pcb 000...001 , then save both files, insert usbdisk and make
firmware upgrd, after finish restart and you got 2D15, but still calibration don't work and gives error 511d1.
Unzip firmware "dso3kb_20210510" and make the upgrade, after finish you can go thrue calibration with no problem, remember
to remove any leads from the device before calibration.
Now the only problem remain for me is the noise the device have, which is unacceplable. My suspect for that noise is
the internal switched power supply, but will take some time to create and install analog power supply and check.
At the same time I bought Fnirsi1014D scope, which uses power adapter 5V/2A far enough from the device, this one don't have
such noise and the line is "clear" like it should be.
The generator works fine at output levels above 500mV, below this the sinusoide is "stepped".
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1021
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #428 on: June 14, 2021, 03:54:05 pm »
Sorry but, might I ask why the f*** you did all that?

latest update I downloaded from the Hantek site , which was 20210416, firmware changed to 3000 and calibration broke
20210416 doesn't change the FW, so you clearly messed up by flashing something you shouldn't.
That's what happens when you go at your own without reading anything.
Either you ran update on dso3kb_20201221 or flashed it with platform-tools FW3000 version.
« Last Edit: June 15, 2021, 12:48:50 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline QuitButton

  • Contributor
  • Posts: 34
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #429 on: June 14, 2021, 04:02:16 pm »
One thing about a probe, when the clip is removed, should there be a probe point? I am probably doing something wrong because the probe tip is in the hook part and so the probe accessories like the spring and yellow covers etc. have no use, and the probe can't be used without the hook. Perhaps the PP-150B just means PP-150 (broken version). Perhaps my understanding falls a bit short and you can of course forget a lot in 40 years!

Simon

Seems you are not the only one with probes that break. These probes look the same as what I had supplied with my 'scope.

https://youtu.be/z96tFMKTDww?t=940
« Last Edit: June 14, 2021, 04:04:09 pm by QuitButton »
 

Offline Piton

  • Contributor
  • Posts: 44
  • Country: ua
Re: New Hantek DSO2X1X models?
« Reply #430 on: June 15, 2021, 11:24:53 am »
Today I accidentally discovered that when you press the "Default Settings" button for a long time, new options for setting up and checking the parameters of the oscilloscope appear. It looks like there is also a generator calibration.
 
The following users thanked this post: eevbstedt

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1021
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #431 on: June 15, 2021, 11:31:46 am »
Nice!
I pressed Default setup for more than 30 seconds...Not happening here.
Maybe it needs to be in a specific screen/option?
How are you doing It exactly? What SW?
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline Piton

  • Contributor
  • Posts: 44
  • Country: ua
Re: New Hantek DSO2X1X models?
« Reply #432 on: June 15, 2021, 11:38:05 am »
I have version b000. The device is at work, I'm at lunch. Later in the evening I will take a picture and post it.
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1021
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #433 on: June 15, 2021, 12:54:51 pm »
Everyone, please check this folder:
https://drive.google.com/drive/folders/12kRZ7GMdFLtON1bypmu-cVSbZOG2Qdtg

If you have a FW version not listed there, please run the update "BACKUP FW".
It will backup your fgpa config file into the usb. Then upload it to my writable folder in Gdrive (Add a prefix describing the FW version).
That file seems the most important file of the scope, so better to have backups of all types.
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 
The following users thanked this post: eevbstedt

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1021
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #434 on: June 15, 2021, 02:39:43 pm »
Does Waveform saving work for anyone? No matter the SW version, it's always disabled. Either for internal and external.
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline SimonM

  • Contributor
  • Posts: 35
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #435 on: June 15, 2021, 10:01:46 pm »
I'm using the SDO2D15 AWG as a signal generator to a separate scope. The sinewave is 1Mhz which is well within what's possible with the AWG. There is no modulation and so you would expect to see almost a pure sine wave.

I noticed that there is a burst of noise in the same position on many (but not all) cycles. If I switch to a square wave the result is the same and there is a burst of noise which is at the same point on many of the square waves e.g. about 3/4 of the way through.

I'm triggering a single shot with the trigger starting below the square wave and lifting the trigger point until it triggers. It's easier to trigger it with the square wave, but forcing trigger catches it, almost every time too.

I can use the SDO2D15 to also capture the square wave, but then I don't know if it's from the AWG or the scope or crosstalk, etc. Using the second scope shows it is from the AWG. I'm not sure if the AWG is updated with the firmware (April 21 release and 3000 version).

The attached shows what you get and the duration of the "noise" (1/10 of a cycle).

[attachimg=1][attachimg=2]

Simon
 

Offline imk

  • Regular Contributor
  • *
  • Posts: 157
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #436 on: June 15, 2021, 10:12:24 pm »
Simon,
Is the glitch the switching psu in the Hantek?
BTW i just downloaded a nice little app for Android Phone by 
https://play.google.com/store/apps/details?id=com.keuwl.functiongenerator&hl=en_GB&gl=US
Works well 10khz plus on Sine wave, but sq wave has much ringing but is ok for free pocket wave gen with two channels.
imk
1201 Alarm
 

Offline tttonyyy

  • Regular Contributor
  • *
  • Posts: 54
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #437 on: June 15, 2021, 10:16:45 pm »
Does Waveform saving work for anyone? No matter the SW version, it's always disabled. Either for internal and external.

Yes with SW 20210517 / FW 3202.  I can save waveform to internal memory and recall correctly.  And save/recall from USB.  First time I've seen the on-screen keyboard for file naming.

"Save to USB" button does not work any more, though.
« Last Edit: June 15, 2021, 10:31:46 pm by tttonyyy »
 

Offline imk

  • Regular Contributor
  • *
  • Posts: 157
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #438 on: June 15, 2021, 10:36:02 pm »
Simon,
Have you tried getting a few feet of wire (single core probably best) and wrapping some turns around a former like middle of kitchen towel roll.
And use it as an aerial to see what is radiating at that Hz
imk
ps how do you like new scope?
 
1201 Alarm
 

Offline tttonyyy

  • Regular Contributor
  • *
  • Posts: 54
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #439 on: June 15, 2021, 10:47:57 pm »
Simon I see the same noise burst on mine.  Most often in the position you identify but it also shifts elsewhere in the cycle.

If I clip my probe ground to the tip to form a loop, I see the same, little 100MHz bursts singing away.  And this is with the AWG switched off.  I can trigger on them quite easily.

I put this down to being in an electrically noisy environment (laptop, monitors, network switches etc) but if you are seeing the same then maybe it's the scope itself?
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1021
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #440 on: June 16, 2021, 01:51:00 am »
Yeah I also get that terrible noise even when coupling to GND! No matter if the probe is shorted or removed.

Hmmm, the 5G is destroying our lives ;D
To make it worse, I'm taking the Covid shot in 3 days, I hope the nanobots are EMI friendly!
Jokes appart, that's really annoying.

I'd blame the on-board buck regulators that provide 1.1V & 1.9V (SIK, TLV62565  1.5MHz).
Would it get better by replacing R83 and R174 with chokes?

Also, the display has 2 switching regulators for the bias (TPS65150, 1.2MHz) and the backlight (SZL, TPS61169, 1.2MHz).

So there are a lot of switchers there. I guess if they should have shielded them, I don't think it's nice when you chase mV accuracy.

Also I don't like the switched  +-8V outputs directly feeding the analog. It's screaming for some filtering.
« Last Edit: June 29, 2021, 02:57:39 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline Piton

  • Contributor
  • Posts: 44
  • Country: ua
Re: New Hantek DSO2X1X models?
« Reply #441 on: June 16, 2021, 12:57:17 pm »
There are also happy owners of the "Default Settings" button with additional functions, or am I the only one?
 

Offline imk

  • Regular Contributor
  • *
  • Posts: 157
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #442 on: June 16, 2021, 01:30:07 pm »
There are also happy owners of the "Default Settings" button with additional functions, or am I the only one?
Piton,
I was a very happy owner of this little scope and can live with the features like noise, offset errors and  display going nuts at 8meg mem depth etc.
As it is a cheap scope that has a lot of function, hence for what i need it for i can forgive a lot, what does it for me is it locking up and have to be power cycled.
(Power cycling is a killer e.g. my workshop PC i use for 3D printing is getting old, runs all day without a glitch, yesterday powered it off this morning powered on and dead :-( )
If Hantek would fix all these lockups so i didn't have to power cycle it i would not be too unhappy.
I have opened a return with banggood but it is near the end of 30 day return window so a return might not happen, what then i don't know.
imk
PS did you try the 30 sec press of Default test again?
« Last Edit: June 16, 2021, 01:32:53 pm by imk »
1201 Alarm
 

Offline QuitButton

  • Contributor
  • Posts: 34
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #443 on: June 16, 2021, 04:18:19 pm »
So I'm pulling the trigger on a return and have ordered a Siglent SDS1202X-E instead.

My cat is currently trying to get inside the box my SDS1104X-U was supplied in  :-+

First Impressions? OOOh nice display!.. Gah! Fan!

Is there a thread for the SDS1104X-U? I have a few questions (one being why I'm struggling with a simple serial decode, lots of "Over length" message).

 :-+ :-+ :-+

 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1021
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #444 on: June 16, 2021, 04:31:04 pm »
It costs twice as the hantek, but the reviews look a lot better!
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline imk

  • Regular Contributor
  • *
  • Posts: 157
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #445 on: June 16, 2021, 05:02:21 pm »
So I'm pulling the trigger on a return and have ordered a Siglent SDS1202X-E instead.

My cat is currently trying to get inside the box my SDS1104X-U was supplied in  :-+

First Impressions? OOOh nice display!.. Gah! Fan!

Is there a thread for the SDS1104X-U? I have a few questions (one being why I'm struggling with a simple serial decode, lots of "Over length" message).

 :-+ :-+ :-+

Why not start a new thread and post the link as i am interested in one.
As for over length msg, maybe it has inbuilt serial msg buffer and your serial msg is blowing it, maybe try a shorter msg.
(My cat cry for dinner, FEEDING TIME AT THE ZOO!)
1201 Alarm
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1021
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #446 on: June 16, 2021, 05:14:19 pm »
Donate one to me, I'll start the hacking right now  :-DD
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline 2N3055

  • Super Contributor
  • ***
  • Posts: 3644
  • Country: hr
Re: New Hantek DSO2X1X models?
« Reply #447 on: June 16, 2021, 05:38:48 pm »
So I'm pulling the trigger on a return and have ordered a Siglent SDS1202X-E instead.

My cat is currently trying to get inside the box my SDS1104X-U was supplied in  :-+

First Impressions? OOOh nice display!.. Gah! Fan!

Is there a thread for the SDS1104X-U? I have a few questions (one being why I'm struggling with a simple serial decode, lots of "Over length" message).

 :-+ :-+ :-+

google this: "site:eevblog.com SDS1104X-U". You will get several results..
 

Offline imk

  • Regular Contributor
  • *
  • Posts: 157
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #448 on: June 16, 2021, 05:57:35 pm »
Donate one to me, I'll start the hacking right now  :-DD
Catch your own :-)

« Last Edit: June 16, 2021, 06:16:07 pm by imk »
1201 Alarm
 

Offline Piton

  • Contributor
  • Posts: 44
  • Country: ua
Re: New Hantek DSO2X1X models?
« Reply #449 on: June 16, 2021, 07:01:19 pm »
imk, i agree with you that this model does not work properly yet, although my copy works well, except for one freeze (during auto measurements with 2 channels, one does not freeze) and is not very stable in some synchronization modes. Maybe Hantek will fix everything, or the guys from EEVblog who have already done a lot of things here. Therefore, I have already ordered RIGOL DS1102Z-E, and I will sell this one. Although a little sorry, I would be completely satisfied with it, especially for the money that I spent on it.
« Last Edit: June 16, 2021, 07:04:05 pm by Piton »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf