Author Topic: New Hantek DSO2X1X models?  (Read 48744 times)

0 Members and 3 Guests are viewing this topic.

Offline michal_nt1

  • Contributor
  • Posts: 6
  • Country: pl
Re: New Hantek DSO2X1X models?
« Reply #525 on: June 24, 2021, 10:44:18 pm »
Hi Imk,
 The thing is that Im not really sure if  the device was working ok or not, I recall some things but I cant tell for sure...
I wish that the owners of this scope would make  a check  in  the ROLL mode in  frequencies lets say between 50 Hz and  2 kHz and share their results . Whats funny when I go above about 100 kHz  the waveform becomes "human readable" but it
looks like the trace expands or shrinks depending on the frequency..   I think that what I should see in the roll time  is a period passing  by from right to left with given time by the  sec/div  knob ...
Correct me if Im wrong .
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #526 on: June 24, 2021, 10:45:56 pm »
Another really annoying issue I found today.
If you set adquisition in average mode (ex. to clean up the signal), when you save the picture it will save the last, non-filtered snapshot!
Damn you Hantek!

Edit: It turns out it was the avg is resetted inmediately after saving, but the picture is ok.
But if you push stop, then yes, it will be resetted!

michal, the wave issue is because you're breaking nyquist (sampled signal frequency/ adcs ample rate), and hantek does pretty much nothing to filter it.
You can see that with the wavegen...ex 1KHz, it will look ok at 200uS/div, but if you go back to 10...100mS range, it will show a completely different signal.
« Last Edit: June 25, 2021, 10:30:54 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline michal_nt1

  • Contributor
  • Posts: 6
  • Country: pl
Re: New Hantek DSO2X1X models?
« Reply #527 on: June 24, 2021, 11:32:21 pm »
DavidAlfa,  thanks for a comprihensive  answer   :-+
 

Offline Gerasim

  • Contributor
  • Posts: 14
  • Country: ua
Re: New Hantek DSO2X1X models?
« Reply #528 on: June 27, 2021, 03:20:53 pm »
Hello Michal! I have a big request for you. Can you back up your 2d15 for me? It’s very simple. Go to the DavidAlf folder with the name GDrive. There you will find the file "dso3kb bakup builder.upk". Copy it to your USB stick and run it on your device. After that, a new file will appear on your flash drive - your backup copy. I would really like you to send it to me, but rather leave a download link in this thread. At one time I did not create such a copy and now I am suffering. Thank you!
« Last Edit: June 27, 2021, 05:00:14 pm by Gerasim »
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #529 on: June 28, 2021, 04:33:22 am »
What issues are you having?

The serial, model, HW, FW version, wavegen calibration... All can be restored easily with the available mods.
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline michal_nt1

  • Contributor
  • Posts: 6
  • Country: pl
Re: New Hantek DSO2X1X models?
« Reply #530 on: June 28, 2021, 11:04:06 am »
Hi Gerasim,
 The problem is that I dont have original files either... Briefly, my scope came with  version 20201221 and FW 3000, then I upgraded it to  dso3kb_20210416,
then downgraded to dso3kb_20210311 (for testing purposes) and the scope started to freeze. After couple of restarts it became nonresponsive.
 ( I could see the screen, like 2 relay cliks on start  and beeps when keys pressed and that was about it ... .) To  fix the scope I used  platform tools 20201221, 
it fixed it but some ID's were removed  like model and serial, so I used the script form DavidAlpha to change ID's. Luckly I had pictures of ID's taken before. Then I realized  that there was an issue with calibration , because platform tools uses diffrent FW  so to fix calibration  upgraded from utility menu using the firmware changer  dso3kb_FW3000 in DavidAlfa's folder,  that changes FW to original 3000. Now I hope everything is as it was before upgrades.  Who knows...   Everything you need with instructions is in DavidAlfa's google drive.
« Last Edit: June 30, 2021, 04:58:49 pm by michal_nt1 »
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #531 on: June 28, 2021, 11:45:55 am »
Check the FAQ in my signature to see what updates can be applied safely. As long as FW is not changed, everything will be ok :-+
Platform-tools 20201221 also uses FW3000, so there shouldn't be any issues?

I also had a lot of freezing 2 weeks ago.
All seemed correct, fw , model were ok, but it freezed very easily. I'm pretty sure I had flashed platform-tools 20201221 and then upgraded to 20210416.
Since then I flashed it few times already.
Currently, everything is undefined, I only bothered to restore the wave gen calibration... and no freezing!
« Last Edit: June 28, 2021, 11:52:29 am by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline Gerasim

  • Contributor
  • Posts: 14
  • Country: ua
Re: New Hantek DSO2X1X models?
« Reply #532 on: June 28, 2021, 01:56:15 pm »
Thank you for your answers! But I know all this and at the moment I have a copy, which was provided to me by DavidAlfa. I also used the generator calibration file. In principle, everything suits me, except for small moments. The generator works quite well at voltages above 1v, but as the voltage drops, the shoulder skew increases greatly. So everyone? It is possible that Hantec calibrates the generator separately for each scope and therefore the calibration files of different devices may not match. So I wanted to try installing a backup from other devices, hoping that the result would be better.
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #533 on: June 28, 2021, 05:44:12 pm »
That's because your calibration is wrong, make a new one!
The same happened to me:
https://www.eevblog.com/forum/testgear/new-hantek-dso2x1x-models/msg3585539/#msg3585539
« Last Edit: June 28, 2021, 05:46:28 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline Gerasim

  • Contributor
  • Posts: 14
  • Country: ua
Re: New Hantek DSO2X1X models?
« Reply #534 on: June 28, 2021, 06:54:46 pm »
We probably didn't understand each other). I meant the offset of the generator amplitude in min and max. I've calibrated many times and reset the scope to default. It does not help. Only by manually shifting the amplitude can you more or less achieve some result and set the signal to the center. But I wish I didn't have to do this. But that's okay! Will live!)) :popcorn:
« Last Edit: June 28, 2021, 07:12:21 pm by Gerasim »
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #535 on: June 28, 2021, 08:37:11 pm »
I've been debugging i2c signals. Must say that at least this decoder work great!
Here the overclock makes a brutal difference:


Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 
The following users thanked this post: eevbstedt

Offline imk

  • Regular Contributor
  • *
  • Posts: 157
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #536 on: June 28, 2021, 09:50:28 pm »
I've been debugging i2c signals. Must say that at least this decoder work great!
Here the overclock makes a brutal difference:


Hello David,
I found the i2c decoder worked VERY well at times, but sometimes I have lockup issues and had to power cycle, then after restart the i2c decoder would not sync correctly so i had to power cycle it a second time to get it to work correctly , most odd.
So are instruction for the overclock on your gdrive and how much did you overclock by please.
ian
1201 Alarm
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #537 on: June 28, 2021, 11:30:44 pm »
Everything is inside Mods / Overclocking folder.
By default it's set to 696MHz(CPU) / 192MHz (RAM). More than that crashed for me.
To change the multipliers, check the script "oc_manager", edit it before running the update package, as thefiles in the usb/overclock folder are copied to the system.
If you want to change the multipliers after installing, just edit the usb files and run the installer again, no need to remove first.

However, I found an issue, only if you flashed platform-tools 20210517. 20201221 and 20210129 are ok.
The keyboard kernel module doesn't output keyboard messages like previous versions, so the overclock script won't be able to detect if you pushed F0 key to skip it.
If the system hangs, then the only way to recover will be platform tools.
However I tested replacing that file (/dso/etc/fpga_i2c_kbd.ko) with the 20210129 version, and it works.
Last update that changes that file is 20210311.


« Last Edit: June 30, 2021, 05:29:53 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline rtausx

  • Newbie
  • Posts: 4
  • Country: do
Re: New Hantek DSO2X1X models?
« Reply #538 on: June 29, 2021, 01:22:17 am »
I'm new to this community. I started running into some issues with my new DSO2C10 today. It started freezing a lot trying to decode some I2C to the point where it would not respond at all after a reboot; the default setup button did not respond at all.

After a few hours of reading around the forum, I decided to try the platform-tools but it seems that the ones available at DavidAlfa's Gdrive are not suitable for my FW version.  :-//

I think I need the platform tools for FW3200, does anyone have it?

I tried the three available in the Gdrive and after restarting the scope it will just show the Hantek logo...

Thanks

 

Offline rtausx

  • Newbie
  • Posts: 4
  • Country: do
Re: New Hantek DSO2X1X models?
« Reply #539 on: June 29, 2021, 01:24:13 am »
I'm new to this community. I started running into some issues with my new DSO2C10 today. It started freezing a lot trying to decode some I2C to the point where it would not respond at all after a reboot; the default setup button did not respond at all.

After a few hours of reading around the forum, I decided to try the platform-tools but it seems that the ones available at DavidAlfa's Gdrive are not suitable for my FW version.  :-//

I think I need the platform tools for FW3200, does anyone have it?

I tried the three available in the Gdrive and after restarting the scope it will just show the Hantek logo...

Thanks


Forgot to mention that my scope was running FW3200, 20210416 before all this.
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #540 on: June 29, 2021, 02:06:34 am »
Try flashing any platform tools version you like. I'd try the latest. Then use FW changer to restore FW3200.
But before flashing anything try to backup your system with the backup builder!
If it hangs shortly after boot, try pressing quickly default setup button, hopefully it will be enought to run the mods.
« Last Edit: June 29, 2021, 02:10:40 am by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline rtausx

  • Newbie
  • Posts: 4
  • Country: do
Re: New Hantek DSO2X1X models?
« Reply #541 on: June 29, 2021, 03:03:38 am »
Try flashing any platform tools version you like. I'd try the latest. Then use FW changer to restore FW3200.
But before flashing anything try to backup your system with the backup builder!
If it hangs shortly after boot, try pressing quickly default setup button, hopefully it will be enought to run the mods.

Thanks for getting back to me. I actually tried the latest platform-tools 20210517 and wanted to clarify that after it finished flashing, the scope rebooted as expected but it's now stuck with the Hantek logo so I have no way to get to the system update menu unfortunately.

I think I soft bricked it by using the wrong platform tools for my fw version 3200.

I will appreciate any further insight.
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #542 on: June 29, 2021, 01:06:20 pm »
I'm pretty sure it failed uploading some file and you didn't read the update window.
First remove the USB drive, you can't have both plugged in.
As far a I know it's impossible to brick it.
Read my FAQ. USB 3.0 ports give problems.
Read carefully the output of the update process.
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 
The following users thanked this post: rtausx

Offline Gerasim

  • Contributor
  • Posts: 14
  • Country: ua
Re: New Hantek DSO2X1X models?
« Reply #543 on: June 29, 2021, 02:11:40 pm »
rtausx I, too, a couple of times after using platform tools, the scope showed only a splash screen.  Repeat the procedure one more time.  Make sure that the driver is displayed correctly in the device manager and immediately run cmds.bad.  And if the driver is not detected, then reinstall it using zadig.exe.  And run cmds.bad right away.  Good luck!
 
The following users thanked this post: rtausx

Offline rtausx

  • Newbie
  • Posts: 4
  • Country: do
Re: New Hantek DSO2X1X models?
« Reply #544 on: June 29, 2021, 02:44:15 pm »
DavidAlfa and Gerasim you guys rock!! I tried with another computer and it worked now. It was either driver not installed correctly or because of USB 3.0 on my laptop (I tried 2.0 now).

To my surprise, my DSO2C10 has all the components for the function generator and it works like a charm. What a steal for $185!!!

Now that I feel safe with tinkering a bit more, it's time for OC.
Thx again
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #545 on: June 29, 2021, 07:15:07 pm »
I increased Vcore slightly over specifications.
Nominal is 1.1V, max 1.2V,  I got 1.25.
I'm currently testing and modifying the overclocking script, because I had to use the second PLL_K multiplier to go over 768MHz.
But it seems stable at 912MHz  :-DD
And factory default is 408MHz, not 384, I had missed that multiplier = Val+1 (default value16, but effectively 17)
« Last Edit: June 29, 2021, 07:18:13 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline imk

  • Regular Contributor
  • *
  • Posts: 157
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #546 on: June 29, 2021, 08:11:38 pm »
I increased Vcore slightly over specifications.
Nominal is 1.1V, max 1.2V,  I got 1.25.
I'm currently testing and modifying the overclocking script, because I had to use the second PLL_K multiplier to go over 768MHz.
But it seems stable at 912MHz  :-DD
And factory default is 408MHz, not 384, I had missed that multiplier = Val+1 (default value16, but effectively 17)
David
The overclock interests me, but i am little concerned about temperature rise.
Did you happen to do a pre and post overclock temperature check?
imk

1201 Alarm
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #547 on: June 29, 2021, 08:32:54 pm »
I already said a few times. It barely gets warm.
The worst that can happen woudl be a system crash, requiring reboot.
Don't try it yet,.I'm updating the overclocking script.
« Last Edit: June 29, 2021, 10:12:12 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 

Offline imk

  • Regular Contributor
  • *
  • Posts: 157
  • Country: gb
Re: New Hantek DSO2X1X models?
« Reply #548 on: June 29, 2021, 09:25:51 pm »
Ok David
Thanks for info, i'll await an update.
Ian
1201 Alarm
 

Online DavidAlfa

  • Super Contributor
  • ***
  • Posts: 1078
  • Country: es
Re: New Hantek DSO2X1X models?
« Reply #549 on: June 30, 2021, 03:50:51 am »
Achieved 1GHz at 1.35Vcore! 250% original speed!  :-BROKE

Code: [Select]
# pi 1000000
Starting PI...

 Pi:    3.141592653589794004176383168669417500495910644531250000000000
 Loops: 1000000
 Time:  9935mS

# oc_manager
[  191.748086] Overclocking CPU to 1044MHz...

# pi 1000000
Starting PI...

 Pi:    3.141592653589794004176383168669417500495910644531250000000000
 Loops: 1000000
 Time:  3878mS



And the Voltage/Frequency table I found in my tests:
Code: [Select]
1,1V 720MHz
1,15V 792MHz
1,2V 864MHz
1,25V 936MHz
1,3V 972MHz
1,35V 1044MHz

About 70MHz gain per 50mV step. Except the weird spot at 1.3V.
« Last Edit: June 30, 2021, 07:07:29 am by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ
Stm32 Soldering FW      Forum      Github      Donate      I need calibration reports!
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf