EEVblog Electronics Community Forum

Products => Test Equipment => Topic started by: costas on September 27, 2012, 04:58:13 am

Title: Osciloscope Owon HDS 1022M-N
Post by: costas on September 27, 2012, 04:58:13 am
Hello,
A two years agou I buy from Owon two osciloscope (PDS6062(T)+HDS1022M-N ) I am very happy with them , unfortunately with HDS1022M-N I had an accident, I dropped down , now no output on screen and the screen is't illuminated, I did not see anything broken or cracked in it , I change the display with another new but the same problem ... the backlight not working , ater power I hear a "buz" but not relay "dita" , I compare this nois with working device , is just a buzer from mesurment block ,
on the mine board I find just 3,3v power suply , other power suply does not work ...
The Owon enginiers told mabe is a firmware problem !!! the firmware are stored in 39LV3201 flash , mabe somebody have read a good firmware for this HDS1022M-N . or can tell me the pin configuration from J-tag connector from the main board , I want to try to read flash 39LV3201 under ARM prcocesor.....Somebody try this ?
Thank you ,
Costas
Title: Re: Osciloscope Owon HDS 1022M-N
Post by: Dread on September 27, 2012, 09:22:53 am
I am not sure I understand. Are you saying part of the power supply is dead after the unit fell and you think it's a firmware issue?  Seems to me like Owon did not understand the problem and gave you bad info.  I would trouble shoot the dead power rail and see why it's not working. There may be a hair line crack on a trace or some other part has been damaged or broke a solder connection.
Title: Re: Osciloscope Owon HDS 1022M-N
Post by: glicos on September 27, 2012, 10:13:08 am
i agree with dread. firmware inside flash ic can't just be erase by dropping the unit. look for microcrack on board or loosed parts inside
Title: Re: Osciloscope Owon HDS 1022M-N
Post by: costas on September 27, 2012, 11:51:16 am
Hello ,
I looked very good motherboard but I found nothing detached or broken,... I got only 3,3v power on the main board , Other power supply is controlled by procedure so when CPU procedure working wrong, then there is only 3.3v on mainborad (because other power supply is closed). So if I only measure 3.3 V then it should be because the SW procedure in mainboard doens't work, so mainboard got problem or SW.

Thank you .
Costas
Title: Re: Osciloscope Owon HDS 1022M-N
Post by: Dread on September 27, 2012, 02:52:57 pm
This is just me but if that's the case I would find a point in the dead powerline and desolder the last coupling component and inject in my own power (limiting the current) and see if it boots up.
I still have a hard time believing the chips firmware got corrrupted after a fall!
IMHO it's got to be physical damage issue somewhere, maybe something near that CPU.
Anyway it's your choice on how to proceed.