Author Topic: Quality problem with the EEVblog BM235 testprobes.  (Read 1628 times)

0 Members and 1 Guest are viewing this topic.

Offline Algojervia

  • Supporter
  • ****
  • Posts: 17
  • Country: se
Quality problem with the EEVblog BM235 testprobes.
« on: December 29, 2016, 02:01:06 am »
Hi
I bought the BM235 via the EEVblog homepage about a month ago and it works perfectly but...
The tip on one of the probe is somewhat loose and when I screw the banana plug thing on I don't get much tactile feedback at all that it is time to stop turning. As a mater of fact I have already accidentally rotated the tip an unknown number of revolution. The other tip does not behave like this at all and the tip does not rotate even when a moderate force is applied to turn it.
I assume that the wire is soldered to the tip and that I sooner or later will break the connection, but it guess it works as long as I keep my mind focused. :)

I guess fixing it might be hard but any ideas are welcome. And has anyone else reported this problem?

//AlgoJerViA
 

Offline Vgkid

  • Super Contributor
  • ***
  • Posts: 2519
  • Country: us
Re: Quality problem with the EEVblog BM235 testprobes.
« Reply #1 on: December 29, 2016, 02:35:15 am »
I think one of my Brymen probes does this as well. They always have so  :-// .
If you own any North Hills Electronics gear, message me. L&N Fan
 

Offline Algojervia

  • Supporter
  • ****
  • Posts: 17
  • Country: se
Re: Quality problem with the EEVblog BM235 testprobes.
« Reply #2 on: December 29, 2016, 05:03:35 am »
I think Dave would gladly replace the probe just to investigate the problem so maybe they should be replaced for that reason. It's just that the local postal service or rather the outsourced remains of a postal service had a hard time keeping track of all the papers involved when a packet arrived from such a strange and exotic country such as Australia, maybe they had a hard time reading australian or something. The thought of repeating that adventure makes me hesitate a bit.   :-\
 

Offline Vgkid

  • Super Contributor
  • ***
  • Posts: 2519
  • Country: us
Re: Quality problem with the EEVblog BM235 testprobes.
« Reply #3 on: December 29, 2016, 05:13:08 am »
I bought mine from Franky about(possibly over) a year ago. For mine, it is the negative(black) probe.
If you own any North Hills Electronics gear, message me. L&N Fan
 

Offline Algojervia

  • Supporter
  • ****
  • Posts: 17
  • Country: se
Re: Quality problem with the EEVblog BM235 testprobes.
« Reply #4 on: December 31, 2016, 04:45:45 pm »
I bought mine about two months ago directly from Dave but it is the red one, maybe yours and mine are old friends. :)
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf