Author Topic: SCPI (VISA) query commands with "?" on Rigol DG1032Z AWG  (Read 1053 times)

0 Members and 1 Guest are viewing this topic.

Offline aharmony

  • Contributor
  • Posts: 6
SCPI (VISA) query commands with "?" on Rigol DG1032Z AWG
« on: November 20, 2017, 02:26:02 pm »
Hi everyone!

I'm hoping that someone here might be able to shed some light on the troubles I'm having using SPCI on the Rigol DG1032Z waveform generator. I am new to SPCI, so maybe it is something I am misunderstanding with the syntax I am using.

I've got one one of these Rigol AWGs in the lab (firmware 00.01.12 - most recent) and am having troubles with certain SCPI commands sent to the device. I'm trying to set up some automated data logging with the instrument, but for some reason many of the SPCI commands including a '?' to receive values from the instrument throw the SPCI error "-113 Undefined header".

The instrument connects over VISA(USB) just fine. I can identify the instrument with *IDN? just fine and even send a lot of setting commands to the DG1032z, and they work just fine without error (for example, the setting command COUNter ON to turn on the frequency counter function, or COUN:COUP AC to turn the frequency counter to AC coupling). But for some reason, many of the commands including a "?" that query information from the device all throw Error 133.  :-//

Some "?" commands work, but others do not. For example, COUN:FREQ? does not work, and throws error 113. But COUN:COUP? does indeed return the coupling of the frequency counter function.

Ultimately I am logging data through MATLAB, but I have minimised the SCPI setup for debugging this issue by sending/reading SCPI over VISA(USB) directly with Rigol's Ultra Sigma software. I have also tried with the VISA terminal in Keysight's Connection Expert utility, and the same results are repeated there.

Maybe there is something that I am missing with my understanding of the SCPI syntax for this device, but even the examples shown in the DG1000 Programming Guide throw error 133. Can anyone spot something amiss? Or does anyone know if there are some SCPI irregularities with this particular test instrument? As I mentioned above, I've updated the DG1032z to the latest firmware from Rigol to see if it's a bug and if that fixes the problem, but the results are the same even on the fresh firmware. So I'm hoping that I am misunderstanding! Thanks for any help.

Here are some example queries and their results, screencapped...

« Last Edit: November 20, 2017, 02:27:44 pm by aharmony »

Offline aharmony

  • Contributor
  • Posts: 6
Re: SCPI (VISA) query commands with "?" on Rigol DG1032Z AWG
« Reply #1 on: November 20, 2017, 03:35:00 pm »
Oooh, well then! Case solved. I'm an idiot  :palm: After a day of wrestling with this yesterday and fumbling around with it today some, I have now realised that I was using commands from the DG1000 Programming Manual from Rigol - not, in fact - the DG1000Z Programming Manual.  |O

So for anyone else that might have that problem (I doubt it...) here's the solution: The DG1000 and DG1000Z have different programming manuals! D'uh!

All works well now!  :-+

Offline _Wim_

  • Super Contributor
  • ***
  • Posts: 1097
  • Country: be
Re: SCPI (VISA) query commands with "?" on Rigol DG1032Z AWG
« Reply #2 on: November 20, 2017, 08:00:43 pm »

I know that feeling! Happens to the best of us. Good to have solved it yourself!

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo