Products > Test Equipment

Rigol DG2000 function generator - NIVISA with Win7/64bit

(1/2) > >>


I tried to communicate with a DG2021A function generator via VISA/USB with Win7/64bit  today, but I had not much success.
Initially I somehow managed to get it installed as "DGX000", but each time I tried to connect ended in a bluescreen due to an issue with USBTMC.
So I uninstalled the USB driver but then read a comment about VisaSharedComponents64_1.4.msi fixing the bluescreen issue with Win/64bit, so I installed that. As a result, the generator is listed as "USB Test and Measurement Device (IVI)" but neither UltraWave nor Ultra Sigma can detect in in any way. Also my own C# program doesn't detect the device at all.
Now if I install the Agilent Visa (IOLibSuite_16_2_15823) on top, the "Agilent Connection Expert" as well as my own C# program detect the device and can connect, but the generator doesn't answer to any command (not even "*IDN?") and I get error codes like this:
" ! VI_ERROR_NCIC: Not the controller-in-charge / Visa ErrorCode: 0xBFFF0060 (-1073807264)"

I also tried to connect via LAN, but the behavior is about the same.

Unfortunately, the whole driver and documentation situation is a little bit confusing to say the least. I tried several versions of several installers from several Rigol and other sites, but most of them either stopped or complained about wrong OS version or whatever. All in all it's not even clear to me if I need to install a dedicated USB driver or not - and if so, if there is a driver available for Win7/64bit at all. All the USB driver installers I found for the DG2000 series would not install in Win7/64bit.
Don't ask how I managed to install that DGX000 driver. I really dunno.

So was anybody succesful to get a DG2041A or DG2021A to communicate via VISA/USB?
Any hint is appreciated...

I have the DG2041A and the USB connectivity never worked for me either. Some say it's a Windows 7/Vista thing, but I've also tried it with Windows XP and that didn't work either. At one pont I also got the DGx0000 name population in device manager, and other times it would restart my computer with a blue screen of death if I even plugged in the USB cable.

Right now I am using a USB-to-RS232 adapter to communicate with it; it is slow and crappy, but it works.

Hm, ok, I kinda feared so.
The frustrating thing is that I can see the device listed as USB and TCPIP and then either connecting or sending commands fails. This also seems to indicate that it's not a missing USB driver, but a general issue.

Then again, remote control via the web interface works and my main interest was to load arb signals from an USB stick, so this is just a minor annoyance. Still, being able to remote control via VISA would have been nice. So I'll try my luck with the support again, but I'm not very optimistic.

I got a reply from Rigol support, but it's kinda worthless:
"I'm afraid that you need to test on another PC which is not win 7".

Dunno what this is supposed to mean. Does Rigol really refuse to support Win7 or is this just a "if it doesn't work, try something else" statement? Anyway, it's not very helpful.

As a sidenote, I tried RS232, LAN and USB now and they behave all the same: the DG2021A is identified, but it doesn't respond to the *IDN? command. IMHO the DG2021A should answer to default SCPI commands over RS232 and LAN without any drivers.
So I would guess that this is more an issue of the DG's firmware. Unfortunately my question regarding a possible firmware bug and availability of an update was ignored as well...

To continue my monologue:

While the Rigol support was actually quite responsive and friendly, it wasn't very helpful.

Anyway, in  the  meantime,  I  was  able  to connect the DG2021A directly through a terminal program via the RS232 interface.
With this approach, the device reacts to SCPI commands as expected.

I  still  don't fully understand why connecting via RS232 or LAN using the NI VISA layer doesn't work at all.
My  understanding  was  that  NI  VISA is just an abstraction layer to transport the SCPI protocol over a physical layer (e.g. RS232 or USB).
As  RS232  and  TCPIP  are supported without any driver and my success using  a terminal program shows that the physical RS232 layer works as well as the SCPI implementation on the DG2021A, I'm kinda puzzled what exactly hinders the NI VISA layer from working.

Anyway,  I'm actually happy that I can remote control the device at all.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod