Author Topic: Rigol DP832 Firmware Update stuck?  (Read 1735 times)

0 Members and 1 Guest are viewing this topic.

Offline Tim5000

  • Contributor
  • Posts: 12
  • Country: gb
Rigol DP832 Firmware Update stuck?
« on: September 12, 2017, 08:46:43 pm »
Hi, I've got a Rigol DP832 on V1.08 firmware (and 1.05 boot) that I decided to update to the latest firmware.
I should first note that, although doing something stupidly wrong is entirely possible on my part, I'm usually updating something embedded in my own time every day - so it's not a new concept to me.

Anyway my problem is that I've followed the DP800 firmware update PDF and, armed with the latest firmware from Rigol, created my USB stick to upgrade the PSU.
I've also renamed the files as noted in the pdf as my starting firmware was < 1.0.9
I tested the stick could be seen by the power supply.

It's currently been running 20 mins stuck at 19.1/19.2 flickering....

Any thoughts please before I dare power cycle it?

EDIT: Not that it probably matters, but it has one official option fitted, and hasn't been unlocked etc.

EDIT2: Spotted this post so as it's now been ...a while...I power cycled without the USB stick in and the PSU has come back to life thankfully - phew!
These are the dropbox links Rigol supplied me with:

Bootloader 1.09:
Firmware 1.11:

Thanks. On 1.09, tried updating firmware first (as their previous guide instructs) but gets stuck on "19.2".
Trying bootloader -> firmware worked.

EDIT3: Performing the update in the opposite order to Rigol's PDF (as per the post above) worked successfully. Hopefully it might be useful for someone else int the future.
« Last Edit: September 12, 2017, 09:47:01 pm by Tim5000 »

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo