Author Topic: How to send a setup using :SYSTem:SETup on Rigol...  (Read 1762 times)

0 Members and 1 Guest are viewing this topic.

Offline alank2

  • Super Contributor
  • ***
  • Posts: 2138
How to send a setup using :SYSTem:SETup on Rigol...
« on: July 10, 2013, 04:06:36 am »
Hi,

Does anyone know how to format the setup data after this command?

:SYSTem:SETup <setup_data>

I've tried:

:SYSTem:SETup\n
#9000002493<data>

:SYSTem:SETup #9000002493<data>

:SYSTem:SETup #9000002493<data>\n

Maybe I did something wrong - does someone know?
 

Offline ve7xen

  • Frequent Contributor
  • **
  • Posts: 860
  • Country: ca
    • VE7XEN Blog
Re: How to send a setup using :SYSTem:SETup on Rigol...
« Reply #1 on: July 10, 2013, 04:17:05 am »
I assume in the same way :SYSTem:SETup? returns the data, which seems to work just feeding it back to the scope verbatim.

That format is:

:SYSTem:SETup #9000002579<data>\n

Beware that you're actually writing the bytes as they came from the scope though, as many mechanisms for doing this might be doing conversion to other character sets etc.

In other words, this code works:

Code: [Select]
config = rigol.ask_raw(":SYSTem:SETup?")
rigol.write_raw(":SYST:SET " + config)
73 de VE7XEN
He/Him
 

Offline alank2

  • Super Contributor
  • ***
  • Posts: 2138
Re: How to send a setup using :SYSTem:SETup on Rigol...
« Reply #2 on: July 10, 2013, 12:24:06 pm »
Thanks - your method worked!
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf