Products > Test Equipment

Rigol DS1054Z faulty, changing offset

(1/2) > >>

plazma:
My scope suddenly broke down. Now there is a changing offset depending on Y-scale. Self calibration didn't help.
I recently updated the firmware but can't say if the faut came directly after update or few days later.

In the attached pictures the probe is connected to the test waveform. Y-scale is changed between pictures.

The fault is in all channels. 1 & 4 also go negative. 2&4 only got positive changing offset.

Anyone seen the same before? Possible faults and fixes?
 

RoGeorge:
Try to downgrade the firmware to a former known working version, using the disk attached as a zip file in the linked message:
https://www.eevblog.com/forum/testgear/new-rigol-ds1054z-oscilloscope/msg3613778/#msg3613778

The disk attached there does not contain any firmware, it only contains a signature that makes a downgrade possible, you have to copy on that disk the firmware version you prefer to downgrade to.

Fungus:

--- Quote from: plazma on January 27, 2022, 09:27:19 am ---My scope suddenly broke down.
...
I recently updated the firmware but can't say if the faut came directly after update or few days later.

--- End quote ---

It's not a coincidence. Get it reflashed ASAP.

You can use the method in the previous post or this one


plazma:
Strange. Now the self-cal passed and the scope works normally again.

Thanks for the links. I'll save them incase I need to downgrade.

tautech:

--- Quote from: plazma on January 27, 2022, 10:11:52 am ---Strange. Now the self-cal passed and the scope works normally again.

--- End quote ---
Was there a reboot involved ?
Always good practice to reboot after a FW install.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version