Author Topic: arduino big problem !  (Read 1420 times)

0 Members and 1 Guest are viewing this topic.

Offline fadyeid

  • Contributor
  • Posts: 11
  • Country: eg
arduino big problem !
« on: May 02, 2017, 03:53:25 pm »
hello I am studying engineering so I have a project with aurduino ,

I have windows 8.1 and when I run the aurduino software and try to  upload gives me error not connected to com1 ,

I cant even install the driver for it

need help asap no time the project should be worked Thursday thanks
 

Offline igendel

  • Frequent Contributor
  • **
  • Posts: 326
  • Country: il
    • It's Every Bit For Itself (Programming & MCU blog)
Re: arduino big problem !
« Reply #1 on: May 02, 2017, 04:08:45 pm »
Arduino boards never show up on COM1. With the Arduino connected, open menu Tools->Port, and choose what is available there (like "COM3" or "COM10").
If no port is available, that's a different problem - maybe incorrect drivers.

Also, "Test Equipment" is probably not the right forum for this question   :)
Maker projects, tutorials etc. on my Youtube channel: https://www.youtube.com/user/idogendel/
 

Online Fungus

  • Super Contributor
  • ***
  • Posts: 12354
  • Country: 00
Re: arduino big problem !
« Reply #2 on: May 02, 2017, 04:17:53 pm »
If your "Arduino" is a cheap Chinese clone then you might need a special driver.

Clue: The trick is to look at the little serial controller chip on the board and read the number there.

PS: What does this have to do with "test gear"? Why aren't the Arduino forums a better place to ask?
 

Offline shteii01

  • Frequent Contributor
  • **
  • Posts: 266
  • Country: us
Re: arduino big problem !
« Reply #3 on: May 03, 2017, 01:12:50 am »
Arduino is an organization. 
Telling us that you have arduino, tells us nothing.
 

Offline amspire

  • Super Contributor
  • ***
  • Posts: 3802
  • Country: au
Re: arduino big problem !
« Reply #4 on: May 03, 2017, 01:22:19 am »
A photo will be good. If it was a recently purchased board, it could easily have a CH340 family RS232 to USB chip.

If it has a chip with a name like this, see this page:

http://www.arduined.eu/ch340-windows-8-driver-download/

You will need to know the type of Arduino board this clone is copying - an Uno? a Duemilanove? You have to configure the Adruino IDE correctly to the board type.

 

Offline DaJMasta

  • Super Contributor
  • ***
  • Posts: 2120
  • Country: us
    • medpants.com
Re: arduino big problem !
« Reply #5 on: May 03, 2017, 01:44:17 am »
You need to have the driver for the device installed, if it's a regular, brand name board of theirs, the drivers can also be found in Arduino\Drivers\ in the install directory.  Aside from that, you also need to make sure the serial port you're trying to program on is set correctly, the Port pulldown menu in the Tools menu in the IDE.

And yes, the beginners or microcontroller subforum is probably the right place for this.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf