Author Topic: R&S RTB2004 buggy - position/offset permanently hosed  (Read 242 times)

0 Members and 1 Guest are viewing this topic.

Offline javadesigner

  • Contributor
  • Posts: 45
  • Country: us
R&S RTB2004 buggy - position/offset permanently hosed
« on: March 27, 2021, 02:06:53 am »
So, I'm playing with my R&S RTB2004 (has the latest firmware), right ?

Edit: I set the probe attenuation to custom 0.1: 1 (not 10:1 or 1:1 but --> 0.1: 1)

When I drag the screen up and down an bit, randomly, somehow I start seeing Vertical -> Offset/Position showing "clipping".

But I should be able to reset this by either hitting the vertical center knob or by simply entering 0 for the offset/position numbers, right ?

Well, no! At this point:

1) The visual channel markers can't be dragged (top left on the screenshots)
2) Clicking the center knob does nothing
3) No number can be entered for either offset or position - at ALL. Upon entering any number (including 0), I get a "high limit reached" error message.

This is bad enough. Buggy. So I do a soft shutdown and restart (power button in front).

Scope reboots to exact same situation as above.

I tried again with all probes unplugged (all channels unplugged) - same situation as above.

I'll do a hard reboot then. I do a soft shutdown and then turn off the power switch on the back.

Scope again reboots to exact same situation as above.

You will note that there is literally no data going into the scope (all probes disconnected) but Offset/Position continue as "clipping" - even after a hard reboot. And no way to change this at all.

Please see attached screenshots.

 >:(  :palm:

PS: I finally managed to fix this by hitting "preset" on that channel.

Edit 2: was able to get to this state again - by twiddling vertical scale/position knobs. Track grid is turned on under display. Although the channel is set to 0.1:1 attenuation, no probes are connected to the oscilloscope at all. (note: 0.1: 1 isn't theoretical, it is necessary when for example, using a current probe that sends 10 mV for every 1 mA it reads).
« Last Edit: March 31, 2021, 06:32:15 pm by javadesigner »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf