Author Topic: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes  (Read 304152 times)

0 Members and 5 Guests are viewing this topic.

Offline e0ne199

  • Regular Contributor
  • *
  • Posts: 81
  • Country: id
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1650 on: April 10, 2020, 11:25:48 pm »
Apart from all:
We got a siglent SDS1104X-E at work, our colleague from R&D use it in his office and the noise level seems to me (and him) nearly quiet - Maybe you got a defective one ? (what the fan concerns)

didn't know it could be a serious tool 😁
 

Offline CiscERsang

  • Regular Contributor
  • *
  • Posts: 119
  • Country: za
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1651 on: April 11, 2020, 09:06:09 am »
Apart from all:
We got a siglent SDS1104X-E at work, our colleague from R&D use it in his office and the noise level seems to me (and him) nearly quiet - Maybe you got a defective one ? (what the fan concerns)

didn't know it could be a serious tool 😁

This tool was spotted twice in this video according to comments. People choose Siglent.  :-+



 
The following users thanked this post: djadeski

Offline patman27

  • Contributor
  • Posts: 7
  • Country: us
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1652 on: July 09, 2020, 02:45:34 am »
For anyone else having Wi-Fi connectivity issues with the SDS-1104X-E ...

When I tried to:
the scope would connect/disconnect/connect/disconnect endlessly. It just couldn't stick a connection.

TL;DR:

UniFi has a master setting that activates a handful of advanced features. I have this enabled on my network.
[attach=2]
That setting (and the features it enables, which are scattered all around) has a general disclaimer that stuff may break or become unstable. Go figure  :-DD

Most of the features work just fine. But there's one in particular that causes an issue with the Siglent scope.

This feature affects the 2.4 GHz band by default - the band used by the scope:
Enable 2G Data Rate Control
[attach=1]
It's intended to maintain a baseline network performance by enforcing minimums - namely a bandwidth floor - and disassociating devices that don't meet them. Good for enterprise networks. Bad for home labs.

Simply disabling this feature brought my scope online for good. Goodbye, ethernet!  :-+


Gory Details

At first I blamed Wi-Fi driver implementation in the Linux OS (my scope is rooted and "software-modified"). It didn't instill confidence to find that browser-based network settings (DHCP, subnet mask, etc) only affect the ethernet interface. They don't seem to touch the Wi-Fi interface at all. So I telnet'd in via ethernet and poked around.

I tried to connect the scope to Wi-Fi manually.
Code: [Select]
wpa_supplicant -dd -K -D wext -i wlan0 -c /usr/bin/siglent/usr/wifi/wpa.conf
My buddy and I found the following in the output:

Code: [Select]
...
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:00:00:00:00:00
wlan0: Event DISASSOC (1) received
wlan0: Disassociation notification
wlan0: CTRL-EVENT-DISCONNECTED bssid=xx:xx:xx:xx:xx:xx reason=0
wlan0: Auto connect enabled: try to reconnect (wps=0 wpa_state=9)
...

Turns out my AP was kicking the scope off the network.

So much for that blame game   ;D

Edit: clarity
« Last Edit: July 09, 2020, 04:00:19 pm by patman27 »
 
The following users thanked this post: tautech, 4x1md

Offline TK

  • Super Contributor
  • ***
  • Posts: 1617
  • Country: us
  • I am a Systems Analyst who plays with Electronics
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1653 on: July 09, 2020, 03:27:27 pm »
Apart from all:
We got a siglent SDS1104X-E at work, our colleague from R&D use it in his office and the noise level seems to me (and him) nearly quiet - Maybe you got a defective one ? (what the fan concerns)

didn't know it could be a serious tool 😁

This tool was spotted twice in this video according to comments. People choose Siglent.  :-+



I see a lot of more Rigols in hobby and maker videos.  And Keysight if the youtuber is into more advanced stuff.  I sold some used Rigol and Siglent scopes and my estimate is that probably the market share is 10:1 in favor of Rigol on terms of interest and how they keep the resell value.
 

Offline patman27

  • Contributor
  • Posts: 7
  • Country: us
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1654 on: July 10, 2020, 12:25:52 am »
Final note for peeps running UniFi.

...
Enable 2G Data Rate Control
[attach=1]
...
Simply disabling this feature brought my scope online for good. Goodbye, ethernet!  :-+

Except it didn't. Every 20-30 min the AP reverted to the previous setting, booting my scope off the network.

This post describes the same issue re: another 2.4GHz gizmo.

The fix: (in new settings) Under "Settings > Network Settings > Optimizations", turn off "Auto-Optimize Network" first.
[attach=1]
Otherwise "Enable 2G Data Rate Control" will automatically re-enable and get set to "6 Mbps".
« Last Edit: July 10, 2020, 12:27:48 am by patman27 »
 
The following users thanked this post: tautech

Online SMB784

  • Frequent Contributor
  • **
  • Posts: 322
  • Country: us
    • Tequity Surplus
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1655 on: July 10, 2020, 03:28:08 am »
Tautech, is there a timeline on the next firmware patch for this scope? Are they planning on addressing the WiFi issues mentioned in this thread?

Online tautech

  • Super Contributor
  • ***
  • Posts: 20511
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1656 on: July 10, 2020, 04:25:33 am »
Tautech, is there a timeline on the next firmware patch for this scope?
Last was 2020-03-07 so one wouldn't expect another for a bit.
Quote
Are they planning on addressing the WiFi issues mentioned in this thread?
IDK. AFAIK the TP-Link dongle driver package was used in the scope therefore the WiFi connectivity stability is mainly due to AP settings which is something I suffer from too and thanked patman27 for discovering this and bringing it to our attention.
ATM I'm working with my ISP to discover if the WiFi router they use also has this 2G Data Rate Control feature ::) and if so it will be given prompt flying lessons !  :rant:  :horse:

It all makes some sense what patman27 has reported as I have no issues when WiFi connected to the DSO and live streaming remotely via the webserver but when throughput falls away connection is not maintained.

Still I might pop mail to Siglent to make them aware of patman27's findings.  8)
Avid Rabid Hobbyist
 
The following users thanked this post: SMB784

Offline jayp111

  • Contributor
  • Posts: 6
  • Country: de
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1657 on: July 17, 2020, 11:50:58 pm »
I'm also unable to use my Siglent SDS1104X-E (firmware 6.1.35R2) with TL-WN725N over WiFi.

I am using an AVM Fritz!Box 7590 as WiFi access point and router (https://en.avm.de/products/fritzbox/fritzbox-7590/) with the current AVM firmware 7.20. These devices have a very large market share here in Germany (https://en.wikipedia.org/wiki/Fritz!Box).

The Siglent connects to the access point over WiFi (WPA2) and receives an IP address over DHCP but cannot be reached through this address (web interface, ping). The WiFi connection speed is shown as 1/1 Mbit/s (up/down) by the AVM web interface. That seems unusually slow.

For additional testing I have tried an older ASUS RT-N12D1 access point. No problems with WiFi there.

It would be great if Siglent would fix this issue.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 20511
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1658 on: July 18, 2020, 12:13:59 am »
I'm also unable to use my Siglent SDS1104X-E (firmware 6.1.35R2) with TL-WN725N over WiFi.

I am using an AVM Fritz!Box 7590 as WiFi access point and router (https://en.avm.de/products/fritzbox/fritzbox-7590/) with the current AVM firmware 7.20. These devices have a very large market share here in Germany (https://en.wikipedia.org/wiki/Fritz!Box).

The Siglent connects to the access point over WiFi (WPA2) and receives an IP address over DHCP but cannot be reached through this address (web interface, ping). The WiFi connection speed is shown as 1/1 Mbit/s (up/down) by the AVM web interface. That seems unusually slow.

For additional testing I have tried an older ASUS RT-N12D1 access point. No problems with WiFi there.

It would be great if Siglent would fix this issue.
Welcome to the forum.

Do you say you can access the scopes websever through one WiFi access point and not the other ?
It is simple to overlook the need to Save the scopes IP address.
Avid Rabid Hobbyist
 

Offline jayp111

  • Contributor
  • Posts: 6
  • Country: de
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1659 on: July 18, 2020, 12:21:38 am »
The IP address that is assigned to the Siglent by DHCP is visible in the AVM access point interface. It's clearly not a routing issue (or mixed up IP address) but a problem with the Siglent WiFi connection to the AVM router.
I moved the Siglent right next to the AVM Fritz!Box 7590 that is located in the basement. Now the WiFi status shows 90 Mbit/s downstream, but I still cannot reach the IP address of the Siglent.

The Siglent web server can be accessed if I use the ASUS WiFi access point instead.
« Last Edit: July 18, 2020, 12:34:15 am by jayp111 »
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 20511
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1660 on: July 18, 2020, 12:31:58 am »
The IP address that is assigned to the Siglent by DHCP is visible in the AVM access point interface. It's clearly not a routing issue (or mixed up IP address) but a problem with the Siglent WiFi connection to the AVM router.

The Siglent web server can be accessed if I use the ASUS WiFi access point instead.
OK, can you get any access at all with the AVM router ?

FWIW I turn DHCP ON only to have an IP assigned to the scope then Save it and turn DHCP OFF.
Then point PC browser to saved IP and it works fine for a while depending on the task I'm doing. 

Hope that helps.
Avid Rabid Hobbyist
 

Offline cardre

  • Contributor
  • Posts: 23
  • Country: au
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1661 on: July 18, 2020, 12:34:58 am »
The IP address that is assigned to the Siglent by DHCP is visible in the AVM access point interface. It's clearly not a routing issue (or mixed up IP address) but a problem with the Siglent WiFi connection to the AVM router.

The Siglent web server can be accessed if I use the ASUS WiFi access point instead.

I've read that people do have issues with various access points and it appears that it may be an issue with the Siglent itself and its firmware. Just one other thing to check though. Are you trying to access the Siglent via another computer/device that is also connected via wifi?

Reason I ask is that I have an older model Fritz Wifi router (7390) and in the "Wireless" settings, there is a "Security" section. There's a little checkbox that has to be switched on to allow the above scenario to work "The active wireless devices displayed below may communicate with each other". If this is not enabled, any Wifi device connected to the Fritz Wifi router will not be able to communicate with other Wifi devices on the same network.

This may or may not be the problem you're experiencing, but something worth checking. It's a security feature to help reduce hacking of a Wifi device by another Wifi device, by effectively disabling communication between them. So maybe see if that setting helps your scenario. I don't have a Wifi dongle for mine to check as I'm using Ethernet on my new Siglent.
 

Offline cardre

  • Contributor
  • Posts: 23
  • Country: au
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1662 on: July 18, 2020, 12:44:02 am »
FWIW I turn DHCP ON only to have an IP assigned to the scope then Save it and turn DHCP OFF.
Then point PC browser to saved IP and it works fine for a while depending on the task I'm doing. 

This will cause lots of problems next time a new device on your network wants a DHCP address and the DHCP lease time for your Siglent has expired (typical router DHCP configs are 3-24 hours.) After that time the DHCP server will give out the same IP address to another device and if your Siglent is still on or turned on at a later stage, they'll both have same IP address causing all sorts of network related issues.

Best to either assign your Siglent a static IP address that is outside of your DHCP IP address pool range, so that it never clashes, or alternatively, use DHCP all the time and check your router or device to see what IP address it is using next time it turns on. Another option is to have the DHCP server remember the Wifi MAC address of your Siglent and permanently assign it an IP address, again out of the normal DHCP pool range. That way it will always be assigned the same IP address that you can refer to with client devices, but the Siglent just uses DHCP all the time.
 
The following users thanked this post: tautech

Offline jayp111

  • Contributor
  • Posts: 6
  • Country: de
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1663 on: July 18, 2020, 12:57:10 am »
I have already checked the Fritz!Box settings. I have half a dozen ESP8285 Tasmota devices on the same Fritz WiFi network with the identical WiFi settings. They can be accessed without any problems.

And yes, I have assigned a fixed IP address for DHCP to the Siglent MAC address over the Fritz!Box interface outside of the dynamic DHCP range. That is not the issue.

BTW, if you use the WiFi USB stick on the Siglent, the static IP settings in the scope are ignored (apparently they are only for the Ethernet port). It's always using DHCP.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 20511
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1664 on: July 18, 2020, 01:22:55 am »
FWIW I turn DHCP ON only to have an IP assigned to the scope then Save it and turn DHCP OFF.
Then point PC browser to saved IP and it works fine for a while depending on the task I'm doing. 

This will cause lots of problems next time a new device on your network wants a DHCP address and the DHCP lease time for your Siglent has expired (typical router DHCP configs are 3-24 hours.) After that time the DHCP server will give out the same IP address to another device and if your Siglent is still on or turned on at a later stage, they'll both have same IP address causing all sorts of network related issues.

Best to either assign your Siglent a static IP address that is outside of your DHCP IP address pool range, so that it never clashes, or alternatively, use DHCP all the time and check your router or device to see what IP address it is using next time it turns on. Another option is to have the DHCP server remember the Wifi MAC address of your Siglent and permanently assign it an IP address, again out of the normal DHCP pool range. That way it will always be assigned the same IP address that you can refer to with client devices, but the Siglent just uses DHCP all the time.
Thanks, very helpful and obvious you know more about networks than I do.  :-[

I don't have a Wifi dongle for mine to check as I'm using Ethernet on my new Siglent.
Your contribution to connection issues would be very welcome if you decide to get the TP-Link TL-WN725N (gold version) which are on eBay for ~ AU$15.
Avid Rabid Hobbyist
 

Offline jayp111

  • Contributor
  • Posts: 6
  • Country: de
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1665 on: July 18, 2020, 02:52:05 am »
When the Siglent scope is connected to the Fritz WiFi (and cannot be pinged/accessed) it uses 40 Mhz WiFi channel bandwith. On the ASUS WiFi it's only 20 Mhz.
Maybe that's the issue. There are some reports about the cfg80211_disable_40mhz_24ghz=1 setting on Linux machines that helped in other configurations.

I have no telnet hack on the scope to test it though...
 

Offline MathWizard

  • Regular Contributor
  • *
  • Posts: 224
  • Country: ca
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1666 on: July 18, 2020, 03:31:19 am »
I have the hacked 1104 series, I'd love the 5000 series, someday, someday.
 

Offline cardre

  • Contributor
  • Posts: 23
  • Country: au
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1667 on: July 18, 2020, 03:54:08 am »
I have already checked the Fritz!Box settings. I have half a dozen ESP8285 Tasmota devices on the same Fritz WiFi network with the identical WiFi settings. They can be accessed without any problems.

Ok, that's good to confirm that's not the problem.

As 802.11n can include both 2.4 and 5GHz networks, next thing I'd try is temporarily disable the 5GHz radio on the Fritz Box and see if the Siglent works correctly or not. From what I saw of a quick read of the TP-Link TL-WN725N datasheet, it does not support 5GHz, only 2.4GHz. The Fritz box may be making wrong assumptions about the device and trying to talk back to it in a way that the Wifi dongle cannot or does not respond.

And yes, I have assigned a fixed IP address for DHCP to the Siglent MAC address over the Fritz!Box interface outside of the dynamic DHCP range. That is not the issue.

BTW, if you use the WiFi USB stick on the Siglent, the static IP settings in the scope are ignored (apparently they are only for the Ethernet port). It's always using DHCP.

As I don't have the Wifi dongle, I don't know what it can or can't do, but that's a really important point then about not being able to set a static IP address for the Wifi dongle on the Siglent with the stock firmware. So yes, I'd setup my DHCP server to aways provide the Siglent's Wifi dongle's MAC address with the same fixed IP address out of the DHCP address pool. Otherwise, you'll always need to find the dynamically assigned IP address every time you turn your scope on after you let it connect to Wifi.
 

Offline cardre

  • Contributor
  • Posts: 23
  • Country: au
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1668 on: July 18, 2020, 04:00:41 am »
When the Siglent scope is connected to the Fritz WiFi (and cannot be pinged/accessed) it uses 40 Mhz WiFi channel bandwith. On the ASUS WiFi it's only 20 Mhz.
Maybe that's the issue. There are some reports about the cfg80211_disable_40mhz_24ghz=1 setting on Linux machines that helped in other configurations.

See my other reply, but I think you're on the right track here as I was thinking to eliminate one of the radios from the problem as well.

To try and force the Fritz box then to use 20MHz on 2.4GHz, this is the setting I use. In the "Wireless" -> "Radio Channel" section, turn off the "Set radio channel settings automatically (recommended)". Then in manual "Adjust radio channel settings" click on "Additional settings" and make sure to enable the "Wireless LAN coexistence enabled (2.4 GHz frequency band. In heavily used wireless environments the available channel width is divided among the participants in the best way possible." checkbox.

See if that maybe helps, but again, only guessing here as I can't see the problem myself.
 

Offline jayp111

  • Contributor
  • Posts: 6
  • Country: de
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1669 on: July 18, 2020, 04:11:43 am »
Yeah, that's been enabled. 5 GHz is disabled, too.
The Siglent connects with 40 MHz WiFi bandwith anyway. I have no other device that uses 40 MHz bandwith on the 2.4 GHz band. That seems to be quite uncommon and probably causing the issue.

« Last Edit: July 18, 2020, 04:17:38 am by jayp111 »
 

Offline MathWizard

  • Regular Contributor
  • *
  • Posts: 224
  • Country: ca
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1670 on: July 18, 2020, 04:21:27 am »
I've had to reboot a few times now lately, like 2 days ago, the trace on 2ms or 5ms, disappeared, it would appear at +10ms and less than 5 or 2ms (iirc which was missing).

It might have been just me changing the time base too quick and it trips up the machine, but I don't change stuff much faster than it can update it, and then why would the trace not ever appear on that ms/div afterwards, and I had to reboot.



I hacked my 1104, and then updated to latest firmware in May/June, I hope thats not the problem
 

Offline cardre

  • Contributor
  • Posts: 23
  • Country: au
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1671 on: July 18, 2020, 04:24:29 am »
Yeah, that's been enabled. 5 GHz is disabled, too.
The Siglent connects with 40 MHz WiFi bandwith anyway. I have no other device that uses 40 MHz bandwith on the 2.4 GHz band. That seems to be quite uncommon and probably causing the issue.

So have you tried setting the 2.4GHz radio to only 802.11b+g, thus removing 802.11n?

This would obviously be less than ideal for normal devices, as it defeats the purpose of having an 802.11n Wifi router. That said, if you allow 802.11n+a on the 5GHz radio, it may not really be such a big problem.
 

Offline jayp111

  • Contributor
  • Posts: 6
  • Country: de
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1672 on: July 18, 2020, 01:34:11 pm »
The Siglent does indeed work properly with the ancient WiFi standards 802.11b+g instead of 802.11g+n on the AVM Fritz!Box 7590. It uses 20 MHz WiFi bandwidth then.

I think it's not unlikely that the Linux setting cfg80211_disable_40mhz_24ghz=1 could fix the issue with 802.11g+n enabled (if it's possible to change that setting on the Siglent).
 

Offline cardre

  • Contributor
  • Posts: 23
  • Country: au
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1673 on: July 18, 2020, 03:25:23 pm »
The Siglent does indeed work properly with the ancient WiFi standards 802.11b+g instead of 802.11g+n on the AVM Fritz!Box 7590. It uses 20 MHz WiFi bandwidth then.

OK, glad to hear you've been able to isolate the problem then and have some sort of a solution. I guess it depends how much you want to use the AVM FrtizBox with that config and whether having the 2.4GHz radio use the older Wifi standards and let your 5GHz radio use the newer Wifi standards. I don't know your network and devices to know whether that's workable or not, but at least the actual problem has been identified and some sort of (less desirable?) solution is possible.

I think it's not unlikely that the Linux setting cfg80211_disable_40mhz_24ghz=1 could fix the issue with 802.11g+n enabled (if it's possible to change that setting on the Siglent).

I guess a request could go in for some sort of config setting to be incorporated into the Siglent firmware, but I don't know how open they are to that sort of setting/configuration changes.

Once you have network access, you could try enabling/using telnet access and modifying the filesystem of the Siglent. The risk here is that it will be lost/overwritten on future firmware updates.
 

Offline tony359

  • Regular Contributor
  • *
  • Posts: 100
  • Country: gb
Re: Siglent SDS1104X-E and SDS1204X-E Mixed Signal Oscilloscopes
« Reply #1674 on: August 09, 2020, 08:53:18 pm »
I've been having the 1104 for several weeks now - still learning.
One thing that caught my eyes and I find pretty annoying is that I cannot see the top line of the screen unless I am looking perpendicular at the screen itself. If I'm standing in front of my bench - hence the scope is at "belly height" I cannot see it. The plastic frame around the screen should have been chamfered more to avoid this issue which I find pretty major as the top line has some crucial information!

I did a quick search on this thread and I do not see anybody else noticing it but it is so obvious to me.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf