Author Topic: Rigor DG1022U brick  (Read 307 times)

0 Members and 1 Guest are viewing this topic.

Offline icemanh

  • Contributor
  • Posts: 6
Rigor DG1022U brick
« on: July 05, 2020, 02:04:48 pm »
Hello

My DG1022U is bricked while upgrading firmware.  My hardware version is 3, bootloader version is 0. So I upgraded the bootloader and it looked fine.

However, I found it halted during DSP.  Only the Mod, Store/Recall, Burst buttons lighted up forever.  No choice that I had to switch it off.  Retried the upgrade and everything is the same..

I am using a 2G usb stick.

Any idea how I can fix it?

Thank you...
 

Offline icemanh

  • Contributor
  • Posts: 6
Re: Rigor DG1022U brick
« Reply #1 on: July 06, 2020, 01:17:26 am »
I solved the problem by using different FAT32 formatted USB stick.

I noticed that the DG1022 kept trying to read USB when it stuck at Burst button lighted on.  It may indicate there is some wrong in USB reading.

So I tried different USB sticks, 1G, 2G, 4G etc.  Finally a Lexar 4G worked good and now DG1022U resumed to normal...
 
The following users thanked this post: egonotto

Offline Gandalf_Sr

  • Super Contributor
  • ***
  • Posts: 1725
  • Country: us
Re: Rigor DG1022U brick
« Reply #2 on: July 06, 2020, 11:01:47 am »
Glad you fixed it. Was it a Rigol (and not Rigor)?  Rigol gear is crazy-fussy about the USB drives, has been a source of problems for me in several occasions now.  I recently had one where the drive that loaded the new bootloader worked but then that same drive would not work for the GE file upload.

When you find a drive that works for a specific piece of test gear, label it and put it on one side, that's what I have done.
If at first you don't succeed, get a bigger hammer
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf