Author Topic: New Zoyi multimeter+oscilloscopes - ZT-70xS, up to 50MHz/250MSps (nov 2022)  (Read 265429 times)

0 Members and 7 Guests are viewing this topic.

Offline deforme

  • Newbie
  • Posts: 5
  • Country: at
I havre just got the zt-703s from aliexpress.
but I have this problem. osiloscope seems working but multimeter mode does not start. it seems it is stuck like in video.
https://www.youtube.com/shorts/cMMDfdvmfbs


does anyone have this problem?
 

Offline Astur_TorQue

  • Contributor
  • Posts: 12
  • Country: es
I havre just got the zt-703s from aliexpress.
but I have this problem. osiloscope seems working but multimeter mode does not start. it seems it is stuck like in video.
https://www.youtube.com/shorts/cMMDfdvmfbs


does anyone have this problem?

try updating the firmware
 

Offline deforme

  • Newbie
  • Posts: 5
  • Country: at
I havre just got the zt-703s from aliexpress.
but I have this problem. osiloscope seems working but multimeter mode does not start. it seems it is stuck like in video.
https://www.youtube.com/shorts/cMMDfdvmfbs


does anyone have this problem?

try updating the firmware

I have done already it was 1.3.2 now 1.3.8 but same....
 

Offline black6host

  • Contributor
  • Posts: 15
  • Country: us
I'd pull the battery and let it sit for a bit.  If that doesn't work I'd send it back, I've found nothing on mine that would make it non-responsive.  Good luck!
 

Offline deforme

  • Newbie
  • Posts: 5
  • Country: at
I'd pull the battery and let it sit for a bit.  If that doesn't work I'd send it back, I've found nothing on mine that would make it non-responsive.  Good luck!

it didnt work also :(.
 

Offline RAPo

  • Frequent Contributor
  • **
  • Posts: 674
  • Country: nl
Please take a look at this post.
If the device starts again, do a reflash with newest firmware.
 

Offline lchao

  • Contributor
  • Posts: 14
  • Country: at
After a long time a new firmware on the horizon (V1.39):
ZOYI-703S-FW-V139 firmware.ZTK

https://www.szzotek.com/h-col-159.html
or direct download link:
http://8164272.s21d.faiusrd.com/0/ABUIABAAGAAgnOXYtAYo_OLtzAc?f=ZOYI-703S-FW-V139%E5%9B%BA%E4%BB%B6.ZTK&v=1721119388

I couldn't find any info about the improvements/updates in it.
 
The following users thanked this post: GnatGoSplat, m72, tonyalbus

Offline bebopdk

  • Contributor
  • Posts: 13
  • Country: dk
The 1.39 changes are listed on the home page:
https://zotektools.com/firmware-update-703/
 
The following users thanked this post: m72

Offline artv

  • Contributor
  • Posts: 20
  • Country: gb
Has anyone tried the latest firmware - 1.3.9? For me auto range doesn't work when I'm measuring a mains 240V signal - works fine on 1.3.8? I've had to revert but interested of anyone else had any issues?
 

Offline sergkz

  • Newbie
  • Posts: 3
  • Country: kz

1.3.9
 

Offline artv

  • Contributor
  • Posts: 20
  • Country: gb
I'm looking at the trace via the scope - not in multimeter mode.
 

Offline eljjc

  • Newbie
  • Posts: 1
  • Country: fr
It is working for me with 1.3.9 :

 

Offline sergkz

  • Newbie
  • Posts: 3
  • Country: kz
1.3.9
*SAMPLE* appeared in the menu
*AUTO* mode works very poorly, the internal generator does not always detect
 
The following users thanked this post: m72


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf