Author Topic: TDS 540 problem II  (Read 2438 times)

0 Members and 1 Guest are viewing this topic.

Offline vaualbus

  • Frequent Contributor
  • **
  • Posts: 308
  • Country: it
TDS 540 problem II
« on: June 08, 2013, 12:55:59 pm »
In relation to my previous forum I make another one.
Now I've replaced both the TVS diode and Q9 and now I have a bias voltage of 15, sweat!.
Unfortunally the psu still doesn't work, it have no output from the transformer and for some reason the 12V bias is 15V. This is no strange because the service manual refer to 12V bias voltage to a rail that than is ratet to 14.65V. (See the picture below for more detail).
I also post the A19 board schematics.
There some common failure on the A18 board that is the switching part of the psu?
There some else to check to make sure that everything is ok?
« Last Edit: June 08, 2013, 01:00:43 pm by vaualbus »
 

Offline vaualbus

  • Frequent Contributor
  • **
  • Posts: 308
  • Country: it
Re: TDS 540 problem II
« Reply #1 on: June 13, 2013, 08:23:07 pm »
Jus to in form people out there finally I replace  UC3525A nad boom now it work!!! :)
 

Online nctnico

  • Super Contributor
  • ***
  • Posts: 19974
  • Country: nl
    • NCT Developments
Re: TDS 540 problem II
« Reply #2 on: June 13, 2013, 11:04:26 pm »
That is a pretty uncommon failure. Usually the controller chip is about the last thing that fails. In other words: very good find!  :clap:

How is the rest of the scope?  :scared:
There are small lies, big lies and then there is what is on the screen of your oscilloscope.
 

Offline vaualbus

  • Frequent Contributor
  • **
  • Posts: 308
  • Country: it
Re: TDS 540 problem II
« Reply #3 on: June 14, 2013, 03:55:15 pm »
Ya I also think so but I'm luck finding this error.
My thought is that the chip not techical wrong a part from the internal 5V ref that read 0.
 

Offline vaualbus

  • Frequent Contributor
  • **
  • Posts: 308
  • Country: it
Re: TDS 540 problem II
« Reply #4 on: June 14, 2013, 04:11:45 pm »
For the rest of the scope, see the TDS540 problem III
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf