Products > Test Equipment

Tek CSA7404/TDS7000 repair project (Upgraded memory/CPU)

<< < (173/176) > >>

Ghastly:
Honestly, I just got this a week ago as an upgrade from the 1054z. By dallas dead battery do you mean the coin battery on the NLX board? I can check the vxwork boot process but it would seem weird to me for it not to work. It worked right until I switched and I have no errors when booting into Win98. The only drivers I know and install are the  CSA7154-7404_TDS7154-7254-7404_2.5.3, and yes it is a 7254 not a 7254B. Motherboard unsure, again haven't opened it since it's only been a week since I've had it but my configuration is a Celeron 566mhz with 256mb of ram installed. Am I missing a driver? I can give you the exact installation program I am using. Thanks for the reply though! This is some quite tricky stuff.

Ghastly:
Side note: I remembered I did actually save some of the folders just in case prior to upgrading if that makes any difference. Details in pic.

coromonadalix:
if you backed theses folder, you have the folders who contain the needed drivers

for the gpib interface you need the drivers setup

for the dallas battery  it is on the power pc board under the computer motherboard  dallas  ds xxxxx   


well since its a used scope you've bought,  do you have an idea of it's history / checkups / maintenance ??     dust cleaned ??  a checkup  has to be made

if windows boot fine minus some errors,  you have to check device manager

you can kill the scope software if  with a keyboard    crtl alt del  you invoke task manager and kill the tekscope running task


i have a 7404 non B,    who seemed fine  and the next day,  hell happened, took me 2 weeks to re-install everything  and find appropriate hardware to do re-installations, win2k was not working, endless loop,  ended up with Windows ME, with all the crap removed

motherboard (su 810) is hardware locked, you can not connect all you want, or all you need ...  hard drive size too   etc ... the cd-rom  would not read burned cd's,  finding originals was tough, changed to a 1ghz cpu, and doubled the ram with a mix of pc133 sync and pc100 sync (would not accept the same sizes and speed ????)

you have to read the tds7k thread,  its huge but the last pages have more recent informations ... 

the power pc dallas battery died, lost the vxwork configs ... tekscope was hanging up and crashed, spc errors due to eeprom corruption  ...

now fully working, spc fine etc ...

its a big beast you bought,  with some quirks     you should not have tampered with it,  unitil you had done an hdd cloning

Ghastly:
Thank you. Ill check out the stuff you told me tomorrow not at the bench now. Last calibration date I think was 2015 that's traceable. And yes you are absolutely correct. Really should have cloned the drive.

hazelnutsky:
Hi,

This thread is AMAZING! I recently got me a TDS7404, with some issues.

I am using these two sites for reference:

https://www.eevblog.com/forum/testgear/tek-csa7404-repair-project/850/
https://github.com/exit-failure/tds7000/blob/main/NVRAM/README.md

I have managed to fit a new NVRAM battery onto the PPC board, and have figured out how to connect up and capture the PPC console port output. I have also done the modification of the c:/vxBoot/topscript.hw to reset the NVRAM.

    # remove '#' from next line to set powerup scope state to factory default:
    NvramClearDb = 1   




So I am a little confused why I don't get the countdown in the console chatter, it just goes right to 0.

    Press any key to stop auto-boot...
     0
    auto-booting...

I tried a few things on the Console port, such as RTS-CTS loop back and DSR-DTR loopback but still it does the same. I am using puTTY on a windows 10 machine with a native RS232 port.

Here is my console chatter during a SPC:

    0x15f8570 (SPC task): cc_loadV: CC_TRIGdcGain1c was 0; clipped
    0x15f8570 (SPC task): cc_loadV: CC_TRIGdcGain1d was 0; clipped
    0x15f8570 (SPC task): cc_loadV: CC_TRIGdcGain2c was 0; clipped
    0x15f8570 (SPC task): cc_loadV: CC_TRIGdcGain2d was 0; clipped


Here is my console chatter during a Diagnostic:

    DIAGNOSTIC EXECUTION begin
    OptionST not tested. (option not enabled)
    BK2 not tested (option not enabled)
   
    DIAGNOSTIC EXECUTION finished

My conclusion here is my Ch1/Ch2 Trigger chip is fried. CH1 does not edge trigger, but it does trigger on level in Advanced settings. Does this seem correct?


Navigation

[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod