Author Topic: Very weird problem with the BM235 select button  (Read 557 times)

0 Members and 1 Guest are viewing this topic.

Offline aesteve

  • Newbie
  • Posts: 3
  • Country: es
Very weird problem with the BM235 select button
« on: April 25, 2019, 06:24:48 pm »
Well, let's see if anyone can help me with this one.

The problem is that the select button doesn't change between different modes of each wheel position. In voltage, it is stuck at AC, in resistance, it doesn't change to continuity, in diode/capacitance, it it stuck at capacitance. Every wheel position is stuck in one mode. The weird part is, it is not the button. The button works fine. When I push it, it beeps, then the screen blinks as if it is changing mode, but remains in the same spot. It isn't some sort of double pulsation, if I hold the button the light turns on. And, on top of that, when I discovered it, I went through all positions in the wheel, testing the button in each position, and found that it changed once and then got stuck in whatever mode it changed to.

I've tried removing batteries for a long time (more than one day) but doesn't seem to reset it. Somehow, it remembers. Does anyone know a method to hard reset the meter? By the way, the firmware is revision D.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 18013
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Very weird problem with the BM235 select button
« Reply #1 on: April 25, 2019, 09:46:58 pm »
Welcome to the forum.

Try another set of batteries.
Avid Rabid Hobbyist
 

Offline aesteve

  • Newbie
  • Posts: 3
  • Country: es
Re: Very weird problem with the BM235 select button
« Reply #2 on: April 26, 2019, 07:33:28 am »
Also tried that, nothing changed.
 

Online shakalnokturn

  • Frequent Contributor
  • **
  • Posts: 953
  • Country: fr
Re: Very weird problem with the BM235 select button
« Reply #3 on: April 26, 2019, 11:15:06 pm »
Any chance a previous set of batteries may have leaked a little?
The QFP I.C.'s are not far behind, some contamination there could cause all sorts of weird things.
 

Offline aesteve

  • Newbie
  • Posts: 3
  • Country: es
Re: Very weird problem with the BM235 select button
« Reply #4 on: April 27, 2019, 12:48:45 pm »
Nope, it's not that either.
I've noticed there is a jumper inside. I've tried shorting it and power it on. It doesn't seem to do anything.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf