Author Topic: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen  (Read 1780 times)

0 Members and 1 Guest are viewing this topic.

Offline rlohmann

  • Contributor
  • Posts: 13
  • Country: de
VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« on: February 09, 2019, 08:05:47 pm »
Hi there,

the mentioned scope is a 4 channel / 80MHz device sold by Conrad / Voltcraft in Germany. The device and specs look similar to  Hantek DSO4084B.

The unit I  have in hands does actually not start properly and get stuck on boot screen.

I attached a serial adapter and captured the terminal during boot. (attached)

It get stuck after:

                acq_dot_nm_of_timerange =4000,time_range=1600000000000,dso_acq.dot_factor =1,sample_rate =2500.000000
                dso_acq_control:1:2056, 2056,0
                dso_acq_control:2:2056, 2056
                dso_acq_control:3:102800000, 103600000
                dso_acq_control:4:after= 102800000, before= 103600000

... hitting enter i get back to the shell:

               unix:path=/tmp/dbus-2Gwvd7Fgoi,guid=78229ec33879218ea98a0b54386d509c
              [root@Hantek ~]#

Hope anybody can help me to figure out whats wrong with the unit and how to get it back to life.  :-//

 

Offline rlohmann

  • Contributor
  • Posts: 13
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #1 on: February 09, 2019, 10:26:23 pm »
... looking closer at at the log, I#ve noticed:

                acq_dot_nm_of_timerange =4000,time_range=1600000000000,dso_acq.dot_factor =1,sample_rate =2500.000000

.. which appears strange to me.

So I looked for any config  and found /dso/etc/system.inf

Code: [Select]
code:
[machine]
       Model=dso1202l
       Vendor=hantek
       Product=FGen
       Manufacturer=hantek
       Serial=DSO4D143501107
[version]
       Pcb=1001
       Keyboard=11
[language]
       Lans=255
       Language=1
[add]
       Start=0
       Update=0

I guess the previous owner applied a wrong update ...

I've found few update files online:

                - dso4kb_20180831.upk  (Conrad/Voltcraft)
                - dso4kb_20181208.upk  (Hantek  DSO4000B)

Is here a way to apply the update form the shell or automatically during boot?

Or how to extract those files and hopefully replace the according files manually within unit?

Maybe someone out there with this scope could help me out with a tar of a working /dso folder ...

 

Online tinhead

  • Super Contributor
  • ***
  • Posts: 1864
  • Country: 00
    • If you like my hacks, send me a donation
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #2 on: February 10, 2019, 10:46:13 am »
sure, unpack first the update by

gpg --batch --passphrase-fd 0 dso4kb_20180831.upk

and give as password dso4000bc

and check what do_update.sh is doing (basically copying few files and setting +x permission)

I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 
The following users thanked this post: rlohmann

Offline rlohmann

  • Contributor
  • Posts: 13
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #3 on: February 10, 2019, 10:03:59 pm »
Thanks a lot TinHead!  :-+    ... you made my day!

The cmd line did not work out for me for some reason. But it turned me into the right direction ...

with:  gpg -o out.tar -d dso4kb_20180831.upk

    ... extracting out.tar and the containing dso4kb.upk.tar I got "upend" and "package/"

Then I went through package/do_update.sh and manually updated all files manually ...
And merged config/root/system.inf with package/system.inf :
Code: [Select]
[machine]
       Model=80M$DSO1084E
       Vendor=voltcraft
       Product=DSO
       Manufacturer=hantek
       Serial=DSO4D143501107
[version]
       Pcb=1001
       Keyboard=11
[language]
       Lans=65535
       Language=6
[add]
       Start=389
       Update=0

On first reboot i got the same error, stuck at boot screen / same terminal output ...   :palm:

But I noticed  "#rm /dso/app/etc/aslf/*" in package/do_update.sh ... so I made a backup of aslf and removed /dso/app/etc/aslf/*...

Voila, the scope finally booted and and appears to work fine!   :clap:

 
The following users thanked this post: tkoop

Online tinhead

  • Super Contributor
  • ***
  • Posts: 1864
  • Country: 00
    • If you like my hacks, send me a donation
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #4 on: February 11, 2019, 04:44:31 am »
Thanks a lot

you welcome.

Out of curiosity, can you post picture of let say 50-100MHz sine one one channel with max sampling ?

I hope it does not looks like this one, which from 4000C model, which is based as the B Models on multiple AD9288



Your 4000B should looks much better, but i never had a chance to see them in action.
« Last Edit: February 11, 2019, 04:46:25 am by tinhead »
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 

Offline rlohmann

  • Contributor
  • Posts: 13
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #5 on: February 11, 2019, 04:55:34 am »
I would be pleased to help ...

Unfortunately, I don't own a signal generator.  Let me check if I can hold on one.

I'll get back to you as soon as I have a update.  :)

 

Offline KlausF

  • Contributor
  • Posts: 23
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #6 on: February 12, 2019, 12:37:24 am »
Thanks a lot

you welcome.

Out of curiosity, can you post picture of let say 50-100MHz sine one one channel with max sampling ?

I hope it does not looks like this one, which from 4000C model, which is based as the B Models on multiple AD9288



Your 4000B should looks much better, but i never had a chance to see them in action.


Have you tried set the trace to average? Does the trace then get clear and crispy?
Did you terminate ?

@rlohmann
Well done, you got it back to working.
Wondering, whether the DSO-1084E is as "buggy" as is this similar looking one here


 

Offline rlohmann

  • Contributor
  • Posts: 13
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #7 on: February 12, 2019, 01:28:20 am »
@KlausF 
This does not look promising :o ... till now my scope did not crash so far. :)
Need to check view examples, but as I updated the FW during the recovery, i'm confident at least few of them got fixed meanwhile.

 
@tinhead   
Just as a side note, I#m guessing the VOLTCRAFT DSO-1084E (aka Hantek DSO4084B) does have a identical PCB to Hantek DSO4000C ...
At least some of the wave gen stuff is on the PCB.

I'm meanwhile trying to figure out if I can get wave gen to work as well. ;D

https://www.eevblog.com/forum/testgear/upgrading-the-hantek-dso4072c-osciloscope-bandwidth-from-70mhz-to-200mhz/new/?topicseen#new   

« Last Edit: February 12, 2019, 01:38:08 am by rlohmann »
 

Online tinhead

  • Super Contributor
  • ***
  • Posts: 1864
  • Country: 00
    • If you like my hacks, send me a donation
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #8 on: February 12, 2019, 10:23:42 am »

Have you tried set the trace to average? Does the trace then get clear and crispy?
Did you terminate ?

Klaus :P it's not my pic, it is taken from here:

https://www.eevblog.com/forum/testgear/upgrading-the-hantek-dso4072c-osciloscope-bandwidth-from-70mhz-to-200mhz/

and no, it does not matter if signal has been terminated, when sampled data has been not sorted properly due to bad fpga design, clock issues or signal path skew -> which was the case in the past for some Hantek models. The DSO4xx4B/C seems however to use single ADC



instead of 8 of them



Interleaving is done within ADC, so one must be a real idiot to still screw this up - but who know, and that's why i'm asking for screenshot of such 4ch model (just check pictures from above thread).

And no, i don't wan't clean avg pics, this is not what i'm asking for.
« Last Edit: February 12, 2019, 10:26:48 am by tinhead »
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 

Offline DK87

  • Newbie
  • Posts: 4
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #9 on: March 09, 2019, 07:35:03 am »
Hey there,

I also own a DSO-1084E which has exactly the same problem.

Recently I told a friend about that issue and he told me to take a look at the EEVBLOG Forum and voila...I just found this thread  ;D


Using another scope I inspected the mainboard for UART Pinouts, but I can only find pins that raise to 3,3V and none of them seems to be "alive" during boot.
@rlohmann..can you tell me where the UART Connector pins are?

In the attachment below is a picture of my pcb and the pins I probed.

Am I doing something wrong?


Thanks a lot  :D
 

Offline rlohmann

  • Contributor
  • Posts: 13
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #10 on: March 09, 2019, 07:54:46 am »
Hi DK87,

welcome to the forum!  :)

If I remember correctly, the connector close to the RTC battery is the one I connected the FTDI adapter.

I'll open my scope and check the connections, once I'm back home on Sunday.

 
 

Offline DK87

  • Newbie
  • Posts: 4
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #11 on: March 09, 2019, 10:53:34 am »
Hey rlohmann,

thank you ;)


But you won't have to open it up anymore because
It's WORKING  :) :) :-+


You were right, the UART pinouts are right beside the RTC battery, I think I have been too lazy in probing or I was just too late when I probed the pins.

After I found the right pins, I connected with my CP2102 UART USB Bridge at 115200 baud and the console
outputted almost the same as in your initial thread.

I decompressed the firmware image downloaded from the conrad website but i haven't updated the files, I just deleted /dso/app/etc/aslf/*
and it worked!

Thank you very very much!


By the way:
I have put my log in the attachment for interest. 
Parts with "##" are a new section because I messed up with vi and you don't wanna see that :palm:

 

Offline rlohmann

  • Contributor
  • Posts: 13
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #12 on: March 09, 2019, 07:09:52 pm »
Great to hear your scope is working again.  :-+

Could you mark the serial connections in your initial photo and post it here for reference?
Just in case someone else is looking for this information ...

 

Offline DK87

  • Newbie
  • Posts: 4
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #13 on: March 10, 2019, 09:04:11 pm »
of cause I'll do that.

Here it is  ;D
 
The following users thanked this post: rlohmann

Offline tkoop

  • Newbie
  • Posts: 3
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #14 on: March 15, 2019, 02:33:27 am »
I think there was a wrong firmware published at some point. I just received a used scope like this. The description said, that the firmware has to be reflashed in order to use it. I'll just leave the serial output here without any comments...

Code: [Select]
acq_dot_nm_of_timerange =4000,time_range=1600000000000,dso_acq.dot_factor =1,sample_rate =2500.000000
dso_acq_control:1:2056, 2056,0
dso_acq_control:2:2056, 2056
dso_acq_control:3:102800000, 103600000
dso_acq_control:4:after= 102800000, before= 103600000

unix:path=/tmp/dbus-2cwNKRB5GT,guid=f88b9ed89c06967a785f15695c8ae710
[root@Hantek ~]#cat /dso/etc/system.inf
[machine]
       Model=dso1202l
       Vendor=hantek
       Product=FGen
       Manufacturer=hantek
       Serial=DSO4D143501107
[version]
       Pcb=1001
       Keyboard=11
[language]
       Lans=255
       Language=1
[add]
       Start=0
       Update=0
[root@Hantek ~]#
 

Offline KlausF

  • Contributor
  • Posts: 23
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #15 on: March 25, 2019, 04:35:08 am »
Is it possible to successfully update a Voltcraft scope with a Hantek firmware?
I mean, it is the same hardware, just a different label.
 

Offline tkoop

  • Newbie
  • Posts: 3
  • Country: de
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #16 on: March 25, 2019, 05:52:52 am »
This should be possible. At least it worked on my DSO
 

Offline Pluscrafter

  • Regular Contributor
  • *
  • Posts: 69
  • Country: ch
  • Somewere on earth
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #17 on: April 23, 2019, 05:32:15 am »
Did anyone know which Hantek Model the Voltcraft DSO-1104E is and if the DSO-1084E or DSO-1104E is hackable ?
 

Offline Microcheap

  • Regular Contributor
  • *
  • Posts: 104
  • Country: 00
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #18 on: April 23, 2019, 07:55:44 am »
Did anyone know which Hantek Model the Voltcraft DSO-1104E is and if the DSO-1084E or DSO-1104E is hackable ?
Apparently these Voltcraft are manufactured by Hantek with the name DSO4004C series (http://www.hantek.com/en/ProductDetail_3_12167.html) and yes they are hackable: https://www.eevblog.com/forum/testgear/upgrading-the-hantek-dso4072c-osciloscope-bandwidth-from-70mhz-to-200mhz/msg2095372/#msg2095372

@tinhead
I am curious, how do you get the passphrase from the .upk files? I've been looking at it during the weekend with no success until I found, by chance, that you had already posted it here. I wanted to create an update file to easily re-config the BW of these scopes without the need to open the case.
 
The following users thanked this post: Pluscrafter

Online tinhead

  • Super Contributor
  • ***
  • Posts: 1864
  • Country: 00
    • If you like my hacks, send me a donation
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #19 on: April 23, 2019, 09:35:35 pm »
@tinhead
I am curious, how do you get the passphrase from the .upk files? I've been looking at it during the weekend with no success until I found, by chance, that you had already posted it here. I wanted to create an update file to easily re-config the BW of these scopes without the need to open the case.

the first time (~10yrs ago) was hard, as i had to buy first proper tools to dump the NAND and read content (that was the famous 0571tekway password), later it was easier as i had lot of Tekway/Hantek gears on my desk. So generally i was always doing dumps, and guessing pwd as well - once they started to use model name as password (0571tekway, 111111, 949307, dso5000p, dso5000c, mso5074fg, dso1000e, dso4000bc, ...)

The rest of update file is easy step, just remember to tar/gzip under Linux (to get +x rights), or add it into "update" script.

Btw, not sure if this is still working with these models, did you checked it? -> https://www.eevblog.com/forum/testgear/hantek-tekway-dso-hack-get-200mhz-bw-for-free/msg467313/#msg467313
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 
The following users thanked this post: Microcheap

Offline Pluscrafter

  • Regular Contributor
  • *
  • Posts: 69
  • Country: ch
  • Somewere on earth
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #20 on: April 28, 2019, 07:26:49 am »
Would you recommend this scope for a beginner?
 

Offline Microcheap

  • Regular Contributor
  • *
  • Posts: 104
  • Country: 00
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #21 on: April 28, 2019, 08:02:59 am »
Would you recommend this scope for a beginner?
huum... yes it is a nice scope but, you being in Europe and given the small price difference I would definitely recommend that you go either for the Rigol DS1054Z or Siglent SDS1104X-E that have better specs and more mature firmware. You can check Batronix in Germany or Batterfly in Italy for prices.
You can get the Hantek DSO4084C from Aliexpress cheaper than Conrad's but then you wont have local support.
 

Offline Pluscrafter

  • Regular Contributor
  • *
  • Posts: 69
  • Country: ch
  • Somewere on earth
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #22 on: May 06, 2019, 11:03:27 pm »
So I bought the scope, but to hack it I have to unscrew it. Are these Inbusscrews inch screws ? It's too big for a 2.5 mm one and too small for a 2 mm one. And has anyone an idea to open it. I have tried it with flat screwdriver but then I would break the screw.
 

Offline Pluscrafter

  • Regular Contributor
  • *
  • Posts: 69
  • Country: ch
  • Somewere on earth
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #23 on: May 07, 2019, 12:27:58 am »
No need to help :) a glove for more grip.
 

Offline Pluscrafter

  • Regular Contributor
  • *
  • Posts: 69
  • Country: ch
  • Somewere on earth
Re: VOLTCRAFT DSO-1084E (Hantek DSO4084B) stuck at boot screen
« Reply #24 on: May 07, 2019, 05:15:04 am »
Thanks it worked on the Voltcraft one you must type in 250M$DSO1254E. And is there a method to take a screenshot without to see the save menu or is this a bug? The key reuse function in the Display menu isn't there but mentioned in the Manual.
With this hack and the newest firmware of Hantek the bugs in the video does not appear.
« Last Edit: May 07, 2019, 05:55:04 am by Pluscrafter »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf