Products > Thermal Imaging

Bought a used Flir E4, not detected by USB and other issues

(1/2) > >>

pdev:
Hi Friends,

I am new here and this is my first post so please pardon my ignorance. I just bought a used flir E4 Ex from local classified for AU$500 and its my first thermal camera but it seems to be full issues and the seller is not helping  :-[. Issues:

1) Its not getting detected via USB cable on my laptop. It only charges via USB. I have installed Flir tools and there also the camera is not detected. I have tried different USB cables but no luck
2) The center spot is not working. I have tried turning on and off but I do not see center spot.
3) The "thermal blending" under image mode doesn't work. It shows thermal image only and no blending. The digital camera and thermal modes work fine seperatly.

Its running firmware 2.3 and its 1.1l but I am not sure if its hacked for better resolution. I have nothing to compare to so can't tell if its hacked but I am guessing that its firmware is corrupted or its partially hacked. I have tried Resetting device and clearing all images from settings and also removing battery but it still remains same.

Can you please help me to fix the USB issue and then guide me to reinstall 2.3 or newer firmware.

Many Thanks,

cq-317:
It may work in rndis mode, you can try to install the driver flir_device_drivers_rndis.rar, and then, if it can be identified as a network device, then you can try to switch back to normal mode.

eKretz:
Sounds like someone started the modding but didn't get it done right. Do some reading here:

https://www.eevblog.com/forum/thermal-imaging/flir-e4-thermal-imaging-camera-teardown/

tmbinc:
(Nice deal though!)

Does it enumerate at all? ("lsusb" in Linux, or device manager in Windows).

Don't panic (yet). It's possible it's just in the wrong mode.

pdev:
Thanks, No it doesn't showing up anywhere in windows but I am using windows 10 64 bit, also its in RNDIS mode and its not changing to any other mode. Going through some other pages it seems like I need windows 7 32 bit and older drivers so just setting up a virtual machine for that...will update here how it goes, hopefully windows 7 will recognize it :)

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod