Author Topic: RESOLVED - Chinese Lepton USB Board - "mediacapturefailedevent"  (Read 2034 times)

0 Members and 1 Guest are viewing this topic.

Offline Abbott242Topic starter

  • Regular Contributor
  • *
  • Posts: 56
  • Country: ca
RESOLVED - Chinese Lepton USB Board - "mediacapturefailedevent"
« on: February 19, 2023, 04:15:50 am »
Hey everybody - to add to my ever growing collection of broken thermal cameras, I now have a lepton 3.5 (bought new in packaging) that has been sitting on my desk in it's spi backboard for a year. I decided to upgrade it to a UVC camera backboard - so bought this (https://www.aliexpress.us/item/2251832719855068.html?) chinese one, "minipt2" which arrived yesterday. It seems very similar to this: https://www.flircameras.com/rhp-lep-vpc-if.htm. My windows 10 PC recognizes that a camera is plugged in, but throws the error "mediacapturefailedevent" whenever I try to turn on the camera. The lepton has yet to try and move the shutter or anything. (I've removed the shutter for most of the tests however, as one of the support legs broke). Has anybody seen this error code before? I've tried restarting, updating my computer, updating the drivers for the lepton, etc. Nothing has changed it. My normal usb webcam works just fine.

Best,

Abbott242
« Last Edit: February 19, 2023, 05:38:57 am by Abbott242 »
 

Offline Abbott242Topic starter

  • Regular Contributor
  • *
  • Posts: 56
  • Country: ca
Re: Chinese Lepton USB Board - "mediacapturefailedevent"
« Reply #1 on: February 19, 2023, 04:51:14 am »
Downloaded the FLIR Lepton application v1.3.2 to test, it recognizes the board as PureThermal (fw:v1.0.0) but no video. Says, "Exception of type 'Lepton+UnknownError' was thrown".
 

Offline Abbott242Topic starter

  • Regular Contributor
  • *
  • Posts: 56
  • Country: ca
Re: Chinese Lepton USB Board - "mediacapturefailedevent"
« Reply #2 on: February 19, 2023, 05:38:40 am »
Update - turns out that the core wasn't fully seated. Thank goodness it was that easy of a fix - just goes to show that even simple mistakes happen, and it's important to check every step when debugging. Can now confirm that:
a) This board works and is much, much cheaper than the actual purethermal.
b) Coming from 50/25Hz, 8.7Hz is simply painful to look at, if useable
c) The Tiny1-C gives much better imagery, and really just outclasses the lepton. The BAE SCC500L is also waaayyy better for the same resolution. But hey, thermal is thermal!

Obligatory selfie attached.
 

Offline Silicium81

  • Regular Contributor
  • *
  • Posts: 74
  • Country: fr
    • Technical forum
Re: RESOLVED - Chinese Lepton USB Board - "mediacapturefailedevent"
« Reply #3 on: March 08, 2023, 01:13:22 pm »
I also bought this interface board to use my lepton core from my failing flir one gen 2.
It works very well!
Thank you for the information !
Electronic engineer with a passion for mechanics
https://vae-tech.forumactif.org/
 
The following users thanked this post: Abbott242

Offline Silicium81

  • Regular Contributor
  • *
  • Posts: 74
  • Country: fr
    • Technical forum
Re: RESOLVED - Chinese Lepton USB Board - "mediacapturefailedevent"
« Reply #4 on: February 23, 2024, 09:37:22 am »
This little module works very well when connected to the USB port of a computer running Windows. It is seen as a basic USB camera.
Do you know if there is an application capable of watching video on an Android smartphone by connecting to the USB port? I tested some applications intended for cameras
usb (endoscope) without success...
This small module with USB output would make it very easy to create a thermal camera for a smartphone and even without a radiometric display it would be very useful!
Electronic engineer with a passion for mechanics
https://vae-tech.forumactif.org/
 

Offline Silicium81

  • Regular Contributor
  • *
  • Posts: 74
  • Country: fr
    • Technical forum
Re: RESOLVED - Chinese Lepton USB Board - "mediacapturefailedevent"
« Reply #5 on: February 23, 2024, 11:15:58 am »
I answer myself!
Finally I managed to display the video stream on my smartphone running Android 14!
I used the UVC_camera app by configuring it as follows:
https://play.google.com/store/apps/details?id=humer.uvc_camera
ALT_SETTING:2
MaxPacketSize:962
FormatIndex:1
Video format:YUY2
FrameIndex:1
ImageWidth:160
ImageHeight:120
FrameInterval:1111111
PacketsPerRequest:1
ACTIVE_URBS:1
LibUsb Support: false
Electronic engineer with a passion for mechanics
https://vae-tech.forumactif.org/
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf