Poll

Has the hackabiliy of the E4 made you buy one :  

Yes, I was already looking at the competition at a similar price, but the hack swung it to E4
240 (26.5%)
Yes, I'd not considered buying a TIC before, but 320x240 resolution at this price justifies it (as either tool or toy!)
425 (46.9%)
Yes, I was going to buy an E5/6/8 class of unit but will now get the E4
43 (4.7%)
No, but am looking out for a cheap i3 to hack
41 (4.5%)
Not yet, but probably will if now that a closed-box hack becomes is possible
158 (17.4%)

Total Members Voted: 748

Author Topic: Flir E4 Thermal imaging camera teardown  (Read 2647738 times)

0 Members and 1 Guest are viewing this topic.

Offline Yeiquiro

  • Newbie
  • Posts: 3
  • Country: pa
  • Country: pa
Re: Flir E4 Thermal imaging camera teardown
« Reply #8550 on: August 13, 2019, 12:03:21 am »
Hi Joe, you know how they solved your saved camera, I am going through the same with mine if I can help, I appreciate it
 

Offline likuidphreon

  • Contributor
  • Posts: 8
  • Country: us
  • Country: us
Re: Flir E4 Thermal imaging camera teardown
« Reply #8551 on: August 23, 2019, 03:53:06 am »
So my camera was firmware 1.2L, software 2.8.
I put the camera in RNDIS mode and then realized I would need to downgrade to 2.3 software. I tried the link posted and it was dead.
So I installed the latest version of Flir Tools and saw there was a software update to 3.16, a known hackable version based on my reading.
I installed it and rebooted the camera. Everything seems fine, EXCEPT that I cannot connect to it via FTP. If I set the Flir RNDIS network adapter to an IP of 192.168.0.2, I can ping it, but I cannot live connect in Flir Tools. I get the error "CAMERA_RTREE_CONNECT ERROR" in the Log window.
When trying to run a FIF to remove RNDIS I get "RESPONSE_TIMEOUT" in FlirInstallNet

Thoughts?
« Last Edit: August 23, 2019, 04:02:31 am by likuidphreon »
 

Online Miek

  • Contributor
  • Posts: 18
  • Country: gb
  • Country: gb
Re: Flir E4 Thermal imaging camera teardown
« Reply #8552 on: August 27, 2019, 11:09:38 am »
I had a bit of trouble finding all the right information for an older firmware, so I thought I'd just document what worked for me while it's fresh.

Camera info:
Model: E4 1.1L
Serial: 6392 1xxx
Software (initially): 1.22.0

I upgraded to the latest software 3.16.0 using FLIR Tools.

The secret menu (hold right for 10s in camera info menu) comes up but changing USB mode would never apply, so instead I used Flirinstallnet.exe and Set_RNDIS_Permanent.fif to enable RNDIS mode.

The camera came up with IP 192.168.250.2 (not 192.168.0.2) and I backed up everything over FTP.

For generating the new conf.cfc lots of posts suggested the cfccfg_V2.py script, but that did not work for me on 1.1 firmware (MSX broke, suggesting the conf was bad). I needed to use the older ftool which I got from here: https://www.eevblog.com/forum/testgear/flir-e4-thermal-imaging-camera-teardown/?action=dlattach;attach=84664 . I'm on linux so I just built it from the source in that zip after renaming a few files for case sensitivity: `g++ -o ftool *.cpp`.

I used `ftool -d <backup/conf.cfc> conf.cfg` to decrypt my backed up config and retreive the two SUID values & the ID to add at the end of the config. I also built the CRC03 tool and generated that, but I don't think that was actually necessary with the patched DLL used later. With the conf.cfg from the basic package below, I used `ftool -e conf.cfg conf.cfc 0x1234 0x5678` (replacing with SUID values gained earlier).

I could then follow the instructions from the basic package at: https://www.eevblog.com/forum/thermal-imaging/flir-e4-wifi-resolution-and-menu-hack-thread/msg1397359/#msg1397359 but replacing the dll with the one here: https://www.eevblog.com/forum/thermal-imaging/flir-e4-wifi-resolution-and-menu-hack-thread/msg2252082/#msg2252082. I also modified the conf.cfg revision entry text from '2.0' to '1.1' but, again, not sure if that was necessary.

Many thanks to everyone involved, and I hope this helps someone!

 

Offline emd802

  • Contributor
  • Posts: 5
  • Country: us
  • Country: us
Re: Flir E4 Thermal imaging camera teardown
« Reply #8553 on: August 29, 2019, 03:16:30 pm »
Has anyone had a 'Runtime Error 9 Subscript Out of Range' when trying to run the BFIC Wrapper for batch FLIR conversions?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf