Products > Thermal Imaging

FLIR E4 Wifi Resolution and Menu Hack Thread

<< < (227/233) > >>

Syntaximus:
Hello all!

My friend is in need of a thermal imager and he linked me to this forum and asked if I could implement this modification.  It looks like this thread continues from a 300-page thread and I was just wondering...where do I start?  Has anyone written a guide along the way?  About how much learning time would it take for a beginner to start to understand the concepts you're putting to use here?

Thanks a ton and take care!

Psi:
The guide/instructions are in the zip files you download.
You just need to read the posts carefully to make sure you are downloading the right files for the E4 fw version you have.

If you're doing the hack for someone else, make sure they know that there are no guarantees. You could make a mistake and brick their E4.

And they need to be aware of the limitations, they cannot do an official firmware upgrade on the unit after the hack or it will brick it. To do an official upgrade the hack must be removed and the camera restored to stock first. That is why it's critical to backup everything before replacing files.

windtalker:
Hi everyone, newbie hobbyist here. I recently got a E4 (e63900 t198547)that won't boot pass the logo screen, that is screen is blank after flir logo. It seems like a hack gone wrong

I am using a windows XP vm, and can connect through FTP to 192.168.0.2 after connect through usb on the first time (anonymous/NcFTP@, flir/3vlig says bad username/password)

after install Flir drivers and flir tools:
upon usb connection: ThermaCAM connect 3" \\IRCAM4007\Images information = 1326 Logon failure: unknown username or bad password
flir tools: import: no sources was found

FLIrInstallNet's :
get versions: Product identification is simply "Qx", OsImgKit 18.1.20, application up status is "DOWN", all the rest is blank (sw combination, appkit,bootloader, confkit, prodkit and serial number)
Check installation: CRC Appkit failed

I have downloaded all files through FTP:
/FlashBFS/system most files were last modified in DEC 2014, with common_dll.dll, bootlogo_legal.bmp rainhc.pal. lava.pal and arctic.pal last modified in OCT 2018
/FlashFS/System/appcore.d/config.d/conf.cfc is last modified in OCT 2018 as well
There is also an thermal image with 320x240 resolution in FlashIFS/DCIM/FLIR_100 with a timestamp of OCT 2018 20 minutes BEFORE last modified timestamp of common_dll.dll and conf.cfc



I have uploaded the entire files directory (zipped) here with timestamp preserved https://drive.google.com/file/d/1wuA9_M5r9ACP5AUs2fRWBD9n1PhAw4vV/view?usp=sharing

I have read through a lot of the posts but I never found a similar situation. Is this one doomed? What other diagnostics process should I try first?

Thank you all !

Bud:
Replace common_dll on the camera with the attached version and see if the camera boots.

windtalker:
Yes thank you it booted! however the crosshair is not seen, and when i pressed the trigger to take a picture it says "application appcore.exe encountered a serious error and must shutdown". after that videofeed is still live in the background, but buttons stopped working, except long press to power down. FTPed in, image is not actually saved

thermaCAM connect 3 still report same error "\\IRCAM4007\Images information = 1326 Logon failure: unknown username or bad password"

attached is the error message image

edit: camera information from settings
E4 1.1L
software 2.3.0

Navigation

[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Thanking...
Go to full version