Products > Thermal Imaging

FLIR E4 Wifi Resolution and Menu Hack Thread

<< < (259/260) > >>

Good morning everyone!

Brand new user here and registered specifically to send my thanks and notes for this hack.

First of all, thanks to Bud in particular for making this possible (and all others who have contributed a few bits and pieces) and.. it's fantastic that this is still going on after.. 10+ years, eh? (-:

I've purchased a SH E5-XT (no Wifi) which arrived with 2.0L and 3.12 firmware.

I've read most of the posts (probably ~40 pages) to figure out what needs to be done.. and the following was applied:

- upgraded to v3.16 (some new menu options were enabled: sport / temperature)
- applied the resolution hack only (4 lines in .cfc and the v3.16 .dll) - all good - new thermal resolution showed up
- applied the Basic pkg
- applied the Advanced pkg


The E5 is liberated - it has all the goodies that is supposed to have - cheers!

*Update* - more attachments added to show other modes as well.

FLIR logo also has vanished from the bottom left (not a biggie).

Let me know if there is something that can be done about the limited area measurement.


P.S. I'll add the xmas pack as well / other changes - just very pleased with the results so far and.. again.. big thanks to Bud/Fraser/all others who made this possible. Camera will be used primarily for electrical work around my cave.

Hi all,

I bought an E4 Wifi, model E4 2.0L, firmware 3.16.0 and successfully hacked it using the steps Sebastion (and Bud et al) laid out with the files attached to his post. Given it's the wifi model I was able to simplify the process and not use the FLIR Tools or FLIR Drivers. I connected the device to my home wifi network and used WinSCP to connect using FTP. I used a handy free iPhone app called Fing to scan my home network and give me the IP address of the FLIR. Backed up all the files on the device first. As Sebastian mentioned, a number of them wouldn't transfer. Followed Sebastian's steps for decrypting, modifying, and re-encrypting the conf.cfc. Renamed the common DLL on the device so I could copy over the new one. Renamed the old conf.cfc on the device so I could copy over the new one. Restarted the device and good to go. I was able to do it all on my Windows 11 desktop. Just had to download and install Python 2.7 as a prerequisite.

Thanks all!

EDIT: This morning I tried to add the Santa mods and it bricked the device. Had to install the FLIR Tools and Drivers after all to get into recovery. I will say that the FLIRInstallerNet didn't work right out of the gate, but as I was sitting there it asked if I wanted to update my FLIR Tools version from 4.x to 5.x. Went through the update install and it had me reboot my computer. Once I got back in it worked and I was able to run the RNDIS FIF. Back in business after reverting the files.

You should Not leave the old .cfc config file on the device. Make a backup of it and delete it.

Hi folks, i promise to read all that thread and not just search'n'google the stuff as i did before.
But the question which is in my head is (one big & multiline question):
• to successfully hack we need to switch flir to rndis mode.
• mk2 versions (solid D-pad) doesn't have service menu.

Could they be hacked?

I wanna buy Exx or ExxBX, there are some good offers for mk2 models.

This thread is for E4. Anything else is one's guess.


[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod