Author Topic: FLIR E6 Thermal Video access on FLIR Tools on Windows 10  (Read 336 times)

0 Members and 1 Guest are viewing this topic.

Offline eri0o

  • Contributor
  • Posts: 14
  • Country: br
FLIR E6 Thermal Video access on FLIR Tools on Windows 10
« on: May 13, 2020, 01:53:52 am »
Hello,

Has anyone ever been able to access thermal data streaming with FLIR Tools for the E6 camera? I have software 3.16.0 on the E6xt 2.1L (with Wi-Fi) and be through USB or Wi-Fi, I can't access the camera to stream the video. I have the camera visible on the Instruments tab but clicking the lighting bolt icon does nothing. I tried disabling the camera Wi-Fi to access it only through USB but it also didn't work.

If I click the update on the flir tools menu it crashes.

I also tried to access the camera using the demo app of the Atlas SDK and it's not visible there.

On FLIR customer help, it suggests that this camera support stopped on Windows 7. I tried to download and install the USB driver of it but Windows 10 is saying the "The folder doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it's designed to work with Windows for x64-based systems".

https://flir.custhelp.com/app/answers/detail/a_id/987/~/usb-connection-problem-with-flir-ex-series-%28e4%2C-e5%2C-e6-and-e8%29-cameras

I have everything from the Atlas dependencias installed from here: https://flir.custhelp.com/app/answers/detail/a_id/3050

Still, looking on Windows Device Manager, the camera appears as FLIR USB Video, but it is using drivers from Microsoft.

Edit:

Telnet to it's IP gave me the following:
FLIR Command Line Interpreter
Version 0.4.3 running on WinCE 6.0

Copyright (C) 1994-1998 Tim Norman and others.
Copyright (C) 1998-2009 ReactOS Team
Copyright (C) 2004-2009 FLIR Systems AB.
« Last Edit: May 13, 2020, 11:53:38 am by eri0o »
 

Offline eri0o

  • Contributor
  • Posts: 14
  • Country: br
Re: FLIR E6 Thermal Video access on FLIR Tools on Windows 10
« Reply #1 on: May 13, 2020, 02:25:45 pm »
OK, so I had the latest FLIR Atlas SDK 6 installed. I uninstalled everything from FLIR and installed only FLIR Tools. Then both FLIR Tools and the software I had built with the Atlas SDK now work. I reproduced I two different Windows 10 PCs. So now I am using a different third PC that HAS the Atlas SDK installed and developing using only the Atlas SDK emulator and testing on the different PC without the Atlas SDK installed. Apparently there's something wrong being shipped with the Atlas SDK that conflicts with FLIR Tools, at least for my Flir E6.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf