Author Topic: Flir E4 "There is no memory card" error  (Read 11037 times)

0 Members and 1 Guest are viewing this topic.

Online Fraser

  • Super Contributor
  • ***
  • Posts: 10598
  • Country: gb
Re: Flir E4 "There is no memory card" error
« Reply #50 on: May 23, 2018, 05:41:15 pm »
Thanks for the update.

The change to HW2.0 indicates FLIR replaced the main board at the very least. Interesting as, to me, it suggests your original board had a fault or strange issue rather than just needing a simple firmware rebuild.

« Last Edit: May 23, 2018, 10:43:07 pm by Fraser »
Cogito, ergo sum

Offline CapnBry

  • Contributor
  • Posts: 24
  • Country: us
Re: Flir E4 "There is no memory card" error
« Reply #51 on: October 26, 2020, 05:33:43 pm »
Windows reports FAT32 as the filesystem type.
Try checking the camera flash drive boot sector using a disk editor. I have attached a screenshot that I made used Active Disk Editor
I knew you were a genius, but you sir are a double genius. I reformatted my FLIR camera by mistake when trying to copy files off it to a USB stick. There was no way to take IR photos any more, complaining "There is no memory card". I tried formatting in every possible filesystem available, recreating all the files that were supposed to be there, nothing worked. I felt as dumb as the time I `dd if=/dev/zero of=/dev/hda bs=512 count=1` to wipe a floppy disk MBR but immediately panicked when the command returned instantly-- I had just wiped the MBR of my system hard drive while it was running. That was 20 years ago.

Back on topic, I used your image and copied the bytes exactly into my FLIR E4's boot sector. Saved, pulled the USB out, as well as the FLIR battery pack. Powered it up... worked like a charm!

Looks like when you try to format it in Windows, it creates a system boot sector, a Master Boot Record. That contains partition tables and boot code, but the FAT32 boot sector is completely different. You'd never get this 512 bytes using Windows format utility, which creates a partition and then formats that. The FLIR E4 does not want all that junk and has no use for partitions, so you just need the FAT32 boot sector Bud supplied.

I have this directory structure:
Code: [Select]
\100_FLIR\FLIR0001.jpg <-- first image taken to see if it works after editing the boot sector
\FLIRCurr.dir (yup two of them. this one was created first, probably when saving the above image)
\flir.db (hidden)
\FLIRVers.rsc (hidden)
So looks like it put the first image in the wrong place, and wasn't fully booted or something.

I'm on Software 2.3.0, with an original E4 1.1L hardware. Thank you thank you thank you!
« Last Edit: October 26, 2020, 05:47:45 pm by CapnBry »

Offline Bud

  • Super Contributor
  • ***
  • Posts: 4769
  • Country: ca
Re: Flir E4 "There is no memory card" error
« Reply #52 on: October 26, 2020, 05:40:38 pm »
Gosh, i even do not remember making that post, but i am glad it helped you  ;D
Facebook-free life and Rigol-free shack.
The following users thanked this post: CapnBry

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo