Products > Thermal Imaging

Fluke VT04 repair


Hello guys!

I got partially working fluke vt04 camera and here is my problem.

When I turned vt04 on and went to the Menu, the list items kept continuously scrolling (like I hod a button). I disassembled and tried to replace the UP/DOWN buttos as well as the FAR button hoping that they simply stuck. But it haven't helped..

Then I measured the voltages on tact buttons and I got this (image 1). Those traces that lead to 10k resistors [1] and [2] were at 3.23/3.25v and they go from MCU pins, while on the other side of tact button was 3.7v as it should be. Other "good" buttons have 0v on the 10k resistor high side that goes to MCU. So where this 3.23/3.25 is coming from?

I tried to raise two MCU legs to make sure they are not the cause and even with that the menu was still scrolling and the voltages on push buttons that led to MCU still were 3.x+ volts.

So I started to look further and found that two through-holes that led from MCU pins to the other side were corroded due to the leaked lition watch battery.  And this is where I stuck... I soldered two wires from the MCU side to the other side of PCB but where they should be connected to I don't know.  [1] and [2] in oval on pic

Can someone help me figure out where the corroded traces and through holes should go??

Well, I managed to fix it. I removed the small camera connector and cleaned everything underneath it. Scrapped all the residuals from leaked watch battery till I reached copper traces. Then soldered connector again and put a UF mask on pcb. So it fixed the 3.25v problem on the tact buttons to the 10k resistors.


[0] Message Index

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod