Products > Thermal Imaging

Hacked Flir E4 computer connection problems

(1/4) > >>

mtdoc:
I've had my Flir E4 - hacked to E8 + menu options for a few years now. I have not tried connecting it to my laptop (Windows 7 64bit) since I did the hack a couple of years ago - until today.

I wanted to give the Thermovision_JoeC software a go.  Long story short, after a few hours of trying I cannot get any connection.  No FTP connection with Filezilla, No telnet with putty, no connection with the original Flir Tools software and no go with the Thermovision_Joe C software.

It's not showing up under Device Manager not with an IP scan.

I've tried RNDIS mode, UVC, MDS and all combos.

I've tried 2 different USB cables.  It does show it charging via the USB cable.

Anyone with any ideas?   :-//

For my normal use, I don't need to connect it to the computer but still ....

jmaja:
I just had the same problem with the same setup, although my E4 is only a few weeks old. Check what ipconfig shows for INFRARED once you have activated RNDIS or RNDIS_UCV (allows you to see webcam live view). Mine was not able to get a sensible IP number for the PC. I had to manually set the following (through Network Sharing Center):

--- Code: ---Ethernet adapter Local Area Connection 4:

   Connection-specific DNS Suffix  . : INFRARED
   Link-local IPv6 Address . . . . . : fe80::d015:8a3:2a86:c1a9%41
   IPv4 Address. . . . . . . . . . . : 192.168.0.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.2
--- End code ---

After that you can try to ping 192.168.0.2. If that works, you should be OK.

Bud:
Try reinstalling the Flir drivers. As the last resort, find a computer or VM with WinXP (install Flir drivers). XP always worked.
There may also be a conflict with your router if it is already using 192.168.0.1. If that is the case try disconnecting the LAN cable from the computer before connecting the camera.

mtdoc:
Thanks for the suggestions.

No go with reinstalling the drivers.
No go with running it on different computers - - another with Win 7 and one running XP..
It does not show up at all when running ipconfig.
Disconnecting from all networks does not help.

It seems the computer is not seeing it at all.  |O

My main concern now is if anything goes wonky with the camera, how will I connect it to the computer to reinstall software, etc?

Another thing:  If I try to run FLIRInstallNet.exe it doesn't show up. When clicking on "scan network" I get this grammatically  incorrect error box:


Platonas:
mtdoc, try to connect to the camera using the FlirInstallNet.exe which is under the ProgramFiles\Flir System\Flir Tools\Bin.  Then load (browse) the Remove_RNDIS_permanent.fif file and press Run FIF.  The Fif file is in the folder used to hack your camera.

That should remove the permanent RNDIS.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod