Author Topic: iOS Flir One Pro no connection, green light flashing  (Read 520 times)

0 Members and 1 Guest are viewing this topic.

Offline agilato

  • Newbie
  • Posts: 2
  • Country: us
iOS Flir One Pro no connection, green light flashing
« on: July 27, 2021, 05:49:37 pm »
Got myself faulty iOS Flir One Pro, it does charges, turns on (green light blipping) but when i plug it in to the iPhone doesn't detects.

1st assumption was that lightning port assembly is damaged and i decide to play around.
Pulled port assembly from my Micro USB Android version of the Flir One Pro and used that.
Looks like device falls in to the "init-loop" green light still blinks but image starts to load for 2sec and then disconnects.

Measured voltage on D+ line and it holds 3.x V for 2-3seconds and jumps to a 0 for 2-3 seconds and loops. D- shows ~100mv.
Filter and fuses on D+ / D- are good. So i still think issue is in the lightning port assembly.

I read on eevblog that Flir 1g2 have setting in to the firmware for the port (L/U). I also found Serial port pinout for 1g2 and looks 1g3 has same header.
Haven't tried to connect to Serial yet but will try later today to see output.

Decide to ask upfront, how would i update firmware to handle Android. And may be i am missing something valuable.

Thank you.


« Last Edit: July 27, 2021, 05:51:47 pm by agilato »
A person who never made a mistake never tried anything new. Albert Einstein
 

Offline agilato

  • Newbie
  • Posts: 2
  • Country: us
Re: iOS Flir One Pro no connection, green light flashing
« Reply #1 on: July 30, 2021, 07:33:38 pm »
Based on that topic i was able to connect via Serial Port with Arduino Nano (NO TTL) via PuTTY:
https://www.eevblog.com/forum/thermal-imaging/fixing-up-a-mixmatched-flir-one/msg3166084/#msg3166084

I had older firmware and preboot menu with different environment variables names, in mine had to set "set_flashing_enable" to 1 in order to boot into the "update mode".
In /root/shared_files/connector_type.txt switched "L" (Apple) to "U" (Android) with command "echo 'U'>connector_type.txt" and after reboot "Flir One" Android app instead of looping started to crash.
Next morning i reset the phone and instead of original "Flir One" app i used "Thermal Camera" and thermal image appeared on the screen of my Samsung Galaxy S6.

Pretty much iOS to Android conversion was successful. Still interested why "Flir One" app is crashing, i think it's has something to do with my phone running older Android 7 OS.
« Last Edit: July 30, 2021, 07:35:29 pm by agilato »
A person who never made a mistake never tried anything new. Albert Einstein
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf