Author Topic: Malfunctioning seek compact  (Read 1010 times)

0 Members and 1 Guest are viewing this topic.

Offline snowphishTopic starter

  • Newbie
  • Posts: 2
  • Country: ca
Malfunctioning seek compact
« on: November 08, 2023, 04:16:49 pm »
I just bought a used Seek Compact, I know this is an older device but from what I read and saw it seemed to somewhat fit my needs for motherboard repair at a very low cost.

Here is what it does :
(that's a cold water bottle, that is definitely not changing temperature, but this loop happens regardless where I am pointing the camera)

I am assuming this isn't normal.

When I plug it in, it seems to function normally for a few seconds, then it goes into this loop (I know the clicking of the shutter is normal) of shutter activation and the temps reading go up until it clicks again.

I have a feeling this is a software bug of some sort, I installed and tested it on PC with SeekOFix and it does not fall into this cycle. The readings seem fine (screenshot attached of SeekOFix)

My plan was to use it with SeekOFix probably with a peltier for cooling too, but it would be nice to have it working standalone on a phone as well.

Now the Seek website states the old microUSB (the device I have) is not compatible with newer phones, so I tried it on a listed compatible device Samsung S7 - the app version is the same so the behavior is the same. I've tried past version APKs but none of them work at all, I think the firmware on the Seek is newer and not compatible with the older app releases.

Seems this community is the right place for information on these so if anyone has a clue what might be going on - would be much appreciated  ;D

Camera details
S/N is 1D0462C4C495
Hw v7 Th v4 TLID -1
Camera software


Offline snowphishTopic starter

  • Newbie
  • Posts: 2
  • Country: ca
Re: Malfunctioning seek compact
« Reply #1 on: November 10, 2023, 11:59:34 am »
Well, if anyone stumbles on one of these old things, I figured it out. The new app Seek released recognizes this old cam when used with micro USB  > USB-C adapter but doesn't seem to work properly with them. I went and rooted/rolled back my old S7 to android 6 to try out the old apps, the oldest app versions didn't work at all but I found out that some do work better.

Ultimately, I ended up trying all versions of the Seek app and at 2.1.7 is the last one that works fine with this older Seek Compact, even with microUSB > USB-C adapter on a newer S21 phone. Anything newer than v 2.1.7 of the app and the reading goes into a crazy loop with a lot more drift than would seem normal, basically making it kinda unusable.

with new app:
with old app:
« Last Edit: November 10, 2023, 01:44:30 pm by snowphish »

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo