Products > Thermal Imaging

Two Flir E4's stopped communicating and charging via the USB

(1/2) > >>

I have 2 E4's (Upgraded), one for me and one for my son.  Yesterday, my son stated that his E4 would not charge.  So I gave him my battery pack sohe could use it.  Then, he told me that he could not communicate with his e4 from the laptop he was using. SO I plugged mine in.  I received an error message from the laptop stating something about the driver.  Then noticed that MY E4 was not charging.  Now, neither E4's will charge or communicate with anything via USB.  I have tried different cables, computers, etc.  Rebooted everything.  Still nothing.  Any ideas?  Any help would be greatly appreciated because I know that if I send them back to Flir, it will cost a lot for repair, regardless how simple the problem.

Thanks in advance!

Have you tried a USB wall charger?

E4 works poorly with computer USB charging, use the wall charger that came with the camera.

Yes, I tried several wall chargers, three different computers as well.  Looks like the usb interface is down.  Will not charge or communicate on either E4.  |O

 So you use the supplied wall charger, do you see battery charge level going to full charge? If so, then you connect the camera to a computer with Flir software installed, what happens? What exact error you get?


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod