Products > Thermal Imaging

Uni-t UTi260B

<< < (38/38)

optotester:
Hello all,

As UT260B seems to share the same platform as C200, I developed an unlocking script that provides root access here:
https://www.eevblog.com/forum/thermal-imaging/infiray-c210-thermal-camera-review/msg4368193/#msg4368193

It might work or not as-is on the UTI260B - I tried to make it very flexible. If it does not, I will need at least one MMC backup taken from the method exposed previously. I do not have the device myself I cannot take that initial backup, but if I get one, I will be easily able to adapt the script if needed. Once we start collecting backups, it should be easy to activate UVC, restore calibration, or unbrick not booting devices.

Kr

All Seeing Eye:
If it could adjust the focal length,That's better :-+

keenox:
I also opened the UTi260B. Tip: use a small suction cap (like the ones used to remove phone screens) to remove the screen shield in order to avoid scratches instead of using tweezers. Also, don't pull hard on the face because there is a small ribbon cable that connects the buttons to the main PCB. I almost ripped mine.
I also attached a script that will enable the USB console. (thanks optotester for the initial script)
Just unzip to the SD card root, press right for 3 seconds, hold and press left.
You will see a new COM in the device manager. Connect using putty (or your preferred terminal client) with baud rate 115200.

Use ftpadmin/ftpadmin (no write rigths, safer to just look around) or root/uti160e (careful! you can mess stuff up if you don't know what you're doing.

Full dump of the 1.2.6 firmware: https://mega.nz/file/2EZXAKJC#L_ROicWxl96tmm10NZP_TM9PELJHTVqmL0C8l_ZAYGQ

Algoma:
Picked up one of these from the Nov11 sales, so far it has been excellent the first few times I've used it. Only trouble is that it doesn't charge on a USB-C charger. I've had to use the included USB-C to USB-A cable to charge it at fixed 5V

This one has a Firmware v1.2.10

After a full charge, I did hit a bug with all temperatures reading 0'C and center spot -275'C. All other general operations seemed normal. A reboot didn't fix. Then did factory reset from the menus with no change. Restarted and it froze up at EN/CN language selection on boot. Rebooted yet again and it now seems to have returned to normal operation.

Algoma:
well, it broke.. First full recharge and it showed all measurements at 0.00'C and the center point read -275'C.  Performed a full factory reset and it came back, but all readings are now 10-15'C off.

@optotester posted a link to access the calibration mode.
https://www.eevblog.com/forum/thermal-imaging/infiray-c210-thermal-camera-review/msg4336675/#msg4336675

Looks like the High Gain calibration was reset, and the NTC value is showing 0.0'C.

Bit of trial and error to recalibrate it properly I've sucessfully worked out a general procedure to restore its operation to within expected values.
Cal Reset to wipe out calibration values of the current gain
RMVC_RESET seems to reset the thermal camera and reload a calibration state.
RMVC_CAL needs to be pointed at a blackbody emitter with a stable thermal gradient.  I used a heavy black coated frypan that had been warmed at slighty above room temperature and allowed to thermally settle to an even color when viewed through the camera. This function evens out variantions and hotspots in the sensor's image and sets the baseline for the other calibrations at 10'C and 120'C
Generally Point the center target an a spot of the desired temperature Cal point. I used Icewater and my SDM3055 Multimeter to aquire the proper 10'C temperature, and then a frypan heated to  generally 120'C as my baseline targets. Any simple IR thermometer should give some target references to work with. The UTi260B is also measuring values at its center point you can use to search the area for a cal point you want to try. An open fridge or freezer is a source to find a target for the 10'C point.

New Recal commits the values to the sensor, Cal Save and Switch Gain switches to Low Gain calibration. These seemed correct and were left alone. Power Cycle to verify the results.

Without a proper calibration source, a few resets of calbration I was able to chart out the responses each time referenced to generally stable values: melting Ice (0'C), Room Temperature (21'C), Body Temperature (36.8'C) and Boiling water(100'C).. With a bit charting the values and responses I was able to tune the 10'C and 120'C values to acheive proper calibration well within original specs. In my case 23 and 96 were the results that gave proper reponse. I think image contrast and accuracy actually improved, it shows body temperature exactly on value at 36.8'C.

Now that NTC value is still showing 0.0'C so I think the internal temperature compensation broke with the first recharge, so the calibration will only be true for the room temperature I calibrated it at, with the tool properly warmed to an operating state.

Any ideas where that NTC might be located in there? .. I'm' thinking its within the IR camera module, or on shutter and not easily replaceable.

Navigation

[0] Message Index

[*] Previous page

There was an error while thanking
Thanking...
Go to full version