Products > Thermal Imaging

Uni-t UTi260B

<< < (60/62) > >>


--- Quote from: Veteran68 on July 19, 2023, 11:22:18 pm ---
--- Quote from: ausdim on July 19, 2023, 10:09:22 pm ---
--- Quote from: Veteran68 ---Thanks, that's a relief then. Unfortunately I looked at but didn't write down the exact version or backup my firmware first (I wasn't aware of the fw backup process until I came here looking for solutions AFTER I bricked it).  :palm:  I want to say mine might have been something like 1.2.32 but I can't swear to it. I did download someone's stock fw backup that was posted in the backup thread though, so if I can get the UART to work then I'll try that.

The upgrade process did, thankfully, save my calibration data to a file on the SD Card, which I have since backed up. I assume if I apply someone else's firmware image, I'll have to restore this calibration file. I'll cross that bridge when I get to it.

--- End quote ---

My firmware is 1.2.28 and I can’t find any newer of series “1.” Anything from series “2.” It will not work, at least two of them that I try 2.0.20 and 2.0.22 that’s why I create that simple script in the backup thread you mention, to collect some firmwares here so we make a database since we cannot find nothing on the net.

Any way if you want my firmware I will pass it to you.

I changed only UTi260B_Thermal and device is normal again no any calibration data since I get the same as old, every time you run upgrade menu that .ini file is written to your as card.

--- End quote ---
Are we sure the 690B and 260B have the same firmware version numbers? Why would Banggood be providing people this version for 690B devices without asking what version you have to start with? There would typically be a warning in the instructions they provide to check current firmware version. I will reply back to them that I'm hearing that v1 firmware cannot be upgraded with v2 firmware and see what they say.

Let me go through the backup thread and check the versions that I've downloaded, then try to get the UART connection going.

--- End quote ---

Where can I download the firmware 1.2.28 or last stable version for uti260b? I'm currently on stock 1.1.22 (never updated the fw).

First of of all big thanks for Fraser and other for sharing their experience with this thermal cam.

I got the 690B variant less than a year ago and that sucker died on me.

I paid about 300 European dollhairs, and it got used 3 times. So it ended up costing 100 Euros for each use.
Lesson learnt again - stay away from chintsy home gamer tools. There is a reason why you never see Uni-Ts used by professionals here in north Europe.

After not using it for several months I tried to turn it on. There was just a brief flash of backlight and then it turned black.
I thought it was just an empty battery and quickly hooked it up to a USB-c charger (for Lenovo laptop).
After charging for a while it remained completely dead. I tried Banggood custormer service, but all I got was a "sorry your crap is out of warranty :)"

So I'll have to try my luck repairing it meself.

Next I stumbled on this thread and was able to gut the camera. I used a suction cup and a little heat to remote the plastic screen protector.
Inside visually everything seemed to be ok. No trace of smoke. I went to ebay and ordered some replacement P-channel mosfets.

I also checked the internal battery on the terminals and it is dead, 0 Volts. Hmm.
There seems to be a built in protector circuit in the battery under the plastic wrapping, so I went ahead and carefully removed some plastic wrapping on top of the positive and negative strips connecting the cell to the protector circuit and it measured 3.05 Volts, so the cell was not dead after all. I tried to charge the battery with a regular li-ion charger, but it could not detect the battery. I put some small jumper wire to the exposed strips and connected the chareger directly to the cell. I charged the cell to 3.8 volts, and hoped the protector circuit would wake up. The terminals still show 0 Volts. Maybe the protector circuit died.

Booting up:
So the battery was dead, maybe that was the reason for the unit not booting, so next I hooked a lab power to the battery connector on the main PCB and started experimenting.

First I set the lab power to 3.3V (simulating an almost empty battery) and wanted to see if it powers up. Well, partial success. I get now the Uni-t splash screen and initializing gets stucked at 69%. Current draw is about 350 mA. Power button does not work. after couple of tries the boot gets stuck at 70%.
I raise the voltage a little and the unit gets stuck at 70% for a very long time (several minutes) and then goes to 100% and gets stuck. Intresting. I do a power reset a few times and power button does not work. Unit gets stuck at 100%. Maybe I need to raise the voltage more.
Now the boot seem a little faster and on the first try it booted almost up and did not get stuck at 100%. Instead it got stuck on the main camera view screen with "Initializing". Current draw is about 400mA. Power button has now some effect, it switches off the screen, but current draw remains over 300mA, which is not good. I repeat the same a few times. Power cycling seems to be the only way to stop the unit from drawing high current. Maybe I raise the voltage a little.
This would resemble a full battery. This time the unit boots fully up and starts the thermal camera, wohoo! Now also the power button shuts down the unit properly and current draw goes from 400 mA to zero. I notice the date on the screen is from 2022, so RTC battery probably also died.

What happened:
I am suspecting I had an empty battery, then hooked the unit up to a powerful charger and burned something inside. The unit still somehow works, but requires a higher voltage, and would not work unless the battery was fully charged. I am suspecting the unit has a design flaw or a FW bug causing the unit not to always shut down properly, especially with lower supply voltage, and this may then finalize your battery.

I will continue the repair some day when I have time.

Thanks for your comment, it's interesting to know that the battery's BMS is integrated into thelse. These BMS are not very qualitative in general.
I've also had a 690b thermal camera for a year and a half. It works very well if i use it occasionally and recharge it regularly, but no more often than every 4 months and only if the battery starts to run down (2 bars on the charge indicator).


--- Quote from: Kellopeli on September 26, 2023, 05:38:33 am ---Lesson learnt again - stay away from chintsy home gamer tools. There is a reason why you never see Uni-Ts used by professionals here in north Europe.

--- End quote ---

While I wouldn't consider most Uni-T gear as "professional," I would certainly put it in the mid and sometimes upper range of hobby gear. Far from what I'll call "chintsy" compared to the sea of cheaper no-name brands. For most hobby or even prosumer users, their gear will do fine. For it's price range, the 260B/690B camera is one of the best on the market in terms of features. Alex from Northridge Fix said it compared very favorably to his $6K FLIR camera (although one should probably take his review with healthy dose of salt since he sells the 260B in his store). But when you look at raw specs, it's pretty hard to find a comparable performing camera in this price range. If you want close to the same features in something from a brand like FLIR or Fluke, you're close to adding another zero to the cost.

My 690B has been fantastic. My only issue with it was self-inflicted, attempting to flash a firmware that clearly isn't compatible (although we had to figure that out the hard way). Thankfully their design is such to make it relatively easy to recover when this happens.

--- Quote from: Kellopeli on September 26, 2023, 05:38:33 am ---I tried Banggood custormer service, but all I got was a "sorry your crap is out of warranty :)"

--- End quote ---

That's odd, because mine was almost certainly out of warranty yet they were very helpful with me. Well, at least their attitude was helpful and they were quick to provide me a firmware to try, unfortunately it was the same incompatible version. They said they would take the firmware issue up with Uni-T but never got back to me. After I fixed mine myself, I didn't follow up. But they were far more helpful than I expected them to be.

--- Quote from: Kellopeli on September 26, 2023, 05:38:33 am ---What happened:
I am suspecting I had an empty battery, then hooked the unit up to a powerful charger and burned something inside.

--- End quote ---

This is doubtful. It uses a standard USB charging circuit, so a charger isn't going to deliver any more power than the device draws and only up to the negotiated charger limit (unless you're using a non-compliant charger). I haven't tried a USB power meter while charging it (now I'm curious and will do so) but as I recall it comes with a USB-C to USB-A cable so it's not even PD, which means it's charging at standard 5V 1-2A max. I'd say more than likely there was a battery defect or other component defect in yours that led to your failure.

Which ZnSe lens you can recommend for PCB thermal analysis?


[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod