Products > Vintage Computing

2732 and TL866II Plus

(1/3) > >>

Hello there,

I use the well know TL866II Plus programmer for my old sbc computers... I use the up to date Xgecu software.

I have programmed a lot of 2716 memory with the help of an external 25VDC power supply connected to pin 21 (pin of course disconnected from the programmer).
I also set programming pulse duration to the maximum value...
I have to disable "pin detect" and "verify" before programming but this is normal... After programming I disconnect the 25 VDC supply, reconnect the pin 21 to the programmer and made a separate verification which is always successful.

Now today I have try to do the same with 3 different 2732 eproms... No way to got a result. The programming progress bar even not appear !!!
Of course on 2732 eprom Vpp is applied to pin 20.

I have check both datasheet of 2716 and 2732 and don't understand why this work for one and not for the other.

I have noticed that some Xgecu software set a voltage level to 6.5 V instead of 5 V for some 2732 model eprom but both settings give the same result.

I have not found any log file or something like that for founding the problem...
The programmer read 2732 eprom without error.

Some other users report success in the same situation so any advice will be helpful.


I think 2716 has a dedicated VPP pin - but 2732 has VPP and OE is on the same pin.

And VPP on 2732 needs a specific timing sequence for programming. But on 2716 you can probably get away with keeping it at a fixed level.

You are perfectly right !

I dont see this evidence reading the datasheet.

Thanks a lot.

Hello there !

Okay some works about 2732 programming with TL866II Plus.

I have quickly made a hack based on the joined schematics...

Now VPP on the eprom follow the timing give by VPP pin of the programmer but at a level adapted to the eprom (usually 25 VCC).

This hack works for 2716. Pin detect works, reading eprom works, programming and verifying eprom works !

Scope show that 25 V timing on the eprom pin follow the VPP programmer pin at the correct level !

But no success for 2732. Pin detect pass, reading works but programming fail !
At programming start scope show that eprom VPP pin start to switch between 0 V and ~25V then everything stop and I got the fail message...

I have try with a very short usb cable to avoid voltage drop and 3 eprom gave the same result so I dont think that the problem is the eprom themselves...

Any help will be appreciated !



A try with minipro and a pulse duration of 50000 ┬Ás give the same result...
Switch to usb 3 port also didn't change anything...


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod