Author Topic: IBM 5150 Restoration  (Read 35282 times)

0 Members and 1 Guest are viewing this topic.

Offline simmiv

  • Contributor
  • Posts: 13
Re: IBM 5150 Restoration
« Reply #25 on: May 11, 2015, 10:29:03 pm »
Hi,
If you are still getting the memory errors, it's hard to continue with booting the floppy as it may fail..  I see you were getting 1054 201 error at bootup..  The service manual map to follow is this one..  http://www.minuszerodegrees.net/hms/HMS%20-%206280087%20-%20Maps%20-%200200.pdf  It seems to take you the check the switch settings..
Rgds,
Simmi
 

Offline simmiv

  • Contributor
  • Posts: 13
Re: IBM 5150 Restoration
« Reply #26 on: May 11, 2015, 10:44:27 pm »
Hi, I also noticed that you have memory chips in all the rows, thus you should have 64kb of RAM..  The bootup says 28,363 bytes, which might indicate the MB switch settings are set to 32kb and the last two rows aren't switched on. 
Simmi
 

Offline TheEPROM9

  • Regular Contributor
  • *
  • Posts: 161
  • Country: gb
  • I have a Kali USB and I'm not afraid to use it!
    • EPROM 9 Home
Re: IBM 5150 Restoration
« Reply #27 on: September 01, 2018, 11:39:01 am »
TheEPROM9 (The Husky Hunter Collectors inc.)
Knowledge should be sheared freely to those who want it.
https://www.flickr.com/photos/146977913@N06/ https://www.youtube.com/channel/UC4vOnjz1G-aM8LddSbrK1Vg https://www.facebook.com/groups/118910608126229/
 

Offline joeqsmith

  • Super Contributor
  • ***
  • Posts: 5241
  • Country: us
Re: IBM 5150 Restoration
« Reply #28 on: September 01, 2018, 12:44:15 pm »
Good to see you have not given up on the old PC.  Have a look at the first board I show and see if it looks like the one you are asking about.

https://www.eevblog.com/forum/vintage-computing/old-ibm-compatible-pcxtat-cards/
How electrically robust is your meter?? https://www.youtube.com/channel/UCsK99WXk9VhcghnAauTBsbg
 
The following users thanked this post: TheEPROM9

Offline TheEPROM9

  • Regular Contributor
  • *
  • Posts: 161
  • Country: gb
  • I have a Kali USB and I'm not afraid to use it!
    • EPROM 9 Home
Re: IBM 5150 Restoration
« Reply #29 on: September 09, 2018, 08:20:47 am »
I try & work on it when I get time. Just lead a bussy life these days.
TheEPROM9 (The Husky Hunter Collectors inc.)
Knowledge should be sheared freely to those who want it.
https://www.flickr.com/photos/146977913@N06/ https://www.youtube.com/channel/UC4vOnjz1G-aM8LddSbrK1Vg https://www.facebook.com/groups/118910608126229/
 

Offline chris_leyson

  • Super Contributor
  • ***
  • Posts: 1210
  • Country: wales
Re: IBM 5150 Restoration
« Reply #30 on: September 09, 2018, 09:32:23 am »
Good luck with the restoration. Wow holy crap that brings back memories. Not a bad machine for it's day and well hackable and a lot of software was still wrtten in assembler. I bought an IBM PC for something crazy like £900 with a CGA monitor back in the day. Stuffed a Hercules graphics card in and used a Hanterex green screen monitor with a long persistance phosphor, P39 maybe. Now you're talking hi-res graphics. Popped a hard disk controller in and a 6Mbyte hard drive so now I've nearly got an XT. Put some half height floppy drives in and punch a hole in the sleve now I've got 720k floppires, overclock it and it's nearly an IBM AT. A few years later and I managed to fit an IBM AT mother board into the chassis. Those were days.

I think back then the 110W power supply was a classic Royer converter or more accurately a Jensen converter which was a more efficient improvement on the Royer. The saturating base drive transformer was smaller and wired in parallel with the main transformer. Also, avoid the IBM MDA display adaptor, the horizontal drive wasn't free running and needed a video signal to work properly, the other gotcha was the two screws hidden under a label which held the CRT PCB in place, oops.

The 5161 expasion card with the crazy 68 way connector, damn, should have kept it, isn't hindsight wonderfull. Also  passed up an opportunity on original ring bound service manuals  :palm:
« Last Edit: September 09, 2018, 10:00:33 am by chris_leyson »
 

Offline TheEPROM9

  • Regular Contributor
  • *
  • Posts: 161
  • Country: gb
  • I have a Kali USB and I'm not afraid to use it!
    • EPROM 9 Home
Re: IBM 5150 Restoration
« Reply #31 on: September 23, 2018, 04:39:51 am »
Thanks for all the links guys =-)

I am curently working on part 8. I have fixed the RAM issues & now have 64KB of working RAM. Just need to sort out a working boot disk. Lubed the drives today.
TheEPROM9 (The Husky Hunter Collectors inc.)
Knowledge should be sheared freely to those who want it.
https://www.flickr.com/photos/146977913@N06/ https://www.youtube.com/channel/UC4vOnjz1G-aM8LddSbrK1Vg https://www.facebook.com/groups/118910608126229/
 

Offline TheEPROM9

  • Regular Contributor
  • *
  • Posts: 161
  • Country: gb
  • I have a Kali USB and I'm not afraid to use it!
    • EPROM 9 Home
Re: IBM 5150 Restoration
« Reply #32 on: October 07, 2018, 07:54:04 am »
Thanks for all the links guys =-)

I am curently working on part 8. I have fixed the RAM issues & now have 64KB of working RAM. Just need to sort out a working boot disk. Lubed the drives today.

Oh yes, disks arrived on Friday =-)
TheEPROM9 (The Husky Hunter Collectors inc.)
Knowledge should be sheared freely to those who want it.
https://www.flickr.com/photos/146977913@N06/ https://www.youtube.com/channel/UC4vOnjz1G-aM8LddSbrK1Vg https://www.facebook.com/groups/118910608126229/
 

Offline TheEPROM9

  • Regular Contributor
  • *
  • Posts: 161
  • Country: gb
  • I have a Kali USB and I'm not afraid to use it!
    • EPROM 9 Home
Re: IBM 5150 Restoration
« Reply #33 on: October 09, 2018, 07:29:03 am »
It is now time for Part 8. =-)


We finaly have it booting from IBM DOS 3.3 =-)
TheEPROM9 (The Husky Hunter Collectors inc.)
Knowledge should be sheared freely to those who want it.
https://www.flickr.com/photos/146977913@N06/ https://www.youtube.com/channel/UC4vOnjz1G-aM8LddSbrK1Vg https://www.facebook.com/groups/118910608126229/
 

Offline pamperchu

  • Contributor
  • Posts: 34
  • Country: us
    • YouTube Page
Re: IBM 5150 Restoration
« Reply #34 on: October 09, 2018, 12:50:38 pm »
If you ever need parts hit me up.
 
The following users thanked this post: TheEPROM9

Offline TheEPROM9

  • Regular Contributor
  • *
  • Posts: 161
  • Country: gb
  • I have a Kali USB and I'm not afraid to use it!
    • EPROM 9 Home
Re: IBM 5150 Restoration
« Reply #35 on: October 10, 2018, 06:03:50 am »
Do you have a CGA for it?

If so, try this demo:

I have it fully working, came with a CGA card. Challenge acepted. Need to up the RAM & probaly add some king of HDD, the original ones might be to far gone to use. So a solid state solution would be best there.
TheEPROM9 (The Husky Hunter Collectors inc.)
Knowledge should be sheared freely to those who want it.
https://www.flickr.com/photos/146977913@N06/ https://www.youtube.com/channel/UC4vOnjz1G-aM8LddSbrK1Vg https://www.facebook.com/groups/118910608126229/
 

Offline w9gb

  • Contributor
  • Posts: 9
  • Country: us
Re: IBM 5150 Restoration
« Reply #36 on: October 20, 2018, 12:15:02 pm »
Now I feel old. 
The IBM PC model 5150 (5-slot) was a year old,
when I entered graduate college (IBM-XT with 8-slots was current).  IBM AT released in 1984, BUT was on allocation due to high demand.  RAM was scarce, so IBM used “pickyback ICs” (128k) for the first version of 6 MHz motherboards.

AST 6-Pack with additional RAM, serial (RS-232) port, parallel port, and clock/calendar that IBM excluded was very popular add-on card.  AST used the TI 1488/1489 line driver/receiver for second serial port.

The engineering, computer science, and business colleges built computer lab (summer 1983) using IBM PCs (DOS 2.0) with 3Com Ethernet cards (ThinNet, 10-Base-2). 
In 1983, this Ethernet lab at Univ. of Iowa had an Altos 986 (8086, 10 MHz) with an Ethernet card designed by 3Com server as network’s file server.  It used 3Com’s file server software under Xenix 3.0 (eventually marketed by 3Com as 3Server).
https://blog.fosketts.net/2007/06/25/storage-history-the-3server/

Worked summer and weekends for local IBM PC dealer.
« Last Edit: October 20, 2018, 12:21:43 pm by w9gb »
 

Online eugenenine

  • Frequent Contributor
  • **
  • Posts: 748
  • Country: us
Re: IBM 5150 Restoration
« Reply #37 on: October 23, 2018, 11:13:29 am »
I had a 5150PC and an XT before I moved about 10 years ago.  They were both in the pile of things I have to leave behind.
 

Offline TheEPROM9

  • Regular Contributor
  • *
  • Posts: 161
  • Country: gb
  • I have a Kali USB and I'm not afraid to use it!
    • EPROM 9 Home
Re: IBM 5150 Restoration
« Reply #38 on: November 06, 2018, 09:11:51 am »
I had a 5150PC and an XT before I moved about 10 years ago.  They were both in the pile of things I have to leave behind.

That's sad =-(
TheEPROM9 (The Husky Hunter Collectors inc.)
Knowledge should be sheared freely to those who want it.
https://www.flickr.com/photos/146977913@N06/ https://www.youtube.com/channel/UC4vOnjz1G-aM8LddSbrK1Vg https://www.facebook.com/groups/118910608126229/
 

Offline nad007007

  • Contributor
  • Banned!
  • Posts: 19
  • Country: nz
Re: IBM 5150 Restoration
« Reply #39 on: March 08, 2019, 08:48:53 pm »
yes dam it
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf